Closed Bug 1006306 Opened 6 years ago Closed 6 years ago

Implement BT on/off and BluetoothManager

Categories

(Firefox OS Graveyard :: Bluetooth, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: ben.tian, Unassigned)

References

Details

(Whiteboard: [webbt-api])

* BT on/off: https://wiki.mozilla.org/B2G/Bluetooth/WebBluetooth-v2/BluetoothAdapter
Properties
  readonly attribute BluetoothAdapterState state;
  readonly attribute DOMString address;
  readonly attribute DOMString name;
  readonly attribute boolean discoverable;
  readonly attribute boolean discovering;
Event handler
  attribute EventHandler onattributechanged;
Methods
  Promise<void> enable();
  Promise<void> disable();
BluetoothAdapterState
BluetoothAdapterAttribute

* BluetoothManager: https://wiki.mozilla.org/B2G/Bluetooth/WebBluetooth-v2/BluetoothManager
Depends on: webbt-api-onoff
Depends on: webbt-api-manager
Blocks: 892172
No longer blocks: 892172
QA Contact: joliu
Assignee: nobody → joliu
QA Contact: joliu
Oops, I took the wrong bug, sorry!
Assignee: joliu → nobody
Close this bug and move webidl changes into bug 1006309.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: webbt-api-manager
Closed the wrong bug. Reopen it.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Depends on: webbt-test-manager
No longer depends on: webbt-test-manager
Resolve this bug since dependent 2 bugs are fixed.
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.