View Source window title same as browser window title? or use URL?

VERIFIED DUPLICATE of bug 60892

Status

SeaMonkey
UI Design
P3
normal
VERIFIED DUPLICATE of bug 60892
19 years ago
a year ago

People

(Reporter: Crysgem, Assigned: Doron Rosenberg (IBM))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Apprunner M8 Build, ID 1999071417

This likeness effectively causes two such minimized Mozilla windows to be
indistinguishable, at sight of taskbar.

Suggested format for "View Source" window title:
"mozilla.org - Markup View - Mozilla"

Updated

19 years ago
Assignee: don → law
Target Milestone: M11

Comment 1

19 years ago
Bill, is this a bug for you or for Matiskella?
I've asked in bug #11519 why we can't view page source inline rather than
opening a new window.  If done, this would render this might render the problem
irrelevant, although I guess you might still want to change the title.

Updated

19 years ago
Status: NEW → ASSIGNED

Comment 3

19 years ago
I'll take this.  If I can't get it right using the existing window-titling code,
then it might go to David. Bug #11519 is another thing entirely (and I haven't
run across that one yet).

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 4

19 years ago
View source title is now:
    Source for: <document title> - Mozilla

I think it should be <url> instead of <document title> but the view-source
parser insists on the latter.

Updated

19 years ago
QA Contact: beppe → claudius

Updated

19 years ago
Status: RESOLVED → REOPENED

Comment 5

19 years ago
I'm going to have to reopen this just to be careful. I suspect that what
I'm seeing is really Bug 14947 but law you'd have to look at that maybe to
be sure. At the very least, that bug is blocking verification of this one.

Updated

19 years ago
Resolution: FIXED → ---

Comment 6

19 years ago
Clearing FIXED resolution due to reopen of this bug.

Updated

19 years ago
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → FIXED

Comment 7

19 years ago
Sure seems to be working OK for me.  Claudius, can you try again and explain
what you're seeing in a little more detail?

Updated

19 years ago
Status: RESOLVED → REOPENED

Comment 8

19 years ago
my comments on 09/27/1999 refer to bug 14947 which involved the page title disappearing.
That bug is still open. I've reopened this bug because I'm looking at a comm. opt build dated
1999102008 and the View Source Boiler plate is not working correctly.
One one occasion I got "Mozilla - Mozilla"  among other wacky results. It looks like there is more
going on here.

Updated

19 years ago
Resolution: FIXED → ---

Comment 9

19 years ago
Clearing FIXED resolution due to reopen.

Updated

19 years ago
Target Milestone: M11 → M12

Comment 10

19 years ago
The wackiness might be due to the problem reported under bug #17500.  I'm moving
this out since it isn't a high enough priority to take me off the things I'm
working on at the moment.

Updated

19 years ago
Target Milestone: M12 → M13

Comment 11

19 years ago
Moving to M13.

Updated

19 years ago
Target Milestone: M13 → M15

Comment 12

19 years ago
Not required for beta 1.

Comment 13

19 years ago
Move to M16 for now ...
Target Milestone: M15 → M16

Updated

18 years ago
Target Milestone: M16 → M18

Comment 14

18 years ago
Move to M21 target milestone.
Target Milestone: M18 → M21
will take this off of claudius' hands, if you doesn't mind :-).
QA Contact: claudius → sairuh
pardon the spam: moving view source bugs into xp apps: gui component.
Component: XP Apps → XP Apps: GUI Features

Comment 17

18 years ago
*** Bug 60380 has been marked as a duplicate of this bug. ***
Consensus seems to be I dup'ed this in 60380, so this is a 
reconfirmation that this problem exists in 1114 on both Win32 and OS/2.

My problem is if you View -> Page Source, the URL of the page your 
viewing the source of doesn't appear in the window's Titlebar.

Under 4.61, it puts the URL in the Titlebar.

This current behaviour can be very confusing if you have several View 
Source browser windows open, since you won't know which one to really 
go to.

Where does this bug sit?  
Is this the same problem?  
Can we change the summary of this problem to make it a little more 
clear, or is this a symptom of a larger problem?
Can we also update the target for this bug?  I'd hate to wait for M21.  
:-)
seems like this bug is asking whether we should put either the <title> or url in
the titlebar of the view source window --is that right? if so, i'd vote to
implement the 4.x version, ie, use the url, which would distinguish the source
window from the browser window. imho. :)

however, i noticed that that the titlebar is empty [save for "Netscape"] --i'll
file a bug on that [i couldn't find an existing one].

also, am clearing the milestone here --bill/blake, could you guesstimate when
this could be implemented? thx!
Severity: minor → normal
OS: Windows 98 → All
Hardware: PC → All
Summary: View Source window title same as browser window title → View Source window title same as browser window title? or use URL?
Target Milestone: M21 → ---
filed bug 60892 for the "empty" titlebar bug.
Depends on: 60892
Netscape nav triage team: per Alec Flett's pre-triage recommendation, this 
bug is nsbeta1-.
Keywords: nsbeta1-

Comment 22

18 years ago
Marking nsbeta1- bugs as future to get off the radar
Target Milestone: --- → Future

Comment 23

17 years ago
-> Doron, but this might need to run through UI Design first.
Assignee: law → doronr
Status: REOPENED → NEW
(Assignee)

Comment 24

17 years ago
the wierd thing is, in viewSource.xul, the title is defined using text from
viewsource.dtd, but it never gets changed. So, I could set it in js.
(Assignee)

Comment 25

17 years ago
dupe (of a fixed bug)

*** This bug has been marked as a duplicate of 60892 ***
Status: NEW → RESOLVED
Last Resolved: 19 years ago17 years ago
Resolution: --- → DUPLICATE
oki.
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite

Updated

10 years ago
Component: XP Apps: GUI Features → UI Design
You need to log in before you can comment on or make changes to this bug.