bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

View source window should have title/URL in title bar

VERIFIED FIXED in mozilla0.9.1

Status

SeaMonkey
UI Design
P3
major
VERIFIED FIXED
18 years ago
10 years ago

People

(Reporter: sairuh (rarely reading bugmail), Assigned: rbs)

Tracking

({helpwanted})

Trunk
mozilla0.9.1
helpwanted
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
...other than "Netscape" [or, "Mozilla" for mozilla bits]. spun this off while
reading bug 10066. tested using trunk bits [2000.11.21.08 on linux and winnt,
2000.11.20.08 on mac].

1. open a webpage, eg, http://mozilla.org/
2. open the source window [ctrl/cmd+U, or View > Page Source].
3. look at the titlebar of the source window.

expected: should see the url displayed in the titlebar as "Netscape: Source of
http://mozilla.org/" [imho, see bug 10066 for more discussion].

actual result: instead the titlebar just says "Netscape".
(Reporter)

Updated

18 years ago
Blocks: 10066
(Reporter)

Comment 1

18 years ago
i keep thinking this *used* to work...then again, if it never has, feel free to
remove the regression kw. thx!
Keywords: 4xp, regression, ui
Netscape nav triage team: per Alec Flett's pre-triage recommendation, this 
bug is nsbeta1-.
Keywords: nsbeta1-

Comment 3

18 years ago
This is very annoying on Windows when having many "View Source" windows open,
and all those are minimized..
(Reporter)

Updated

18 years ago
Keywords: helpwanted

Updated

18 years ago
Keywords: ui
Summary: view source window displays no info in titlebar... → View source window should have title/URL in title bar

Comment 4

18 years ago
*** Bug 70196 has been marked as a duplicate of this bug. ***
*** Bug 52068 has been marked as a duplicate of this bug. ***

Comment 6

18 years ago
Marking nsbeta1- bugs as future to get off the radar
Target Milestone: --- → Future
(Reporter)

Updated

18 years ago
Keywords: nsCatFood

Comment 7

18 years ago
If "Netscape" or "Mozilla" is included in the title, it should be at the end of 
the title, like it is for normal browser windows.  (Netscape 4 does it that way 
for view-source, too.)

Comment 8

18 years ago
we can do this in viewsource.js with document.title = foo in onLoadViewSource.
However, we would need to use a stringbundle in the js.

perhaps the title is somehow overwritten in some c++ code, as the xul properties
are set correctly in viewSource.xul
(Assignee)

Comment 9

18 years ago
Yes, it has to be set from the C++ side (or from the JS side after the document 
is loaded...) It has never worked. Anyway, there is now a fix for this sitting 
on bug 76567. Anyone want to review the proposed patch there?
Blocks: 76567
Keywords: regression
(Assignee)

Comment 10

18 years ago
Just to clarify. It used to "work" when viewsource was done in XML (because 
there is not <title> in XML and whatever was set in JS was preserved). Ever 
since the move to viewsource in HTML, the title is gone because the HTML layout 
expects a <title> in the transformed viewsource document and set it to blank if 
there is no <title>. But as I said, this should be fixed now with the patch.
nav triage: does not affect enough target users to be nscatfood. 
Keywords: nsCatFood → nsCatFood-
(Reporter)

Comment 12

18 years ago
sorry, i disagree --anyone who opens a source window will encounter this. maybe
they're/we're not the majority, but i think there are quite a few users who do
view the source. :) renominating as catfood.
Keywords: nsCatFood- → nsCatFood

Updated

17 years ago
Assignee: law → doronr
I'll do this from the javascript side once the final viewsource backend stuff
happens.  All this requires is moving the entries to js friendly .dtd's and some
stringbundle magic.
(Assignee)

Comment 14

17 years ago
Taking and targetting to m0.9.1 since I currently have the fix as part of bug 
76567. With this, viewsource will show 'Source of: url' as Nav4.x does (the 
'Source of:' is a localizable string from the viewsource.dtd files.)

As per the listed 4xp keyword, that would do job. But doronr, once I land the 
fix, feel free to take it back if there are other things you might want to add. 
Assignee: doronr → rbs
Target Milestone: Future → mozilla0.9.1
(Assignee)

Comment 15

17 years ago
Resolving as FIXED. Just landed the patch on the m0.9.1 trunk.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
(Reporter)

Comment 16

17 years ago
yay! vrfy fixed:

linux comm 2001.05.02.08
mac comm 2001.05.02.09
winNT moz 2001.05.02.12
Status: RESOLVED → VERIFIED
*** Bug 10066 has been marked as a duplicate of this bug. ***
Product: Core → Mozilla Application Suite

Updated

10 years ago
Component: XP Apps: GUI Features → UI Design
You need to log in before you can comment on or make changes to this bug.