Closed Bug 10069 Opened 21 years ago Closed 21 years ago

link does not work after maximize + unnecessary repaint

Categories

(Core :: Layout: Tables, defect, P3, major)

x86
Windows 98
defect

Tracking

()

VERIFIED DUPLICATE of bug 7522

People

(Reporter: bmeerdnk, Assigned: don)

References

()

Details

1. apprunner (gives www.mozilla.org)
2. maximize screen (left column has 1.2 cm white on the right)
3. click on 'Milestone 8'
4. screen is repainted, layout changing (left column narrower, box wider)
5. click on 'Milestone 8'
6. screen is repainted, layout changing slightly again, this time followed by
the page http://www.mozilla.org/projects/seamonkey/release-notes/

Without the Maximize (scroll down instead), 6. follows on 3. (so the link works)
Version: Mozilla M8.  Screen resolution: 1152x864
Actually, the spurious repaint is one cause of the link not working!
If the location where the click occurred still is above the link AFTER the
repaint, then the link works, else it doesn't. In my case a click on the left
part of the link works, on the right part does not.
How can the click-event get to be corrupted this way?
Status: NEW → RESOLVED
Closed: 21 years ago
Component: Browser-General → HTMLTables
Resolution: --- → DUPLICATE
This is a known bug with table reflow. When a link within a nested element
triggers an event, (i.e. :active or :hover) Mozilla incorrectly reflows tables.
The reason why the links no longer work is because they have actually moved.

*** This bug has been marked as a duplicate of 7522 ***
The program should evaluate the effect of the user interaction according to
the CURRENTLY visible layout, NOT defer this until after a repaint.
The reflow bug only serves to bring this problem to the surface.
Status: RESOLVED → VERIFIED
Verified Duplicate
You need to log in before you can comment on or make changes to this bug.