Closed Bug 7522 Opened 21 years ago Closed 20 years ago

{table-reflow} Clicking on URL dynamically resizes table cells

Categories

(Core :: Layout: Tables, defect, P2)

x86
Windows 98
defect

Tracking

()

VERIFIED WORKSFORME

People

(Reporter: icos, Assigned: karnaze)

References

()

Details

(Whiteboard: [testcase] bloviate@yahoo.com)

Attachments

(1 file)

Observed in the 1999060208 build.

On the smoketest startup page, I placed my cursor over a link so that the
Netscape hand-pointer appeared. I clicked and held, then move my mouse either up
or down to start a drag.

After moving the mouse up or down, I noticed that the webpage's tables changed
size before my eyes.

Most strange, can anyone reproduce this? last few lines i got in apprunner:

Document http://www.mozilla.org/quality/smoketests/ loaded successfully
range: 0x53af730         start: 0x4ab68a0 13,    end: 0x4ab68a0,13
    direction = 1  LEFT TO RIGHT
range: 0x53192c0         start: 0x4ab68a0 13,    end: 0x4ab68a0,13
    direction = 1  LEFT TO RIGHT
range: 0x53ad100         start: 0x4ad1030 12,    end: 0x4ad1030,12
    direction = 1  LEFT TO RIGHT
Priority: P3 → P2
Target Milestone: M7
Target Milestone: M7 → M8
Moving to M8.
I tried this on the 1999062408 win 98 build and it the table was not affected,
whatever the problem was appears to have been fixed. In the apprunner window I
did notice that when I dragged the text above did not appear in it. So it looks
as if the bug has been fixed or whatever was cauying it is gone.
Its still there, on mozilla.org.

Go to that page, and click and hold a link thats in the navigation bar (you dont
have to lift the mouse button up, just click and hold)

about the same time that the link changes from the Normal link color to the
Active Link color, the tables resize.
Summary: Starting drag on URL dynamically resizes table cells → {table-reflow} Starting drag on URL dynamically resizes table cells
Summary: {table-reflow} Starting drag on URL dynamically resizes table cells → {table-reflow} Clicking on URL dynamically resizes table cells
Whiteboard: [testcase] bloviate@yahoo.com
*** Bug 8587 has been marked as a duplicate of this bug. ***
*** Bug 9068 has been marked as a duplicate of this bug. ***
Moving to M9.
*** Bug 6954 has been marked as a duplicate of this bug. ***
*** Bug 9811 has been marked as a duplicate of this bug. ***
*** Bug 10067 has been marked as a duplicate of this bug. ***
*** Bug 10069 has been marked as a duplicate of this bug. ***
*** Bug 9291 has been marked as a duplicate of this bug. ***
*** Bug 7446 has been marked as a duplicate of this bug. ***
Status: NEW → ASSIGNED
Status: ASSIGNED → RESOLVED
Closed: 21 years ago
Resolution: --- → WORKSFORME
Marking 'worksforme' -- I think the new table code fixed this. (Note: I've only
verified this on Win98... please reopen if this is still busted on linux/mac.
Thanks.)
What "new table code"? When was it checked in?
I'll give it a run down on the latest build and let you know.
Status: RESOLVED → VERIFIED
Using 7/30 Apprunner, verifying WORKSFORME
The dragging link technique no longer works. probably because mouse input isn't 
being handled the same anymore. But I still see this bug.
Here is a good way to reproduce:
1)Load http://www.mozilla.org/
2)Click on "Windows" to begin downloading the windows nightly build.
3)Watch the tables resize.

Another way to reproduce it:
1)Load http://www.slashdot.org/
2)While the page is loading click on a link.
3)Notice the tables resize.

I'm using build 2000021509 winNT.
Status: VERIFIED → REOPENED
Resolution: WORKSFORME → ---
Target Milestone: M9 → M15
Ignore the attachment. It clearly doesn't work anymore.
This bug was for a very specific problem that was quite visible under the old
HTML pattern for the mozilla.org pages, and it has indeed been fixed. 

I also tried to duplicate your new report with the same 2000021509 build on 
win95, but I could not reproduce. 

Marking *this* bug WORKSFORME, but file a new bug if you wish, with more 
details on how to reproduce. Thanks.
Status: REOPENED → RESOLVED
Closed: 21 years ago20 years ago
Resolution: --- → WORKSFORME
Ok. I opened a new bug. it's bug 28212. marking this one verified. If you want
to look over that bug you can. Thanks.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.