Closed Bug 1007105 Opened 6 years ago Closed 6 years ago

[tarako][Special for Tamil].go into the clock, alarm clock interface date overlay with the new alarm icon

Categories

(Firefox OS Graveyard :: Gaia::Clock, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:1.3T+, b2g-v1.3T fixed, b2g-v1.4 wontfix)

RESOLVED FIXED
2.0 S2 (23may)
blocking-b2g 1.3T+
Tracking Status
b2g-v1.3T --- fixed
b2g-v1.4 --- wontfix

People

(Reporter: jingmei.zhang, Assigned: jingmei.zhang)

Details

(Whiteboard: [sprd309408])

Attachments

(5 files)

Attached image 20140506008.jpg
1.The system language settings for Tamil,enter the clock
2.alarm clock interface date overlay with the new alarm icon
see the picture in the attachment
Summary: [Special for Tamil]. go into the clock, alarm clock interface date overlay with the new alarm icon → [tarako][Special for Tamil].go into the clock, alarm clock interface date overlay with the new alarm icon
Since Tamil is one of the locales for shipping market we should fix this bug, blocking on the issue. NI'ing :doliver to see if someone from productivity can help here.
blocking-b2g: 1.3T? → 1.3T+
Flags: needinfo?(doliver)
It's quite late to work on any new layout of the elements here. Can this be addressed via abbreviations in l10n? How does it look in the day view of Calendar? I think there is less screen width available in that app than there is in Clock.
Flags: needinfo?(doliver) → needinfo?(jingmei.zhang)
Seems like a clock issue, changing component to Clock
Component: Gaia::Settings → Gaia::Clock
shrink font size to workaround.
Can you provide a shot of the full screen and some more information about how frequently this happens? Which dates are most likely to show this overlap?

The font already feels fairly small to me and I still wonder if there's a better solution with l10n abbreviation instead.
Flags: needinfo?(james.zhang)
Assignee: nobody → jingmei.zhang
Flags: needinfo?(james.zhang)
Jingmei, more information please.
Thomas and Kaizhen, Please add Tamil git repo to b2g-manifest, then you can reproduce this issue on you side.
Flags: needinfo?(ttsai)
Flags: needinfo?(kli)
I can reproduce it. This happens only when "week day" or "Month" in Tamil is long string.
For example to display "Friday, May 8" in Tamil is OK,
But it is too long to display "Monday, September 8" etc.

Jugglinmike, could you give some suggestion on this?

Omega, From UX point of veiw, is it possible to use abbrivation for it?

Thanks!
Flags: needinfo?(ofeng)
Flags: needinfo?(mike)
Flags: needinfo?(kli)
Attached image attachment1.PNG
Flags: needinfo?(jingmei.zhang)
Component: Gaia::Clock → Gaia::Settings
[Taking Mike's needinfo; he's stepped down to a peer due to time constraints.]

As per Dylan's comment 5, the font is already small as-is. If there's an abbreviation or shorter version, that would be ideal, rather than trying to shrink the font size. There are many strings throughout FxOS that would have a similar problem of excessive string length, particularly if this is a Month/Date string particular to this locale.
Flags: needinfo?(mike)
Component: Gaia::Settings → Gaia::Clock
ni? Clock UX owner Juwei.
How do you think?
(You can discuss with Wilfred. His mother tongue is Tamil.)
Flags: needinfo?(ofeng) → needinfo?(jhuang)
Attached image attachment2.PNG
(In reply to Dylan Oliver [:doliver] from comment #5)
> Can you provide a shot of the full screen and some more information about
> how frequently this happens? Which dates are most likely to show this
> overlap?
> 
> The font already feels fairly small to me and I still wonder if there's a
> better solution with l10n abbreviation instead.
the full screen shot is shown in the attachment in comment8.
1)the frequency is 100%
2)I have tired to change the font-size in the relevant css file,then the problem could be solved in tamil. but other languages which don't have the problem are changed too.
3)this is not a Gaia::Clock problem,in music module,problem are appear once more.as the picture shown in the following attachment.
4)so,could we only adjust the font-size of tamil on the whole?
Can't we wrap these strings?
(In reply to Omega Feng [:Omega] from comment #10)
> ni? Clock UX owner Juwei.
> How do you think?
> (You can discuss with Wilfred. His mother tongue is Tamil.)

Omega, Thanks!

Juwei, if you need more information you can contact and discuss with me. I am on partner site, so I can discuss with them closely.
Attached image attachment3.PNG
a similar problem caused by tamil in calendar as is shown in attachment3 [details] [diff] [review].
Echo Marcus & Dylan, an abbreviation might be the proper way to solve this problem rather than shrink the font size.
Flags: needinfo?(jhuang)
Target Milestone: --- → 2.0 S2 (23may)
Attached image clock_2_line.png
Juewi, I think this is also a possible solution for this. Is it good for UX?

iliu, This is when Month and weekday are too long, it will seperate into two lines. If this is good for UX, is it easy to make it always with two line?
Flags: needinfo?(jhuang)
Flags: needinfo?(iliu)
Kai-Zhen, this is possible to reduce the width(screen width - margin left - icon width) of div for "Day, Date". And it's easy to let it in two lines. 

Somehow, I would like to keep it in one line via abbreviation personally. Looks like UX also want to fix via abbreviation in comment 15. And comment 9 is clear to figure out the better solution for these truncated issue in different locale.
Flags: needinfo?(iliu)
Echo Ian:)
I also suggest to take abbreviation as the first priority to solve this bug. Making the header into two lines may not looks balance in UI, and it may not a long-term solution as well.

Is there any people we can contact to (such as L10N team?) and give us some advice? I'm sure other OS platform may encounter this issue as well. It would be great if we can have some advice from localization team.
Flags: needinfo?(jhuang)
ni? l10n for suggestions base on comment 18
Flags: needinfo?(ttsai) → needinfo?(l10n)
We usually don't have such problems in desktop (Firefox) while we have on Android, and the solution is usually to abbreviate the string. 

You can take a look at bug 892075 and it dependencies to see how badly truncation has been hurting us on Firefox OS. Bug 908300 is trying to find a solution for truncated headers, but that wouldn't solve any of the issues I see in the attached screenshots.

In general, UX should be designed for much longer strings, and that's not always happening. I take these screenshots are on 1.3, because I fixed at least the "All day" alignment in Calendar.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(l10n)
There's not really a general advice, for each string you'll need to have a conversation with the localizers. In this case, I suspect that's the vendor that sprd has.

One way to start would be to verify the issue on a master build with Tamil. I don't think mozilla produces one at this point, sadly.

Often, a trick is to take advantage of the precise context of the string. Like "full" instead of "all day".

hours-allday in our repo for Tamil (for 2.0) is எல்லா நாளும், that doesn't look like the string on the device.

Also, the font looks like it has issues with it's baseline data or something. Does sprd have an expert for fonts?
Some other notes:
* on master "Shuffle all" is not overlapping, it's translated as "அனைத்தையும் கலக்கு"
* to fix the issue on clock, it should possible to switch %A or %B in dateFormat to their short version (%a or %B). We have at least a couple of locales doing that
ni? James to work with localizer to abbreviate the strings
Flags: needinfo?(james.zhang)
Fixed on my side.
l10n/ta/gaia git repo

commit 16f7e637a5ae6cd5d021b3189aa9e5c7932aaa24
Author: jingmei.zhang@spreadtrum.com <jingmei.zhang@spreadtrum.com>
Date:   Fri May 16 14:01:07 2014 +0800

    Bug #309408 to modify the dateFormat as 'short' for string is too long on Tamil
    
    [bug number  ] 309408
    [root cause  ] dateFormat is 'long' and string is too long on Tamil
    [changes     ]
    [side effects]
    [self test   ] pass
    [reviewers   ]
    
    Change-Id: If46034dc81d19c2b6daa85394dc202fd8e071507

diff --git a/apps/clock/clock.properties b/apps/clock/clock.properties
index 8bdfdfa..e396f2a 100644
--- a/apps/clock/clock.properties
+++ b/apps/clock/clock.properties
@@ -38,7 +38,7 @@ never = எப்போதும் இல்லை
 vibrateOn = ஆன்
 vibrateOff = ஆஃப்
 # see http://www.cplusplus.com/reference/clibrary/ctime/strftime/
-dateFormat = %A, %B %e
+dateFormat = %a, %b %e
 countdown-lessThanAnHour = இப்போதிலிருந்து <strong>{{minutes}}</strong>க்கு அலாரம் அமைக்கப்பட்டுள்ளது.
 countdown-moreThanAnHour = இப்போதிலிருந்து {{hours}} {{minutes}}க்கு அலாரம் அமைக்கப்பட்டுள்ளது.
 countdown-moreThanADay = இப்போதிலிருந்து {{days}} {{hours}}க்கு அலாரம் அமைக்கப்பட்டுள்ளது.
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: needinfo?(james.zhang)
Resolution: --- → FIXED
Whiteboard: [sprd309408]
You need to log in before you can comment on or make changes to this bug.