Closed Bug 1007112 Opened 7 years ago Closed 6 years ago

crash in android.content.ActivityNotFoundException: No Activity found to handle Intent { act=android.intent.action.GET_CONTENT } at android.app.Instrumentation.checkStartActivityResult(Instrumentation.java)

Categories

(Firefox for Android :: Web Apps (PWAs), defect, P1)

All
Android
defect

Tracking

()

RESOLVED FIXED
Firefox 33

People

(Reporter: aaronmt, Assigned: mhaigh)

References

Details

(Keywords: crash, Whiteboard: [WebRuntime])

Crash Data

Attachments

(1 file, 1 obsolete file)

This bug was filed from the Socorro interface and is 
report bp-3f3850f7-8a0e-4fea-b966-ccc682140506.
=============================================================

android.content.ActivityNotFoundException: No Activity found to handle Intent { act=android.intent.action.GET_CONTENT }
	at android.app.Instrumentation.checkStartActivityResult(Instrumentation.java:1632)
	at android.app.Instrumentation.execStartActivity(Instrumentation.java:1424)
	at android.app.Activity.startActivityForResult(Activity.java:3424)
	at android.app.Activity.startActivityForResult(Activity.java:3385)
	at android.support.v4.app.FragmentActivity.startActivityForResult(FragmentActivity.java:839)
	at org.mozilla.gecko.GeckoActivity.startActivityForResult(GeckoActivity.java:68)
	at org.mozilla.gecko.ActivityHandlerHelper.startIntentForActivity(ActivityHandlerHelper.java:26)
	at org.mozilla.gecko.IntentHelper.handleMessage(IntentHelper.java:69)
	at org.mozilla.gecko.EventDispatcher.dispatchEvent(EventDispatcher.java:205)
	at org.mozilla.gecko.EventDispatcher.dispatchEvent(EventDispatcher.java:174)
	at org.mozilla.gecko.GeckoAppShell.handleGeckoMessage(GeckoAppShell.java:2303)
	at org.mozilla.gecko.mozglue.GeckoLoader.nativeRun(Native Method)
	at org.mozilla.gecko.mozglue.GeckoLoader.nativeRun(Native Method)
	at org.mozilla.gecko.mozglue.GeckoLoader.nativeRun(Native Method)
	at org.mozilla.gecko.GeckoAppShell.runGecko(GeckoAppShell.java:348)
	at org.mozilla.gecko.GeckoThread.run(GeckoThread.java:174)

Filing this under Web Apps as the comment suggests the user attempted to run

https://marketplace.firefox.com/app/gameboy
I for one got this time happen 2-3 times yesterday

Steps to reproduce:
1. install Gameboy from link above on Nexus 4 using firefox aurora or firefox nightly
2. launch Gameboy

expected:
1. can use an activity to choose a ROM file

actual:
1. app crashes bringing up crash reporter
Actually, I don't expect mozActivity to work on fennec yet, so I amend my comments above to say:

Expected:
1. app does not crash
Duplicate of this bug: 1008334
Priority: -- → P1
Whiteboard: [WebRuntime]
Assignee: nobody → mhaigh
The pick action was failing as no file type was specified.  If the developer has omitted this data, I've added a 'default' mime type of 'file/*'  which will show all files.
Attachment #8434957 - Flags: feedback?(myk)
Comment on attachment 8434957 [details] [diff] [review]
Add default mime type for pick action if unspecified

This seems reasonable to me, but <https://developer.mozilla.org/en-US/docs/WebAPI/Web_Activities#Firefox_for_Android_activities> says: "For security reasons, only explicitly mapped activities / intents are supported."  And the only "expected data" for the "pick" activity is "type: "image/jpeg".

So I dunno if it's ok to set the MIME type to file/* in this case.  Let's see what Wes thinks.
Attachment #8434957 - Flags: feedback?(wjohnston)
Attachment #8434957 - Flags: feedback?(myk)
Attachment #8434957 - Flags: feedback+
General approach given thumbs up from Wes but mentioned that data transfer may be an issue, which it is as with this approach we are given just a file uri, not the actual file itself.  Will open new bug on this
Attachment #8434957 - Attachment is obsolete: true
Attachment #8434957 - Flags: feedback?(wjohnston)
Attachment #8444558 - Flags: review?(myk)
Bug for file data not being returned
https://bugzilla.mozilla.org/show_bug.cgi?id=1029033
Comment on attachment 8444558 [details] [diff] [review]
Add default mime type for pick action if unspecified

Review of attachment 8444558 [details] [diff] [review]:
-----------------------------------------------------------------

(In reply to Martyn Haigh (:mhaigh) from comment #6)
> General approach given thumbs up from Wes

I'm ok with the general approach as well, but Web Activities > Firefox for Android Activities <https://developer.mozilla.org/en-US/docs/Web/API/Web_Activities#Firefox_for_Android_activities> claims, "for security reasons, only explicitly mapped activities / intents are supported," and that the "pick" activity only expects "image/jpeg".

So if the MozActivity doesn't specify a MIME type, then we should either set the type to "image/jpeg" or call MozActivity.onerror.


> but mentioned that data transfer
> may be an issue, which it is as with this approach we are given just a file
> uri, not the actual file itself.  Will open new bug on this

Sounds good, we can tackle that issue separately.
Attachment #8444558 - Flags: review?(myk) → review-
Comment on attachment 8444558 [details] [diff] [review]
Add default mime type for pick action if unspecified

Erm, in another bug, wesj told me that the wiki page is just outdated, and webapps are now allowed to pick */*.  So this is fine after all.
Attachment #8444558 - Flags: review- → review+
Keywords: checkin-needed
https://hg.mozilla.org/integration/fx-team/rev/6d74858661ae
Keywords: checkin-needed
Whiteboard: [WebRuntime] → [WebRuntime][fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/6d74858661ae
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [WebRuntime][fixed-in-fx-team] → [WebRuntime]
Target Milestone: --- → Firefox 33
You need to log in before you can comment on or make changes to this bug.