Closed Bug 100722 Opened 19 years ago Closed 19 years ago

crash if I do insert character (from dialog) after close Composer window

Categories

(SeaMonkey :: Composer, defect)

defect
Not set
critical

Tracking

(Not tracked)

VERIFIED FIXED
mozilla0.9.5

People

(Reporter: glazov, Assigned: cmanske)

References

Details

(Keywords: crash)

Attachments

(1 file)

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.4) Gecko/20010913
BuildID:    2001091323

When I choose in Composer menu Insert->Characters and Symbols and close
Composer, then "Insert Character" window stay open. Press Insert button, and
crash-h-h.

Reproducible: Always
Steps to Reproduce:
1. Open Composer Window
2. Choose Insert->Characters and Symbols from menu
3. Close Composer
4. Press Insert button
*** Bug 100780 has been marked as a duplicate of this bug. ***
OS: Linux → All
Hardware: PC → All
the actual crash is in libimglib2.so, but this might be dup of some "child
window should be destroyed when parent is destroyed" bug..
TB35655751H windows2000
resolving as new for now. was testing with a current CVS, linux. Non-debug.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: crash
Severity: normal → critical
-->cmanske
Assignee: syd → cmanske
Target Milestone: --- → mozilla0.9.5
The Insert Character dialog should be closed after the last Composer window
is closed.
Status: NEW → ASSIGNED
Keywords: patch, review
Whiteboard: FIX IN HAND need r=, sr=
r=syd
Attachment #51564 - Flags: review+
Whiteboard: FIX IN HAND need r=, sr= → FIX IN HAND need sr=
Comment on attachment 51564 [details] [diff] [review]
Fix: Must check if enumerated 'tempWindow' is the Insert Character dialog!

sr=kin@netscape.com
Attachment #51564 - Flags: superreview+
Keywords: review
Whiteboard: FIX IN HAND need sr= → FIX IN HAND, reviewed
Whiteboard: FIX IN HAND, reviewed → reviewed
checked in
Status: ASSIGNED → RESOLVED
Closed: 19 years ago
Resolution: --- → FIXED
Whiteboard: reviewed
Verified Fixed in 10-03 Trunk Build
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.