Hide titlebar-placeholder when not draw in titlebar

RESOLVED FIXED in Thunderbird 32.0

Status

defect
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: Paenglab, Assigned: Paenglab)

Tracking

unspecified
Thunderbird 32.0
All
macOS
Bug Flags:
in-testsuite -

Thunderbird Tracking Flags

(thunderbird_esr3132+ fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
Bug 768516 introduced the possibility to draw into the titlebar under OS X. When this is enabled one time and later disabled again, the tabbar has still the spaces at the start and end.
(Assignee)

Updated

5 years ago
Blocks: 768516
(Assignee)

Comment 1

5 years ago
This patch adds the same rule we have already on Windows.
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #8418846 - Flags: review?(josiah)
Comment on attachment 8418846 [details] [diff] [review]
hideTitlebar-placeholder.patch

Review of attachment 8418846 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks, looks good.
Attachment #8418846 - Flags: review?(josiah) → review+
(Assignee)

Updated

5 years ago
Keywords: checkin-needed
https://hg.mozilla.org/comm-central/rev/75cacce22b79
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 32.0
(Assignee)

Comment 4

5 years ago
Comment on attachment 8418846 [details] [diff] [review]
hideTitlebar-placeholder.patch

[Approval Request Comment]
Regression caused by (bug #): 768516
User impact if declined: when user switches back to "not draw in titlebar" will have on both sides of the tabbar unused space.
Testing completed (on c-c, etc.): in c-c and the same code is in Windows theme since long time.
Risk to taking this patch (and alternatives if risky): small, only CSS change.
Attachment #8418846 - Flags: approval-comm-aurora?
Attachment #8418846 - Flags: approval-comm-aurora? → approval-comm-aurora+
Comment on attachment 8418846 [details] [diff] [review]
hideTitlebar-placeholder.patch

Looks like we missed landing this. Flagging for esr.
Attachment #8418846 - Flags: approval-comm-aurora+ → approval-comm-esr31?
Attachment #8418846 - Flags: approval-comm-esr31? → approval-comm-esr31+
(Assignee)

Updated

4 years ago
Flags: in-testsuite-
You need to log in before you can comment on or make changes to this bug.