libpurple XPCOM protocol commands leak into JS protocols

RESOLVED WORKSFORME

Status

defect
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: qheaden, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
If a JavaScript based implementation of a chat protocol is enabled, and it overrides a libbpurple implementation of that same protocol, the available commands from the libpurple implementation are still available when using the JavaScript implementation.

Most of the time this is okay, but some JS protocols, such as JS-Yahoo, have been cleaned up from confusing, unused, or unnecessary commands, such as the /join command found in the libpurple Yahoo code which was removed from JS-Yahoo.

libpurple protocol commands should not appear at all in the JS implementation of a protocol.
Blocks: 955574

Comment 1

5 years ago
I can't reproduce this with the current nightly.

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME

Comment 2

5 years ago
I believe I fixed this in bug 955360.
I don't see how that patch would have fixed this.
You need to log in before you can comment on or make changes to this bug.