Status

defect
RESOLVED FIXED
5 years ago
4 months ago

People

(Reporter: qheaden, Assigned: qheaden)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Assignee)

Description

5 years ago
*** Original post on bio 2135 at 2013-08-28 01:54:00 UTC ***

JS Yahoo is currently in the main source tree, but it is turned off by default. Once the plug-in is seen as feature complete and stable enough for public use, it should be enabled by default, taking the place of the libpurple Yahoo plugin.
(Assignee)

Comment 1

5 years ago
Posted patch Patch 1Splinter Review
*** Original post on bio 2135 as attmnt 2807 at 2013-08-30 17:59:00 UTC was without comment, so any subsequent comment numbers will be shifted ***
Attachment #8354577 - Flags: review?(clokep)
(Assignee)

Updated

5 years ago
Assignee: nobody → qheaden
Status: NEW → ASSIGNED

Comment 2

5 years ago
Comment on attachment 8354577 [details] [diff] [review]
Patch 1

*** Original change on bio 2135 attmnt 2807 at 2013-09-03 10:33:38 UTC ***

Stealing this review :)
Attachment #8354577 - Flags: review?(clokep) → review+

Updated

5 years ago
Whiteboard: [checkin-needed]
*** Original post on bio 2135 at 2013-09-03 10:36:28 UTC ***

I was purposefully leaving this open so that we wouldn't lose this bug when we want to check it in.

Removing checkin-needed whiteboard since we DON'T want to check this in until it's clear we want to enable it by default. I'm still waiting for Quentin to come put blockers on this bug saying what's necessary for this to be enabled by default.
Whiteboard: [checkin-needed]

Comment 4

5 years ago
Comment on attachment 8354577 [details] [diff] [review]
Patch 1

*** Original change on bio 2135 attmnt 2807 at 2013-09-03 17:03:43 UTC was without comment, so any subsequent comment numbers will be shifted ***
Attachment #8354577 - Flags: review+

Updated

5 years ago
Depends on: 955526
Comment on attachment 8354577 [details] [diff] [review]
Patch 1

*** Original change on bio 2135 attmnt 2807 at 2013-09-03 18:03:21 UTC ***

This looks fine, but let's get the blockers done before checking this in.
Attachment #8354577 - Flags: review+

Updated

5 years ago
Depends on: 955528, 955522
Depends on: 955644
Depends on: 1000469
Depends on: 1007239

Updated

5 years ago
Depends on: 976177

Updated

5 years ago
Depends on: 955508

Updated

5 years ago
Depends on: 955616

Updated

5 years ago
Depends on: 955571
We need to also enable this for Thunderbird:
http://mxr.mozilla.org/comm-central/source/chat/protocols/yahoo/moz.build#6 (needs to be removed)
http://mxr.mozilla.org/comm-central/source/im/installer/package-manifest.in#229 (needs to be added to mail/installer/package-manifest.in)

And tested, of course.
I have no idea who actually needs to review this (since it's touching mail/installer), but Quentin should look over it first. I tested this briefly, I could connect my account and receive messages.
Attachment #8478748 - Flags: review?(qheaden)
(Assignee)

Comment 8

5 years ago
Comment on attachment 8478748 [details] [diff] [review]
Enable for TB v1

So sorry for the late review. I finally found time to build Thunderbird, and it finally built for me. :-)

JS-Yahoo seems to work well within it.
Attachment #8478748 - Flags: review?(qheaden) → review+

Updated

5 years ago
Keywords: checkin-needed

Updated

5 years ago
Keywords: checkin-needed

Updated

5 years ago
Attachment #8478748 - Flags: review?(Pidgeot18)
Attachment #8478748 - Flags: review?(Pidgeot18) → review+

Updated

5 years ago
Keywords: checkin-needed
https://hg.mozilla.org/comm-central/rev/40e9e5697656
https://hg.mozilla.org/comm-central/rev/82716d4fb208
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → 1.6
Depends on: 1118499

Updated

4 years ago
Duplicate of this bug: 877388
Does this add functionality or UI that should be tested by users? If so, what are the instructions to test?
(In reply to Wayne Mery (:wsmwk, use Needinfo for questions) from comment #11)
> Does this add functionality or UI that should be tested by users? If so,
> what are the instructions to test?

It's an extra chat protocol. Someone could connect to Yahoo! Messenger, test that they can send/receive messages. I kind of doubt we even do this with IRC/XMPP right now though.
You need to log in before you can comment on or make changes to this bug.