Closed Bug 1007560 Opened 7 years ago Closed 7 years ago

[Sora][Email] text/html messages do not have "word-wrap: break-word" in effect, so otherwise unbreakable lines of characters may trigger ridiculously zoomed-out newsletter mode. text/plain only has it applied for author-written text

Categories

(Firefox OS Graveyard :: Gaia::E-Mail, defect, P2)

defect

Tracking

(b2g-v1.3 affected, b2g-v1.3T affected, b2g-v1.4 affected, b2g-v2.0 fixed)

RESOLVED FIXED
2.0 S2 (23may)
Tracking Status
b2g-v1.3 --- affected
b2g-v1.3T --- affected
b2g-v1.4 --- affected
b2g-v2.0 --- fixed

People

(Reporter: sync-1, Assigned: asuth)

References

Details

Attachments

(7 files)

Mozilla Build ID: 20140422024003  FFOS 1.3
 
 DEFECT DESCRIPTION:  [Email]Display will exceed when receive a long suject mail(some character)
  REPRODUCING PROCEDURES:
  1,open Email --> add an email account successfully
  2,choose an email(send from web email client on PC) with long suject, open
    ,display exceed --> K01
  3,choose an email(send from web email client on PC) with long content,open
    ,the content font too small to see --> KO2
 
  1.1 also have this problem.
 
  EXPECTED BEHAVIOUR:
  Subject can line feed automatically.
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
 
  REPRODUCING RATE: 5/5
Attached image long content
Attached image A LONG SUBJECT
I looked into this while trying to determine how this was related to bug 957157.  I think I have a simple fix.  Patch and example screenshots coming up.

Note that this may slightly increase the chance of a message with external or embedded images without explicit sizing information initially being detected as not wanting newsletter mode, but then wanting it after we display the images.  (But we fail to transition to newsletter mode or don't do it automatically or something like that.)  That bug is bug 828717.
Assignee: nobody → bugmail
Status: NEW → ASSIGNED
See Also: → 957157
Summary: [Sora][Email]Display will exceed when receive a long suject mail(some character) → [Sora][Email] text/html messages do not have "word-wrap: break-word" in effect, so otherwise unbreakable lines of characters may trigger ridiculously zoomed-out newsletter mode. text/plain only has it applied for author-written text
Here's the patch.  Note that I also make the change I discuss in bug 957157 comment 1 about causing the breaking rule to apply to *all* different content types for text/plain stuff.  (Quoted, not quoted, etc. etc.)  In general this should only affect ASCII <hr>-equivalent stuff since all other line-breaking heuristics would already be in effect.

Also note that this only affects cases where overflow is happening.  word-break is another knob that would impact things when there is no overflow; we are not changing that.
Attachment #8419987 - Flags: review?(jrburke)
Attachment #8419987 - Flags: review?(jrburke) → review+
landed in master:
https://github.com/mozilla-b2g/gaia/pull/19100
https://github.com/mozilla-b2g/gaia/commit/5c28006682b42c10c0165cfac04f174097f75ba3
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.0 S2 (23may)
Issue still occurs in latest 1.4 Flame build

Result: Long unbroken lines of text in email (like a long URL) are zoomed out to the point where they are unreadable if they are the only content in body of message

Environmental Variables:
Device: Flame 1.4
Build ID: 20140620000201
Gaia: 3419a1f68aaf64a0688685bce42d4173b6125597
Gecko: d9c755c8055f
Version: 30.0 (1.4) 
Firmware Version: v121-2
Correct, the fix for this is only on master, and the tracking flags indicate the "affected" branches go back to 1.3. This bug would need a blocking-b2g flag approved for example, 1.4+ to land on the 1.4 branch.
You need to log in before you can comment on or make changes to this bug.