Closed Bug 1008082 Opened 6 years ago Closed 2 years ago

Set keyboard frame size forcely instead of 100%

Categories

(Firefox OS Graveyard :: Gaia::System::Input Mgmt, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: alive, Unassigned)

References

(Blocks 1 open bug)

Details

See bug 1003870.
If we don't set the element width but use default 100%, when keyboard is not foreground it will rotate with the system to landscape if we are unlocking the screen orientation.

But the problem is when we try to set the height to the keyboard frame, keyboard app will see resize and thinks its in landscape mode so it resize again.

This is wrong, it should use screen.mozOrientation instead of guess.
> This is wrong, it should use screen.mozOrientation instead of guess.
The suggestion would be implemented with the dependent bug.
Thanks.
Depends on: 1079161
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.