Closed Bug 1008178 Opened 6 years ago Closed 2 years ago

Intermittently, mouse-over on personas doesn't preview the themes

Categories

(Toolkit :: Add-ons Manager, defect)

30 Branch
defect
Not set

Tracking

()

RESOLVED INACTIVE
Tracking Status
firefox32 --- affected
firefox34 --- affected
firefox36 --- affected

People

(Reporter: petruta.rasa, Unassigned)

References

Details

Attachments

(1 file)

Reproducible on:
- Firefox 30 beta 3 - 20140508121358
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:30.0) Gecko/20100101 Firefox/30.0
- latest Aurora 31.0a2
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:31.0) Gecko/20100101 Firefox/31.0
- latest Nightly 32.0a1 - 20140508030203
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:32.0) Gecko/20100101 Firefox/32.0

Steps to reproduce:
1. Start Firefox with a clean profile
2. Go to about:addons - Get Add-ons tab
3. Hover the mouse over the themes displayed in Featured Themes list
4. Open some of the themes to see their details page
5. Hover to preview the theme in the browser

Expected results:
The themes can be previewed either from Feature Themes section or from theme's details page.

Actual results:
Intermittently, nothing happens when the themes are hovered.
Installing several themes and restarting the browser may do the trick. Also installing a complete theme and then adding a normal theme may work.

The issue is intermittent, but I tried to find the regression range considering that the Nightly builds downloaded with mozregression are opened in clean profiles. This are my results, but I'm not sure how reliable they are:

Last good revision: 9f8233fcce1d (2013-10-25)
First bad revision: ef3f5669b53e (2013-10-26)
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=9f8233fcce1d&tochange=ef3f5669b53e

Note: The issue also reproduces on Ubuntu 13.10 32-bit and Mac OSX 10.8.5
Component: Theme → Add-ons Manager
Product: Firefox → Toolkit
Attached image gif10.gif
More reliable steps for this issue would be to cross over a persona frame (from https://addons.mozilla.org ) with mouse cursor from bottom up in order to put first in focus the Theme Name link and only then to hover over the image. 
Following these steps, this issue is constantly reproducible.

I am attaching a video recorded on Windows 8.1 32-bit where I captured this issue.
Per policy at https://wiki.mozilla.org/Bug_Triage/Projects/Bug_Handling/Bug_Husbandry#Inactive_Bugs. If this bug is not an enhancement request or a bug not present in a supported release of Firefox, then it may be reopened.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → INACTIVE
You need to log in before you can comment on or make changes to this bug.