Closed Bug 1008386 Opened 6 years ago Closed 6 years ago

Add thumbnail position to griditem loadurl probe

Categories

(Firefox for Android :: Awesomescreen, defect)

x86_64
Linux
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 32
Tracking Status
firefox31 --- verified
firefox32 --- verified

People

(Reporter: mfinkle, Unassigned)

Details

Attachments

(1 file)

We can add the position of the thumbnail that was tapped to open a URL. It might be useful for detecting usage patterns. It's pretty easy to do as well.

The "tablet" flag (bug 1007836) can be used to help us switch analyses between phone and tablet layouts.
Attachment #8420306 - Flags: review?(lucasr.at.mozilla)
Attachment #8420306 - Flags: review?(lucasr.at.mozilla) → review+
https://hg.mozilla.org/mozilla-central/rev/347544269c33
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 32
Comment on attachment 8420306 [details] [diff] [review]
uitelemetry-grid-position v0.1

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: We want to do before and after testing with telemetry
Testing completed (on m-c, etc.): Works on m-c
Risk to taking this patch (and alternatives if risky): low, but will likely need a rebased patch
String or IDL/UUID changes made by this patch: none
Attachment #8420306 - Flags: approval-mozilla-aurora?
Attachment #8420306 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
SendUIEvent: action = loadurl.1 method = griditem timestamp = 18599525 extras = 0
SendUIEvent: action = loadurl.1 method = griditem timestamp = 18599525 extras = 1
SendUIEvent: action = loadurl.1 method = griditem timestamp = 18599525 extras = 2
SendUIEvent: action = loadurl.1 method = griditem timestamp = 18599525 extras = 3
SendUIEvent: action = loadurl.1 method = griditem timestamp = 18599525 extras = 4
SendUIEvent: action = loadurl.1 method = griditem timestamp = 18599525 extras = 5

Verified as fixed in builds:
- 32.0a1 (2014-05-30);
- 31.0a2 (2014-05-30);

Device: Alcatel One Touch 8008D (Android 4.1.2)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.