Problem compiling with Xlib

RESOLVED FIXED in mozilla0.9.5

Status

SeaMonkey
Build Config
P2
major
RESOLVED FIXED
16 years ago
13 years ago

People

(Reporter: Joseph, Assigned: cls)

Tracking

Trunk
mozilla0.9.5
Sun
SunOS

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
I get the following error when compiling Mozilla with xlib:
--
rm -f libgfxxprint.so
/usr/local/lic/SUNWspro/bin/CC -I/usr/openwin/include -mt -O  -DNDEBUG -DTRIMMED
-I/usr/openwin/include -G -Qoption ld -z,muldefs -h libgfxxprint.so -o
libgfxxprint.so  xprintutil.o xprintutil_printtofile.o nsDeviceContextXP.o
nsDrawingSurfaceXlib.o nsFontMetricsXlib.o nsRenderingContextXlib.o
nsGfxFactoryXP.o nsXPrintContext.o nsRegionXlib.o nsGCCache.o   -xildoff  
-L/usr/openwin/lib -R/usr/openwin/lib -lXp -lXext -lX11 -L../../../dist/bin
-lxpcom -L../../../dist/bin -L/usr/local/src/building/moz/mozilla/dist/lib
-lplds4 -lplc4 -lnspr4 -lpthread -ldl    -lxlibrgb -L../../../dist/bin
-L../../../dist/lib -lgkgfx -L../../../dist/bin -lxpcom -L../../../dist/bin
-L/usr/local/src/building/moz/mozilla/dist/lib -lplds4 -lplc4 -lnspr4 -lpthread
-ldl   -lposix4 -lsocket -ldl -lm    
ld: fatal: file nsDrawingSurfaceXlib.o: cannot open file: No such file or directory
ld: fatal: file nsFontMetricsXlib.o: cannot open file: No such file or directory
ld: fatal: file nsRenderingContextXlib.o: cannot open file: No such file or
directory
ld: fatal: file nsRegionXlib.o: cannot open file: No such file or directory
ld: fatal: file nsGCCache.o: cannot open file: No such file or directory
ld: fatal: File processing errors. No output written to libgfxxprint.so
gmake[3]: *** [libgfxxprint.so] Error 1
gmake[3]: Leaving directory `/usr/local/src/building/moz/mozilla/gfx/src/xprint'
gmake[2]: *** [install] Error 2
gmake[2]: Leaving directory `/usr/local/src/building/moz/mozilla/gfx/src'
gmake[1]: *** [install] Error 2
gmake[1]: Leaving directory `/usr/local/src/building/moz/mozilla/gfx'
gmake: *** [install] Error 2
--
By manually running that CC line and inserting a ../xlib/ in front of the
missing object files, the CC command runs just fine, the build then can
complete, and Mozilla runs (typing this in a browser that has had this done).

I'd submit a patch, but I can't seem to grok how your linking dependencies are
done, and I'm in a hurry right now.
(Assignee)

Comment 1

16 years ago
Bah. Building in the srcdir always complicates the cool things we can do with VPATH.

Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P2
Target Milestone: --- → mozilla0.9.5
(Assignee)

Comment 2

16 years ago
Created attachment 50181 [details] [diff] [review]
override OBJ_SUFFIX and do the right thing when overridding OBJ_SUFFIX
(Assignee)

Comment 3

16 years ago
*** Bug 91954 has been marked as a duplicate of this bug. ***

Comment 4

16 years ago
Comment on attachment 50181 [details] [diff] [review]
override OBJ_SUFFIX and do the right thing when overridding OBJ_SUFFIX

r=jag
Attachment #50181 - Flags: review+
(Assignee)

Comment 5

16 years ago
Patch has been checked in.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.