[Flatfish][Marketplace] Launch after installing a packaged app doesn't work

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: cyke64, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [flatfish][TCP=breakage])

(Reporter)

Description

5 years ago
After installing a packaged app in the Marketplace application , this app can not be launched directly. The issue affects only the packaged app not the hosted apps.


B2G: 1.4.0.0-prerelease
https://marketplace.firefox.com/app/kanafire?src=search

STR : 
1. Tap "Marketplace" app
2. Tap "search" box and enter "Kanafire"
3. Install the packaged app: tap "Install"
4. When app is installed tap "launch" in app Marketplace 
    or
   Tap the "Kanafire" app on the home screen

Actual : 
1. In both cases a mini filemanager is displayed. (ISSUE)

index of app://{XXXXXX-XXXX-XXXXX-XXXXX-XXXXXX}/
Name                Size       Last    Modified
...........
...........

2. If you tap in this mini file manager the "file: index.html" line the app is launched !
 
2.
Expected : The app is running as usual.

Workaround : Reboot the first time you have installed the packaged app. To the next boot you be able to launch as usual.
(Reporter)

Updated

5 years ago
Whiteboard: [Flatfish]
This is similar to the bug I had with my GP Keon - this is fixed with 1.2 however, we should figure out why it's still happening with tablets running 1.3/1.4?
See Also: → bug 930574

Comment 2

5 years ago
I've encountered this same issue, getting the standard "index of" as if the index file isn't being located.

Updated

5 years ago
Duplicate of this bug: 1014251

Comment 4

5 years ago
the thing is once you tap the file index.html the app will launch normally every time afterward
This issue is for offline apps only. This does not affect apps that require an online connection. 
This was fixed for phone on version 1.2 but it seems to still persist on tablets especially running 1.4.
Whiteboard: [Flatfish] → [flatfish][TCP=breakage]
Blocks: 903304

Comment 6

5 years ago
I had the same issue with FxOS 1.4.
As far as I can see, the 2.1 release does not have this issue.
This issue does not reproduce on latest master, and contribution program will follow m-c branch so closing this bug.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.