Closed Bug 903304 (flatfish) Opened 6 years ago Closed 2 years ago

[Flatfish] [meta]

Categories

(Firefox OS Graveyard :: General, defect)

Other
Other
defect
Not set

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: styang, Unassigned)

References

(Depends on 1 open bug)

Details

The meta bug for Flatfish
Depends on: 903915
Depends on: 903916
Depends on: 903918
Depends on: 903920
Depends on: 903924
Depends on: 903926
Depends on: 903927
Depends on: 903929
Depends on: 903930
Depends on: 903931
Depends on: 903932
Depends on: 903933
Depends on: 903934
Depends on: 788975
Blocks: 904377
No longer blocks: 904377
Depends on: 904377
Depends on: 904509
Depends on: 904510
Depends on: 904517
Depends on: 905065
Depends on: 897900
Depends on: 905482
Depends on: 905501
Depends on: 905589
Depends on: 905957
Depends on: 905956
No longer depends on: 905589
Since orientation in large device is not ready yet, we will fire separate bugs for landscape and portrait for large device to not block the development progress
Depends on: 906538
Depends on: 906594
Blocks: 910132
Depends on: 910239
No longer blocks: 910132
Depends on: 910132
Depends on: 911668
Depends on: 911670
Depends on: 911673
Depends on: 911676
instead of software homebutton,
UX suggest to use 'scroll from device side to screen'(scroll up) gesture to back to homescreen (bug 911673)
Depends on: 911677
Depends on: 911679
Depends on: 911681
Depends on: 911684
Depends on: 911686
Depends on: 911689
Depends on: 911693
(In reply to Fred Lin [:gasolin] from comment #1)
> Since orientation in large device is not ready yet, we will fire separate
> bugs for landscape and portrait for large device to not block the
> development progress

Do they have a solution to get to the task/app switcher as well?
Depends on: 912339
Depends on: 911117
Depends on: 913895
Depends on: 913371
Depends on: 917228
Depends on: 917435
Depends on: 919455
Depends on: 911696
Depends on: 920042
please use build command `GAIA_DISTRIBUTION_DIR=distribution_tablet MOZILLA_OFFICIAL=1 GAIA_DEV_PIXELS_PER_PX=2 make production` for production settings
Depends on: 920445
Depends on: 920537
Depends on: 920551
Depends on: 920921
Depends on: 921014
Depends on:920992
Blocks: 920992
Depends on: 921327
update from UX, 

please use build command `GAIA_DISTRIBUTION_DIR=distribution_tablet MOZILLA_OFFICIAL=1 GAIA_DEV_PIXELS_PER_PX=1.5 make production` for production settings
No longer depends on: 920537
No longer blocks: 920992
Depends on: 920537, 920992
No longer depends on: 920537
Depends on: 921350
Depends on: 921912
Depends on: 921913
Depends on: 922462
Depends on: 922955
Depends on: 922957
Depends on: 922958
Depends on: 922961
Depends on: 922962
Depends on: 922964
Depends on: 922966
Depends on: 922969
Depends on: 922972
Depends on: 922973
Depends on: 911130
Depends on: 922983
Depends on: 922997
Depends on: 923001
Depends on: 921404
Depends on: 923022
Depends on: 923040
Depends on: 921915
Depends on: 923031
Depends on: 923366
Depends on: 923437
Depends on: 911121
Depends on: 918272
Depends on: 922548
Depends on: 922980
Depends on: 923866
Depends on: 924015
Depends on: 924018
No longer depends on: 922548
Depends on: 924729
after landing bug 922462, please use following build command for production setting

`GAIA_DISTRIBUTION_DIR=distribution_tablet MOZILLA_OFFICIAL=1 make production`


 (no longer need `GAIA_DEV_PIXELS_PER_PX=1.5` parameter)
Depends on: 908601
Depends on: 927749
Depends on: 928254
Depends on: 928306
Depends on: 928643
We need add extra param `GAIA_KEYBOARD_LAYOUTS=en, zh-Hans-Pinyin` for recent keyboard build-time customization from bug 884752
to test your layout via firefox nightly, please change the responsive design layout to `1312x831` to get precisely 1280x800 layout. (check the screenshot size, it might be the gaia add-on bug) 

You could use ctrl+mouse to do the precise size control.
Depends on: 929369
Depends on: 929854
Depends on: 929875
Depends on: 929883
Depends on: 930306
Blocks: 930361
No longer blocks: 930361
Depends on: 930361
Depends on: 929889
Alias: flatfish
Depends on: 932081
Depends on: 930858
Depends on: 932174
Depends on: 932204
Depends on: 934326
Depends on: 934881
Depends on: 932669
Depends on: 932672
Depends on: 934893
Depends on: 934895
Depends on: 934898
Depends on: 934906
Depends on: 934908
Depends on: 934925
Depends on: 935323
Depends on: 935352
Depends on: 935358
Depends on: 935378
Depends on: 935381
Depends on: 935386
Depends on: 935391
Depends on: 935424
No longer depends on: 934898
Depends on: 935547
Depends on: 934894
Depends on: 935816
Depends on: 935820
Depends on: 935833
Depends on: 935865
No longer depends on: 934908
Depends on: 936335
Depends on: 936395
Depends on: 936396
Depends on: 936532
Depends on: 936997
Depends on: 937039
Depends on: 937048
Depends on: 937051
Depends on: 937055
Depends on: 937060
Depends on: 936401
Depends on: 936392
Depends on: 938518
Depends on: 940188
Depends on: 940921
Depends on: 940922
Depends on: 941386
Depends on: 942681
Depends on: 943173
Depends on: 940157
Depends on: 943266
Depends on: 943758
Depends on: 939672
Depends on: 944077
No longer depends on: 937048
Depends on: 950601
Depends on: 972181
Depends on: 966540
Duplicate of this bug: 987489
Depends on: 994601
Depends on: 993315
Depends on: 999902
Depends on: 1017396
Depends on: 1017569
Depends on: 1017584
Depends on: 1017622
Depends on: 1017955
Depends on: 1018188
Depends on: 1018385
Depends on: flatfish-ux
No longer depends on: 897900
No longer depends on: 903916
No longer depends on: 905065
No longer depends on: 905482
No longer depends on: 906537
No longer depends on: 906540
No longer depends on: 906541
No longer depends on: 906542
No longer depends on: 906552
No longer depends on: 906553
No longer depends on: 906555
No longer depends on: 906556
No longer depends on: 906559
No longer depends on: 906582
No longer depends on: 906583
No longer depends on: 906584
No longer depends on: 929369
No longer depends on: 932081
No longer depends on: 934326
No longer depends on: 935816
No longer depends on: 940921
No longer depends on: 940922
No longer depends on: 943173
No longer depends on: 944077
No longer depends on: 993315
No longer depends on: 1017955
I had the problem describe at Bug 1018636 with Flatfish.
OS: Mac OS X → Other
Hardware: x86 → Other
No longer depends on: 1018655
No longer depends on: 1018780
Depends on: 1021327
Depends on: 1026963
Depends on: 1029940
Depends on: 1031535
Depends on: 1031545
Depends on: 1031983
Depends on: 1032282
No longer depends on: 1032282
Depends on: 1003781
Depends on: 1024881
Depends on: 1025856
Depends on: 1028113
Depends on: 1029464
Depends on: 1003035
Depends on: 1029475
Depends on: 1033619
Depends on: 1017934
Depends on: 1034196
Depends on: 1034529
Depends on: 1031840
Depends on: 1033957
No longer depends on: 1031840
Depends on: 1034941
Depends on: 1034956
Depends on: 1035483
Depends on: 1036358
Depends on: 1038039
Depends on: 1038564
Depends on: 1038107
Depends on: 1040236
Depends on: 1022933
Depends on: 1040648
Depends on: 1040671
Depends on: 1041391
Depends on: 1042286
Depends on: 1026430
Depends on: 1043313
Depends on: 1043548
Depends on: 1044733
Depends on: 1044982
Depends on: 1045424
No longer depends on: 1045424
Depends on: 1045461
Depends on: 1014403
No longer depends on: 1045461
Depends on: 1045974
Depends on: 1046509
Depends on: 1014632
Depends on: 1048189
Depends on: 1048195
Depends on: 1048804
Depends on: 1050215
Depends on: 1050689
Depends on: 1051582
Depends on: 1052080
Depends on: 1052373
Depends on: 1053728
Depends on: 1054234
Depends on: 1054432
Depends on: 1054943
Depends on: 1054964
Depends on: 1055482
Depends on: 1055494
Depends on: 1053346
Depends on: 1018144
Depends on: 1056017
Depends on: 1056708
Depends on: 1041921, 1046719
Depends on: 1059137
Depends on: 1059196
Depends on: 1059713
Depends on: 1059748
No longer depends on: 1059713
Depends on: 1060303
Depends on: 1060457
Depends on: 1060468
Depends on: 1061043
Depends on: 1062198
Depends on: 1062227
Depends on: 1018024
Depends on: 1063425
Depends on: 1065342
Depends on: 1066389
Depends on: 1066395
Depends on: 1066408
Depends on: 1066415
Depends on: 1066420
Depends on: 1066424
Depends on: 1067302
Depends on: 1067905
Depends on: 1069237
No longer depends on: 1061043
Depends on: 1069892
Depends on: 1069900
Depends on: 1069957
Depends on: 1070909
Depends on: 1071540
No longer depends on: 1071540
Depends on: 1072250
No longer depends on: 1052080
Depends on: 1073433
Depends on: 1073438
Depends on: 1082512
Depends on: 1082516
Depends on: 1083054
Depends on: 1085063
Depends on: 1088582
No longer depends on: 1089051
Depends on: 1092146
Depends on: 1092150
Depends on: 1097483
Depends on: 1098159
Depends on: 1098496
Depends on: 1098964
Depends on: 1099000
Depends on: 1102176
Depends on: 1105166
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.