Closed Bug 1008737 Opened 9 years ago Closed 9 years ago

[DSDS] [Flame] Only first IMEI is exposed in Settings -> About

Categories

(Firefox OS Graveyard :: Gaia::Settings, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(tracking-b2g:backlog, b2g-v2.0 affected, b2g-v2.1 verified)

RESOLVED FIXED
tracking-b2g backlog
Tracking Status
b2g-v2.0 --- affected
b2g-v2.1 --- verified

People

(Reporter: gerard-majax, Assigned: gsvelto)

References

Details

Attachments

(2 files, 2 obsolete files)

Dual SIM devices like the Flame have two IMEIs, one for each SIM card. However, Settings -> About only exposes the first IMEI number.
This may be a followup of bug 1002327.
Depends on: 1002327
Flags: needinfo?(gsvelto)
Depends on: 942740
(In reply to Alexandre LISSY :gerard-majax from comment #1)
> This may be a followup of bug 1002327.

Yes indeed, now that both dependencies have landed we can fix this.
Flags: needinfo?(gsvelto)
feature no blocking
blocking-b2g: 2.0? → backlog
Blocks: 1020166
per T2M RD's confirmation, Flame does support 2 IMEIs.

>[T2M - Youlong]
Yes, each device have two IMEIs number.
Assignee: nobody → gsvelto
Status: NEW → ASSIGNED
(In reply to Gabriele Svelto [:gsvelto] from comment #5)
> Created attachment 8453114 [details] [diff] [review]
> [PATCH WIP] Display all IMEI codes in the "More information" panel

Can you add a unique attribute/clas/id into the HTML for each SIM? It will make UI testing much easier!

Thanks
(In reply to Zac C (:zac) from comment #6)
> Can you add a unique attribute/clas/id into the HTML for each SIM? It will
> make UI testing much easier!

Would something like a data-slot attribute work? The list of elements would then look like:

<span data-l10n-id="deviceInfo-IMEI" data-slot="0"> IMEI0 </span>
<span data-l10n-id="deviceInfo-IMEI" data-slot="1"> IMEI1 </span>
etc...
perfect, any CSS locatable strategy is fine.
Here's the full patch complete with adjusted unit-tests and additional coverage for multi-SIM operation. I've added a data-slot attribute to the spans containing the IMEI codes that's populated with the SIM slot number as discussed in the comments above. I'll attach the PR shortly.
Attachment #8453114 - Attachment is obsolete: true
Attachment #8455203 - Flags: review?(arthur.chen)
Comment on attachment 8455203 [details] [diff] [review]
[PATCH] Display all IMEI codes in the "More information" panel

EJ, could you help me review this patch? Thanks!
Attachment #8455203 - Flags: review?(arthur.chen) → review?(ejchen)
Comment on attachment 8455203 [details] [diff] [review]
[PATCH] Display all IMEI codes in the "More information" panel

Hi :gsvelto,

I did review on Github and left some comments there, please check and r? me again 
when you fix them. 

BTW, please set r? on the attachment which points to the github link instead of the one with diff messages. Thanks !
Attachment #8455203 - Flags: review?(ejchen)
Attachment #8455203 - Attachment is obsolete: true
Comment on attachment 8455205 [details] [review]
[PULL REQUEST] Display all IMEI codes in the "More information" panel

Thanks for the review Ej, I've addressed all of your GitHub comments and updated the PR accordingly except for the bug comment: normally we don't use the bug title in the commit comments but we put an explanatory message instead. If you want it changed though I don't really mind.

I've also changed the labels for the IMEI codes according to your suggestion. Now a single-SIM device will show the IMEI code alone in the panel, e.g.:

  IMEI

0123456789

While a multi-SIM one will have individual labels such as we have for ICC IDs:

  IMEI

IMEI 1: 0123456789
IMEI 2: 1234567890
etc...

Unit-tests have been adjusted accordingly. I've tested this on both a dual-SIM device (Flame) and a single-SIM one (Hamachi).
Attachment #8455205 - Flags: review?(ejchen)
Comment on attachment 8455205 [details] [review]
[PULL REQUEST] Display all IMEI codes in the "More information" panel

Thanks for the patch, Gabriele.

There is one more nit and please check it on github. By the way, remember to merge after travis / gaia-try is green, thanks !!
Attachment #8455205 - Flags: review?(ejchen) → review+
Try was green: https://tbpl.mozilla.org/?rev=ef7675f9f77e27a7dc28ae9ad1a052deaa3338ea&tree=Gaia-Try

Pushed to gaia/master 065f6361a60734d25b9317ce5c3917cdf8297075

https://github.com/mozilla-b2g/gaia/commit/065f6361a60734d25b9317ce5c3917cdf8297075
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Guys this affects v2.0 build also. Push fix to v2.0?

Build:
Gaia      aa4f795b81c6147d67c4f06009e166debcf8856e                         
Gecko     https://hg.mozilla.org/releases/mozilla-aurora/rev/0ec0b9ac39f0  
BuildID   20140717000201                                                   
Version   32.0a2
Status: RESOLVED → REOPENED
Flags: needinfo?(gsvelto)
Resolution: FIXED → ---
(In reply to [:AndreiH] from comment #16)
> Guys this affects v2.0 build also. Push fix to v2.0?

Yes, but this bug is not a 2.0+ blocker so it cannot land on v2.0 without approval. If you need this bug to land on v2.0 please ask for approval as described here:

https://wiki.mozilla.org/Release_Management/B2G_Landing#v2.0.0

Also do not reopen the bug since this has been fixed on master, use the tracking flags to mark which versions are affected/fixed. I've already marked v2.0 as affected in this case.
Status: REOPENED → RESOLVED
Closed: 9 years ago9 years ago
Flags: needinfo?(gsvelto)
Resolution: --- → FIXED
This issue has been verified successfully on Flame2.1.
Reproducing rate: 0/5
See attachment: Verify_Flame_IMEI.png

STRs:
1. Launch Settings->Device information.
2. Tap "More Information, check the IMEI.

Actual Result:
The two IME number are displayed normally.

Flame2.1 build version:
Gaia-Rev        ccb49abe412c978a4045f0c75abff534372716c4
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/18fb67530b22
Build-ID        20141201001201
Version         34.0
Attached image Verify_Flame_IMEI.png
blocking-b2g: backlog → ---
You need to log in before you can comment on or make changes to this bug.