Closed Bug 1008925 Opened 6 years ago Closed 6 years ago

Port plugin crashed handler changes from bug 981237

Categories

(SeaMonkey :: UI Design, defect)

defect
Not set

Tracking

(seamonkey2.27 unaffected, seamonkey2.28 fixed, seamonkey2.29 fixed)

RESOLVED FIXED
seamonkey2.29
Tracking Status
seamonkey2.27 --- unaffected
seamonkey2.28 --- fixed
seamonkey2.29 --- fixed

People

(Reporter: neil, Assigned: neil)

References

Details

Attachments

(1 file)

Bug 981237 changed the plugin crashed event from a DataContainerEvent to a CustomEvent.
Where is SeaMonkey's plugin crashed handler? I couldn't find any references to DataContainerEvent under comm-central:
https://mxr.mozilla.org/comm-central/search?string=DataContainerEvent
(In reply to Masatoshi Kimura from comment #1)
> Where is SeaMonkey's plugin crashed handler? I couldn't find any references
> to DataContainerEvent under comm-central:
> https://mxr.mozilla.org/comm-central/search?string=DataContainerEvent

Looks like I removed it in bug 813963, I assumed it wasn't necessary since we didn't have to worry about untrusted events any more. Do you think I should restore the check? I've already ported the other changes locally.
Flags: needinfo?(VYV03354)
I don't think we need to restore the check.
Flags: needinfo?(VYV03354)
Attached patch Proposed patchSplinter Review
Assignee: nobody → neil
Status: NEW → ASSIGNED
Attachment #8425307 - Flags: review?(philip.chee)
Comment on attachment 8425307 [details] [diff] [review]
Proposed patch

r=me via code inspection
Attachment #8425307 - Flags: review?(philip.chee) → review+
You could always try killing plugin-container.exe in Task Manager.
Pushed comm-central changeset 1f0d20ca745f.
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.29
Comment on attachment 8425307 [details] [diff] [review]
Proposed patch

[Approval Request Comment]
Regression caused by (bug #): 981237
User impact if declined: Plugin crashed placeholder does not work
Testing completed (on m-c, etc.): Landed on c-c
Risk to taking this patch (and alternatives if risky): Very low
String changes made by this patch: None
Attachment #8425307 - Flags: approval-comm-aurora?
Comment on attachment 8425307 [details] [diff] [review]
Proposed patch

a=me commm-aurora
Attachment #8425307 - Flags: approval-comm-aurora? → approval-comm-aurora+
You need to log in before you can comment on or make changes to this bug.