Add Google search purpose for about:newtab

VERIFIED FIXED in Firefox 31

Status

()

defect
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: adw, Assigned: adw)

Tracking

Trunk
Firefox 32
Points:
---
Dependency tree / graph
Bug Flags:
firefox-backlog +

Firefox Tracking Flags

(firefox31 verified, firefox32 verified)

Details

(Whiteboard: p=1 s=it-32c-31a-30b.2 [qa!])

Attachments

(1 attachment)

Posted patch patchSplinter Review
From bug 980606:

(In reply to Bryan Clark (Firefox Search PM) [:clarkbw] from comment #18)
> - need to land -
> Google: use the "nts" channel id
Attachment #8421427 - Flags: review?(MattN+bmo)
Comment on attachment 8421427 [details] [diff] [review]
patch

LGTM assuming tests pass.
Attachment #8421427 - Flags: review?(MattN+bmo) → review+
Whiteboard: p=1 → p=1 s=it-32c-31a-30b.2 [qa?]
Flags: firefox-backlog+
Per comment #0 use the Google portion of bug 980606#c18 for verification.
Whiteboard: p=1 s=it-32c-31a-30b.2 [qa?] → p=1 s=it-32c-31a-30b.2 [qa+]
https://hg.mozilla.org/mozilla-central/rev/a00aa4018cef
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 32
QA Contact: cornel.ionce
I can confirm that the "channel=nts" parameter is added to the result URL string if a search is made from the newtab page using Google as default engine.
Tested using latest Nightly, build ID: 20140514030203.

Is there anything else I should look at before marking this verified?
Flags: needinfo?(adw)
No, thanks.
Flags: needinfo?(adw)
Comment on attachment 8421427 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #):
search in about:newtab, bug 962490

User impact if declined:
Bug 962490 landed on 31, so this patch should be on 31, too.  The right search purpose code must be sent to Google when the user uses the search box in about:newtab.

Testing completed (on m-c, etc.):
automated test on fx-team, m-c

Risk to taking this patch (and alternatives if risky):
low

String or IDL/UUID changes made by this patch:
none
Attachment #8421427 - Flags: approval-mozilla-aurora?
Thanks, marking issue verified based on above comments.
Status: RESOLVED → VERIFIED
Whiteboard: p=1 s=it-32c-31a-30b.2 [qa+] → p=1 s=it-32c-31a-30b.2 [qa!]
Attachment #8421427 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Confirming that the "channel=nts" parameter is also present on Latest Aurora, build ID: 20140520004002.
You need to log in before you can comment on or make changes to this bug.