OS X - Netscape -> About Brings up home page instead of About Netscape window

VERIFIED WORKSFORME

Status

VERIFIED WORKSFORME
17 years ago
14 years ago

People

(Reporter: TucsonTester2, Assigned: asa)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Build ID: 20010919

If you launch Netscape and click on Netscape -> About Netscape the window that
launches has the set start page instead of the About info.

Reproducibility: Everytime

Steps to reproduce:
1.Open Netscape (Browser, composer, etc. - doesn't matter)
2.Click on Netscape -> About Netscape

Actual Results:
The window that opens shows the start page instead of the about information.

Expected Results:
I would expect that the about information would be displayed. Help -> About
Netscape does work though.
(Reporter)

Comment 1

17 years ago
I tried reproducing this on the 20010913 build for OSX but it worked fine.

Summary: Netscape -> About Brings up home page instead of About Netscape window → OS X - Netscape -> About Brings up home page instead of About Netscape window

Comment 2

17 years ago
Reporter, using Fizzilla build of course there isn't a Netscape menu, but rather a Mozilla menu.

That notwithstanding, selecting Mozilla/About Mozilla actually does nothing using Fizzilla/
2001092021. Selecting Help/About Mozilla opens a new Navigator window showing the proper 
About content.

Mozilla/About Mozilla works properly using Fizzilla/2001091313 (0.9.4).

Reporter, can you reproduce your precise reported behavior using the most recent _Fizzilla_ 
build? If not, this will have to go to Bugscape.

Comment 3

17 years ago
Greg,

Are you not infact describing a bug?
Mozilla->About Mozilla does nothing

until you go under help->about mozilla
then mozilla->about mozilla displays the help

Would this not still be a bug that mozilla has to work on?
(Reporter)

Comment 4

17 years ago
Actually this bug does quite a few things, some I can't get to reproduce yet.  I
have seen it open a new composer window while I was in composer, a new start
page as I stated above, the netscape help window and I've also seen it do
nothing at all.

Comment 5

17 years ago
There is already a bug for {appname}>About. if this is just about that then this
bug should be duped.

Comment 6

17 years ago
Riscky, yes, but it's a different bug than described here.

Comment 7

17 years ago
well i should have made what i was thinking clear

is this but not really depended on the what i was talking about and what you
mentiond greg?

Comment 8

17 years ago
TucsonTester2, have a look at bug 83187. It's about implementing Mozilla/About Mozilla 
on Mac OS X. It's marked Resolved/Fixed, but if it isn't in fact working you should reopen 
it.

Marking this bug a duplicate of that one.

*** This bug has been marked as a duplicate of 83187 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
about was broken for a day or two last week when i landed a menu change and
biffed only the 'app' menu (where about lives). it should work fine with a
current build. if not, please reopen this bug (it's not a dupe as marked, that
was the wrong thing to do).
This works on both the trunk 2001-10-02-21 build and the 2001-10-03 branch builds.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
now, marking worksforme.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → WORKSFORME
...verified
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.