Closed Bug 1009900 Opened 6 years ago Closed 6 years ago

[email] blue focus line in compose

Categories

(Firefox OS Graveyard :: Gaia::E-Mail, defect)

x86
macOS
defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED
2.0 S2 (23may)

People

(Reporter: jrburke, Assigned: jrburke)

References

Details

Attachments

(1 file)

46 bytes, text/x-github-pull-request
mcav
: review+
pivanov
: feedback+
Details | Review
This is caused by the changes from bug 992994, part of the 2.0 visual refresh work:

In Compose, tapping in the Subject or the To/CC/BCC fields shows a blue underline.

I do not believe this is the desired effect, so I will do a patch that overrides those base styles for the compose inputs.
Attached file GitHub pull request
Style override for compose card input fields. Asking for feedback from :ivanovpavel to make sure it fits in with any master designs he knows about, before I ask for formal dev review.
Attachment #8422056 - Flags: feedback?(pivanov)
Duplicate of this bug: 1009903
Comment on attachment 8422056 [details] [review]
GitHub pull request

Yep, as I know we don't need the blue line of these inputs so I think we need this patch :) Thanks James :)
Attachment #8422056 - Flags: feedback?(pivanov) → feedback+
Comment on attachment 8422056 [details] [review]
GitHub pull request

Asking for formal review, pinging mcav since he probably has some recent compose exposure due to outbox, and the style changes are very localized to the compose card. mcav: basically, the inputs on compose should look as they did before.

In addition to removing the blue line I also restored the height and alignment of the address areas from before.

Tested on device and in firefox desktop.
Attachment #8422056 - Flags: review?(m)
Comment on attachment 8422056 [details] [review]
GitHub pull request

Looks good to me.
Attachment #8422056 - Flags: review?(m) → review+
Merged in master:
https://github.com/mozilla-b2g/gaia/commit/0cfa7fc994702467708c57ad0bbab8f6b7646677

from pull request:
https://github.com/mozilla-b2g/gaia/pull/19217
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
[Environment]
Gaia      917174ee3812a43758bf43f7ba5f9416dcdb2ca8
Gecko     https://hg.mozilla.org/releases/mozilla-b2g28_v1_3t/rev/a3a14fb5ad51
BuildID   20140519164002
Version   28.1
ro.build.version.incremental=eng.cltbld.20140519.201203
ro.build.date=Mon May 19 20:12:10 EDT 2014

[Result]
PASS
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.