Closed Bug 1010493 Opened 6 years ago Closed 6 years ago

Startup crash in dgapi.dll (Digital Guardian)

Categories

(Core :: General, defect)

27 Branch
x86_64
Linux
defect
Not set

Tracking

()

RESOLVED WONTFIX

People

(Reporter: u501009, Assigned: dmajor)

References

Details

(Keywords: crash)

Crash Data

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:27.0) Gecko/20100101 Firefox/27.0 (Beta/Release)
Build ID: 20140218140359

Steps to reproduce:

"I cannot open Firefox AT ALL. Neither in Safe Mode, nor any other way. I have tried all of the troubleshooting steps recommended on the site to no avail." 


Actual results:

Firefox crashes
Component: Untriaged → General
Keywords: crash
Product: Firefox → Core
What is dgapi.dll and why is nsObserverService::NotifyObservers calling it, do we know?
Flags: needinfo?(dmajor)
No name or version, which is suspicious.

    Loaded symbol image file: dgapi.dll
    Image path: c:\windows\system32\dgapi.dll
    Image name: dgapi.dll
    Timestamp:        Tue Mar 25 06:18:21 2014 (533068DD)
    CheckSum:         001FF831
    ImageSize:        00208000
    File version:     0.0.0.0
    Product version:  0.0.0.0
    File flags:       0 (Mask 0)
    File OS:          0 Unknown Base
    File type:        0.0 Unknown
    File date:        00000000.00000000
    Translations:     0000.04b0 0000.04e4 0409.04b0 0409.04e4

Here's the notification:

         aTopic = 0x047ce564 "content-document-global-created"
       someData = 0x0043be10 "null"

I'm guessing either dgapi got itself onto the observers list, or it hooked something along the way. It's been seen before in bug 640895 but that didn't go anywhere.
Flags: needinfo?(dmajor)
According to the support thread, dgapi is Digital Guardian enterprise software.

This particular signature is new in 29, but there are also startup crashes at other parts of dgapi in 28.
Crash Signature: [@ dgapi.dll@0x92d5d ]
Summary: Crashes → Startup crash in dgapi.dll (Digital Guardian)
So what is the solution ?
There is no solution currently. This needs to be fixed by the authors of Digital Guardian. KaiRo, do you know anyone with contacts at Verdasys?

In the meantime we might need to recommend using ESR as a workaround.
Flags: needinfo?(kairo)
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Resolution: --- → WONTFIX
(In reply to David Major [:dmajor] (UTC+12) from comment #6)
> There is no solution currently. This needs to be fixed by the authors of
> Digital Guardian. KaiRo, do you know anyone with contacts at Verdasys?

I don't know right away, but release management has a list of contacts in different places, we usually run those through them.
Flags: needinfo?(kairo) → needinfo?(release-mgmt)
I looked in our rolodex and I could not find any reference about Verdasys.
Flags: needinfo?(release-mgmt)
The conflict between Verdasys Digital Guardian and Firefox is due to Digital Guardian only supporting ESR versions of Firefox. If you run into a problem with Firefox and Verdasys Digital Guardian please have your organizations Digital Guardian Support contact open a support incident with Verdasys Support for more information on suggested work arounds.

Thank you,
Chris Loiselle
Director, Technical Support
Verdasys Inc.
Can we just blacklist the Digital Guardian DLLs in non-ESR versions, in that case?
Flags: needinfo?(dmajor)
Flags: needinfo?(benjamin)
Christopher Loiselle, can you please make sure that if Digital Guardian only loads itself into versions of Firefox that it is tested with?

blocklisting the DLLs in regular versions but not ESR builds would be tricky; I'm pretty sure we don't have any build flags that mark an ESR version, so it would probably involve checkins and backouts.

Although unless Digital Guardian commits to fixing the crash and making sure, I'm tempted to say we should block the DLLs permanently.
Flags: needinfo?(dmajor)
Flags: needinfo?(cloiselle)
Flags: needinfo?(benjamin)
As Verdasys Digital Guardian is a security software we cannot discuss its functions with anyone other then authorized contacts. We can configure around this problem however in order to inform customers of this method they will have to open a support incident with Verdasys Support. When an authorized contact opens an incident we will provide them with the suggested work around.

Thank you,
Chris Loiselle
Flags: needinfo?(cloiselle)
Given that the vendor isn't helpful, dmajor please block the DLL.
Assignee: nobody → dmajor
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: WONTFIX → ---
Benjamin,
If you are having this problem it means that you are using a company computer that has Digital Guardian installed. Please contact your IT department to work with Verdasys to resolve this problem.

If you believe Verdasys is not being helpful I apologize however Verdasys Digital Guardian is a Security software platform and we cannot provide details about this to unauthorized support contacts.

Please NOTE that Verdasys DOES have a workaround to resolve this problem. It MUST be accessed by authorized Verdasys support contacts.

Chris Loiselle
Verdasys
Christopher, I am the engineering manager responsible for Firefox stability. Typically if third-party software causes Firefox to crash, we expect the vendor of that software to coordinate with Mozilla in resolving the issue. If you are not willing to do that, then we take measures to prevent your software from loading into Firefox.
Benjamin,
I have escalated this to out Product Management and Engineering department. I would assume they would be in contact with you directly to discuss. Do you have a Mozilla email address we can use to contact you?

Chris Loiselle
I can also be reached at bsmedberg@mozilla.com
Had a conf-call with Versdasys today. They will be updating their software to present the user with a incompatibility message instead of silently crashing. I have contact info on file for future reference. We don't need to make client changes at this time.
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → WONTFIX
Hii Team,
Recently I again got a message about crash which is due to digital guardian . So what is the current staus ?and how we sort out this issue ?
This issue has been resolved in the latest release of the Digital Guardian Product. This can also be worked around via a configuration change. Please have the Digital Guardian Administrator open a support case with Digital Guardian for more details on the solution.

Thank you,
Chris Loiselle
See Also: → 1318858
You need to log in before you can comment on or make changes to this bug.