Closed Bug 1011087 Opened 8 years ago Closed 8 years ago

[B2G][SMS]Using edge gestures to change apps while keyboard is present, message bar is partially offscreen after returning to SMS app

Categories

(Firefox OS Graveyard :: Gaia::System::Window Mgmt, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:2.0+, b2g-v2.0 fixed)

RESOLVED FIXED
2.0 S2 (23may)
blocking-b2g 2.0+
Tracking Status
b2g-v2.0 --- fixed

People

(Reporter: rkuhlman, Assigned: etienne)

References

Details

(Whiteboard: [systemsfe])

Attachments

(4 files)

Attached file MessageBarLog.txt
Edge gestures can be used to cycle between open apps. If the messaging app is currently open and the keyboard is displayed, the messaging app will not display appropriately when the user swipes to a different app and back to messaging. The text bar at the bottom of the screen will be partially offscreen.

Repro Steps:
1) Update Open_C to Build ID: 20140515040207
2) Launch an app that does not support keyboard (Camera, Gallery, Music, etc)
3) Launch messaging app
4) Tap on a text field to summon keyboard
5) Use edge gesture to switch to app launched in step 2
6) Use edge gesture to switch back to messaging

Actual:
The 'Message' text box at the bottom of the screen is partially offscreen

Expected:
The 'Message' text box is entirely onscreen

Environmental Variables
Device: Open_C Master M-C
Build ID: 20140515040207
Gecko: e4843f4f08a7
Gaia: 3a1d67246a79e3632c3b3f2460a25291e7e2714c
Platform Version: 32.0a1
Firmware Version: P821A10 v1.0.0B06_LOG_DL

Notes:
Repro frequency: 100%
See attached: screenshot, logcat
Component: Gaia::SMS → Gaia::System::Window Mgmt
Flags: needinfo?(etienne)
Can we get a video?
Keywords: qawanted
Whiteboard: [systemsfe]
Keywords: regression
Attached file Gaia PR
If we end up without a SheetTransition this will be moved pretty easily.
Until then I think this is the best place to put it.
Assignee: nobody → etienne
Attachment #8423368 - Flags: review?(alive)
Flags: needinfo?(etienne)
Etienne: I was about to file a bug, but is the attached screenshot part of the same issue and will your patch address it? Otherwise I can file a new bug
needinfo for comment 4
Flags: needinfo?(etienne)
(In reply to Marcia Knous [:marcia - use needinfo] from comment #4)
> Created attachment 8423389 [details]
> Screenshot of calendar app after using edge gestures
> 
> Etienne: I was about to file a bug, but is the attached screenshot part of
> the same issue and will your patch address it? Otherwise I can file a new bug

If the keyboard was not involve in reproducing this screenshot we probably need a new bug :/
Flags: needinfo?(etienne)
Removing regression keyword since this only happens if edge gestures is actually used.
Keywords: regression
QA Contact: nkot
Comment on attachment 8423368 [details] [review]
Gaia PR

r+ though I prefer an event for keyboard to close it but anyway...
Attachment #8423368 - Flags: review?(alive) → review+
Comment on attachment 8423368 [details] [review]
Gaia PR

Yeah.. it was already kinda ugly, switched to an event, can you take another quick look?
Attachment #8423368 - Flags: review+ → review?(alive)
Attachment #8423368 - Flags: review?(alive) → review+
https://github.com/mozilla-b2g/gaia/commit/31ca6daae442ceacf942c74e747618deaff9c648
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
blocking-b2g: --- → 2.0+
Target Milestone: --- → 2.0 S2 (23may)
blocking-b2g: 2.0+ → ---
feature-b2g: --- → 2.0
This is a bug in a preffed on feature, which should be using the blocking-b2g flag, not the feature-b2g flag.
blocking-b2g: --- → 2.0+
feature-b2g: 2.0 → ---
You need to log in before you can comment on or make changes to this bug.