bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

While keyboard is present, swipe the edge to swipe app without actual switching between apps results hidden keyboard but focus not removed

RESOLVED FIXED in Firefox OS v2.0

Status

Firefox OS
Gaia::System::Window Mgmt
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: timdream, Assigned: etienne)

Tracking

({regression})

unspecified
2.0 S3 (6june)
ARM
Gonk (Firefox OS)
regression
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.0+, b2g-v2.0 fixed)

Details

(Whiteboard: [systemsfe])

Attachments

(1 attachment)

46 bytes, text/x-github-pull-request
timdream
: review+
Details | Review | Splinter Review
+++ This bug was initially created as a clone of Bug #1011087 +++

STR:

0. Enable sheet swipe
1. Open one app
2. Open another, find a input and focus it. Wait for keyboard
3. Start swiping from the edge without lift the finger
4. Move your finger back to the edge and lift.

Expected:

1. Keyboard being hidden on step 3, and focus removed

Actual:

1. Keyboard being hidden, but focus not removed

Note:

I think this is a incomplete fix of bug 1011087. We should remove the focus there. We don't run into this for a complete swipe because the focus will be removed by setVisible(false) in app window manager.

I recommend we try mozInputMethod.mgmt.removeFocus() if that works.

Triage: should block because incomplete work in bug 1011087.
Flags: needinfo?(etienne)
(Assignee)

Updated

4 years ago
Assignee: nobody → etienne
Flags: needinfo?(etienne)
(Assignee)

Comment 1

4 years ago
Created attachment 8432995 [details] [review]
Gaia PR

Thanks Tim! Your suggestion worked like a charm.
Mind reviewing it? :)
Attachment #8432995 - Flags: review?(timdream)
Comment on attachment 8432995 [details] [review]
Gaia PR

I would have to rebase bug 1017327 but I think this 2.0+ should land first anyway.
Attachment #8432995 - Flags: review?(timdream) → review+
Status: NEW → ASSIGNED
(Assignee)

Comment 3

4 years ago
https://github.com/mozilla-b2g/gaia/commit/ec9d4679cc55306b2efa9486c32f4f7c2adee35b
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED

Updated

4 years ago
blocking-b2g: 2.0? → 2.0+
status-b2g-v2.0: --- → fixed
Target Milestone: --- → 2.0 S3 (6june)
You need to log in before you can comment on or make changes to this bug.