Closed Bug 1011106 Opened 7 years ago Closed 7 years ago

[B2G][FM Radio]User can unintentionally edge gesture swipe while changing radio stations

Categories

(Firefox OS Graveyard :: Gaia::FMRadio, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:2.0+, b2g-v1.4 unaffected, b2g-v2.0 fixed)

RESOLVED FIXED
2.0 S3 (6june)
blocking-b2g 2.0+
Tracking Status
b2g-v1.4 --- unaffected
b2g-v2.0 --- fixed

People

(Reporter: jschmitt, Assigned: justindarc)

References

()

Details

(Keywords: regression, Whiteboard: [systemsfe])

Attachments

(3 files, 1 obsolete file)

Description:
Changing radio stations the user can accidentally swipe edge gestures and change apps.

Repro Steps:
1) Update a Open_C to BuildID: 20140515040207
2) Open the FM Radio app
3) Plug in Headphones
4) Start scrolling through the radio stations

Actual:
While changing radio stations users can unintentionally use edge gestures

Expected:
The edge gesture does not swipe where the radio stations scrolling is located

2.0 Environmental Variables:
Device: Open_C 2.0
BuildID: 20140515040207
Gaia: 3a1d67246a79e3632c3b3f2460a25291e7e2714c
Gecko: e4843f4f08a7
Version: 32.0a1
Firmware Version: P821A10V1.0.0B06_LOG_DL

Keywords:
Edge Gestures, FM Radio

Notes:
Repro frequency: 100%
See attached: https://www.youtube.com/watch?v=kuvkou8dYaU
Issue repros on 2.0 Buri

Issue repros on 1.4 Open_C with edge gestures enabled.

1.4 Environmental Variables:
Device: Open_C 1.4 MOZ
BuildID: 20140515000202
Gaia: 2e97bee6bb79d3577dba1bf2a1bbfcba64ee99ab
Gecko: 0cb91945f404
Version: 30.0
Firmware Version: P821A10v1.0.0B06_LOG_DL
This probably needs to be fixed if we're shipping edge gestures in 2.0.

Note - I'd call this unaffected for 1.4 actually, since the feature was preffed off there.
blocking-b2g: --- → 2.0?
Leaving needinfo for Etienne to look into this.
Flags: needinfo?(etienne)
Keywords: regression
Whiteboard: [systemsfe]
The edge gestures live in the system app, so we don't know where the radio scrolling is located.
I don't think we can implement the Expected behavior, but I'm sure we can figure out some UX to mitigate the issue. It's being discussed on bug 972275.
Flags: needinfo?(etienne)
Component: Gaia::System → Gaia::FMRadio
We will need to come up with a solution for apps that conflict with edge gestures...for FM Radio it is very important because the edge gesture interferes with the primary function - channel scrolling and selection

adding ux folks

Thanks
Hema
Flags: needinfo?(squibblyflabbetydoo)
Flags: needinfo?(rmacdonald)
Flags: needinfo?(jsavory)
Flags: needinfo?(dkuo)
blocking-b2g: 2.0? → 2.0+
Jacqueline and I will prepare a proposal for this. I'll confirm the timing with her tomorrow.
Assignee: nobody → jdarcangelo
(In reply to Rob MacDonald [:robmac] from comment #6)
> Jacqueline and I will prepare a proposal for this. I'll confirm the timing
> with her tomorrow.

Jacqueline/Rob,

Any update on the proposal?

Thanks
hema
Hi Hema,

Yes, Hung and I are currently working on a proposal to reduce the size of the radio station bar. We should have something to show in the next couple of days.
Hey Hema

Attached you'll the proposed find spec. 

The proposal is to add "ends" to the dialer to create a buffer zone so users will focus in on the middle section.

I've also made some minor tweaks to improve contrast ratio. This will also help the app run smoother on our low end devices. 

Please let me know if you have any questions. 

Thanks
H.
Flags: needinfo?(rmacdonald)
Flags: needinfo?(jsavory)
Attachment #8427238 - Attachment description: pul → pull-request (master)
Comment on attachment 8427238 [details] [review]
pull-request (master)

Flagging Pavel for review since I'm not sure who is a qualified reviewer for FM Radio (I noticed you had some commits to FM Radio in the repo history). If this is incorrect, please let me know who should review. Thanks!
Attachment #8427238 - Flags: review?(pivanov)
Comment on attachment 8427238 [details] [review]
pull-request (master)

Also flagging Hung for UX review. I'll add a screenshot here as well.
Attachment #8427238 - Flags: ui-review?(hnguyen)
Attached image screenshot with patch applied (obsolete) —
Comment on attachment 8427238 [details] [review]
pull-request (master)

I'm not a owner/peer of FM Radio App ... but I made some small comments on github.

I think you should r? Vivien :)
Attachment #8427238 - Flags: review?(pivanov)
(In reply to Pavel Ivanov [:ivanovpavel] from comment #14)
> Comment on attachment 8427238 [details] [review]
> pull-request (master)
> 
> I'm not a owner/peer of FM Radio App ... but I made some small comments on
> github.
> 
> I think you should r? Vivien :)

Thanks Pavel! I applied the feedback in your comments and updated the PR. I'll flag Vivien for review.
Comment on attachment 8427238 [details] [review]
pull-request (master)

Vivien: Please review at your earliest convenience. Thanks!
Attachment #8427238 - Flags: review?(21)
Updated screenshot with feedback from Hung.
Attachment #8427241 - Attachment is obsolete: true
Comment on attachment 8427238 [details] [review]
pull-request (master)

After the minor update Justin made, I think we're good to go. 

thanks
Attachment #8427238 - Flags: ui-review?(hnguyen) → ui-review+
Comment on attachment 8427238 [details] [review]
pull-request (master)

Re-assigning this review to someone within the Media team.

David: If you can take a look at this patch, its pretty simple. Just some CSS changes to apply the new visual style.
Attachment #8427238 - Flags: review?(21) → review?(dflanagan)
Comment on attachment 8427238 [details] [review]
pull-request (master)

Pin/Dominic: I wasn't sure if either of you would be available to review this patch. If one of you can, you can clear the R? for the other. Thanks!
Attachment #8427238 - Flags: review?(pzhang)
Attachment #8427238 - Flags: review?(dkuo)
Attachment #8427238 - Flags: review?(dflanagan)
Flags: needinfo?(squibblyflabbetydoo)
Attachment #8427238 - Flags: review?(dkuo)
(In reply to Justin D'Arcangelo [:justindarc] from comment #20)
> Comment on attachment 8427238 [details] [review]
> pull-request (master)
> 
> Pin/Dominic: I wasn't sure if either of you would be available to review
> this patch. If one of you can, you can clear the R? for the other. Thanks!

Hi Just, thanks for your patch, please check my comments on Github PR.
(In reply to Pin Zhang [:pzhang] from comment #21)
> Hi Just, thanks for your patch, please check my comments on Github PR.

Thanks Pin! I have updated the PR to address your comments. Can you please re-review?
(In reply to Justin D'Arcangelo [:justindarc] from comment #22)
> (In reply to Pin Zhang [:pzhang] from comment #21)
> > Hi Just, thanks for your patch, please check my comments on Github PR.
> 
> Thanks Pin! I have updated the PR to address your comments. Can you please
> re-review?

Hi Justin, I didn't see your update, I think you might need |-f| to force update your branch, :)
(In reply to Pin Zhang [:pzhang] from comment #23)
> Hi Justin, I didn't see your update, I think you might need |-f| to force
> update your branch, :)

Ahhh.. Sorry 'bout that! Check it now :-)
Attachment #8427238 - Flags: review?(pzhang) → review+
Flags: needinfo?(dkuo)
Landed on master:

https://github.com/mozilla-b2g/gaia/commit/99698af7c6fbff5d32d923079d391165f4fa8f36
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.0 S3 (6june)
You need to log in before you can comment on or make changes to this bug.