Closed Bug 972275 Opened 7 years ago Closed 3 years ago

[Haida] The edge gesture feature is conflicting with Gallery swipe view

Categories

(Firefox OS Graveyard :: Gaia::Gallery, defect)

x86
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: timdream, Unassigned)

References

()

Details

(Keywords: regression)

Attachments

(1 file)

STR:

1. in settings, enable developer menu and edge gesture
2. go to Gallery, tap one of the image to go to single image view.
3. swipe left and right

Expected:

1. clear visual/interaction feedback to tell if I am swiping within the app (between images) or I am swiping between sheets.

Actual:

1. Need a few tries to tell where the invisible edge is.

We should probably address this issue before enabling the feature.
Flags: needinfo?(firefoxos-ux-bugzilla)
Flagging Francis and Gordon on the gesture here. Please un-flag whomever will not be working on this. Thanks!
Flags: needinfo?(gbrander)
Flags: needinfo?(firefoxos-ux-bugzilla)
Flags: needinfo?(fdjabri)
This is Rob's territory, so adding him as ni,.
Flags: needinfo?(fdjabri) → needinfo?(rmacdonald)
Hi Tim - This is something we're working on currently as part of the 1.4. Were you having trouble using the edge gesture or was it mainly being able to differentiate the transition between apps? - Rob
Flags: needinfo?(rmacdonald)
Flags: needinfo?(gbrander)
Blocks: 991849
No longer blocks: edge-gestures
Attached image edge-zones-flash.png
Here's an idea.
The issue here, like Tim said, is that the "edges zones" are invisible.
So event if you know how edge gestures work, you don't know which swipes are going to trigger an app switch.

We could detect edge swipes that are "false positive" and highlight the edge zones for half a second when this happens. This way the user will know which zones to avoid when using the app.

The heuristic to detect a "false swipe" could be something like < than 40px and < than 400ms. This way "peeking" won't be detected as a "false swipe".

Feedback?
Flags: needinfo?(firefoxos-ux-bugzilla)
Flagging Gordon to review.
Flags: needinfo?(firefoxos-ux-bugzilla) → needinfo?(gbrander)
Hi Tim...

In the version that you were evaluating, had the overlay and gap between sheets been implemented? 

If the goal is to have a "clear visual/interaction feedback to tell if I am swiping within the app (between images) or I am swiping between sheets", then the overlay and gap may have already addressed this issue.

We adopted this approach for the recent study and it performed quite well.

- Rob
Flags: needinfo?(gbrander) → needinfo?(timdream)
I just tried this again from the build last week. IMHO the problem is still there. I find myself wondering, when pressing down, before moving the finger, on what I will be swiping this time. So maybe we need visual hint at that timing.

I am not the expert here. Find me tomorrow and I will show it to you.
Flags: needinfo?(timdream)
feature-b2g: --- → 2.0
Can we get a video showing this bug on the latest trunk build?
Blocks: edge-gestures
No longer blocks: 991849
Keywords: qawanted
Added video URL


Video was taken on:
Device: Open_C 2.0
BuildID: 20140515040207
Gaia: 3a1d67246a79e3632c3b3f2460a25291e7e2714c
Gecko: e4843f4f08a7
Version: 32.0a1
Firmware Version: FFOS_US_EBAY_P821A10V1.0.0B06_LOG_DL
Note - this is classified as a regression from turning on edge gestures, so switching this to the blocking flag instead of the feature flag.

The video sends the impression that it's hard for a user to distinguish between a swipe in the gallery vs. a swipe to switch apps, which is confusing.
blocking-b2g: --- → 2.0?
feature-b2g: 2.0 → ---
Component: Gaia::System → Gaia::Gallery
Keywords: regression
Whiteboard: [systemsfe]
Another bug with impact of edge gestures on gallery...haida/edge gestures feature is not a blocker for 2.0 but it is being turned on in this release. Since it is interfering with gallery swipes with no clear distinction between swiping in app and from app-to-app leading to poor experience, this has to be fixed.
We need have to plan this into sprint 3 for 2.0. 

Rob, please provide your recommendation on the fix. 

Thanks
Hema
Flags: needinfo?(rmacdonald)
Target Milestone: --- → 2.0 S3 (6june)
NI Tif too
blocking-b2g: 2.0? → 2.0+
Flags: needinfo?(tshakespeare)
UX folks, please provide your recommendation here?
Rob is commenting on this bug today.
Flags: needinfo?(tshakespeare)
The key here is that the edge gestures and swipes are activated in a consistent, predictable way. In the video, the swipes are quite chaotic and not indicative of how users would interact with this UI. My experience with Gallery on Flame is it is actually a bit difficult to activate the swipe when using my thumb but that it is quite accurate and predictable when using an index finger.

I'm meeting with Etienne tomorrow to discuss potential tuning. Otherwise, the gesture is predictable, learnable and, in the event of an error, it is easy to recover.
Flags: needinfo?(rmacdonald)
Marcia - Can you provide your take on current usability of the switching photos given the above comments?
Flags: needinfo?(mozillamarcia.knous)
When I played around with the swiping the photos the gallery, I did not really see the unpredictable behavior between swiping apps & swiping photos until I hit the edge the screen. It's plausible a user could have that happen, but I also agree with Rob's comments that the user could quickly adapt to this by knowing that swiping edges --> switch apps vs. swiping not on edge --> switch photos.

I do wonder if a contextual gallery tutorial is useful here or not to avoid initial user errors.
IMO, the experience on trunk trying to swipe through my pictures is pretty bad. I find it very difficult to just get to the picture I want, and I am not doing it as aggressively as in the video. I am using the latest nightly on Flame:

Gaia   bc6f07c149770c6e6dfbea941ac65138dc364a15
SourceStamp 448f2153d6d3
BuildID 20140527160201
Version 32.0a1
Flags: needinfo?(mozillamarcia.knous)
(In reply to Jason Smith [:jsmith] from comment #17)
> When I played around with the swiping the photos the gallery, I did not
> really see the unpredictable behavior between swiping apps & swiping photos
> until I hit the edge the screen. It's plausible a user could have that
> happen, but I also agree with Rob's comments that the user could quickly
> adapt to this by knowing that swiping edges --> switch apps vs. swiping not
> on edge --> switch photos.
> 
> I do wonder if a contextual gallery tutorial is useful here or not to avoid
> initial user errors.

I tried it again with latest master on my flame and it does not look too bad. It was fairly easy to distinguish between swiping images in app and switching to other app

If this is getting difficult to adapt for certain users, would it help to place a quick user tip that disappears automatically and only shows once (informed adaptability to this interaction, right there). Jason is probably also talking about the same thing...

I tried it
Lets discuss this in the media triage this week
blocking-b2g: 2.0+ → 2.0?
I just showed jsmith how I hit this every time on the Flame. In my gallery if I start in the middle of the pictures and swipe to the left, I hit this every time. Jason noticed it is because it is how far I have my finger to the edge of the screen. I can demonstrate with a video if it helps.
(In reply to Marcia Knous [:marcia - use needinfo] from comment #21)
> I just showed jsmith how I hit this every time on the Flame. In my gallery
> if I start in the middle of the pictures and swipe to the left, I hit this
> every time. Jason noticed it is because it is how far I have my finger to
> the edge of the screen. I can demonstrate with a video if it helps.

If you're swiping from the middle, the app switch definitely shouldn't be triggered. That doesn't sound like it's behaving as expected. Could you post a video and NI Etienne and I?
Flags: needinfo?(mozillamarcia.knous)
Actually, when I meant the middle of the pictures I meant the middle of my gallery - I have pictures dating back to December.

When I swipe I have my finger at the very edge of the phone - will make a video to demonstrate.
Flags: needinfo?(mozillamarcia.knous)
Here is a short video I made of the issue:  http://youtu.be/WgNxvVaowYQ

1. Start in gallery with a few other apps open. Note that I have a number of pictures in my gallery and I start about in the middle of all of the gallery pictures.
2. Begin swiping to get to the next picture. Swiping doesn't end up being very smooth.
3. Note that a few swipes later I end up one of the apps instead of continuing through my gallery of pictures.
Flags: needinfo?(rmacdonald)
Flags: needinfo?(etienne)
(In reply to Marcia Knous [:marcia - use needinfo] from comment #24)

Hi Marcia - Looking at the video the edge swipe seems to be activated from the left edge of the screen so technically I wouldn't consider this a bug. I do recognize, though, that this is a learned behaviour and we're counting on users to make slight adjustments in the case of Gallery and other apps that use panning. Although edge gestures tested well in our study, there is risk. I think Etienne has found a good balance and the behaviour is quite consistent. In a worse case scenario, the contingency is the ease of recovery by swiping back, or in a worst case scenario, the ability to disable edge swipe in settings. - Rob
Flags: needinfo?(rmacdonald)
Whiteboard: [systemsfe]
Target Milestone: 2.0 S3 (6june) → ---
Triage on 6/4: Removing from nom -- marcia will have a couple of folks test this out at the bug bash tomorrow.
blocking-b2g: 2.0? → ---
Flags: needinfo?(etienne)
> Hi Marcia - Looking at the video the edge swipe seems to be activated from the left edge of the screen so technically I wouldn't consider this a bug. I do recognize, though, that this is a learned behaviour and we're counting on users to make slight adjustments in the case of Gallery and other apps that use panning.

I've found that in my daily use on Flame, it's easy to trigger edge gestures when you hold your phone with only one hand, and try to show the next/prev picture with your thumb. For example, if you hold it with your left hand, and swipe with the left thumb, it's very easy to trigger the gesture.

And in my experience this get annoying because when you hold the device with only one hand, it usually means you would like to find what you need quickly, instead of manipulate the phone on a stable surface.
Flags: needinfo?(rmacdonald)
The video:

https://www.youtube.com/watch?v=YYPH0x3YbiY

I also found another issue is when you're in Browser app, it's hard to trigger edge gesture when the page is too long and comes with scroll bar. You can see the video, I try to swipe back to Gallery but it didn't work.
(In reply to Greg Weng [:snowmantw][:gweng][:λ] from comment #28)
> The video:
> 
> https://www.youtube.com/watch?v=YYPH0x3YbiY
> 
> I also found another issue is when you're in Browser app, it's hard to
> trigger edge gesture when the page is too long and comes with scroll bar.
> You can see the video, I try to swipe back to Gallery but it didn't work.

The edge + scroll case looks really bad, even worse than this bug. Could you file it?
Flags: needinfo?(gweng)
(In reply to Tim Guan-tin Chien [:timdream] (MoCo-TPE) (please ni?) from comment #29)
>
> > https://www.youtube.com/watch?v=YYPH0x3YbiY
> > 
> The edge + scroll case looks really bad, even worse than this bug. Could you
> file it?

Yeah, that's a new one. Etienne, any ideas what's happening with the Browser in this instance? I'm assuming it's related to the scrolling somehow. Greg, please NI me on the bug when you've created it.
Flags: needinfo?(rmacdonald) → needinfo?(etienne)
The bug is here.

Bug 1026936 

I'll CC Rob at the bug, too.
Flags: needinfo?(gweng)
(In reply to Rob MacDonald [:robmac] from comment #30)
> (In reply to Tim Guan-tin Chien [:timdream] (MoCo-TPE) (please ni?) from
> comment #29)
> >
> > > https://www.youtube.com/watch?v=YYPH0x3YbiY
> > > 
> > The edge + scroll case looks really bad, even worse than this bug. Could you
> > file it?
> 
> Yeah, that's a new one. Etienne, any ideas what's happening with the Browser
> in this instance? I'm assuming it's related to the scrolling somehow. Greg,
> please NI me on the bug when you've created it.

The content of the app has no effect of the behavior of the edges.
I think this is bug 1016976 (the video matches the STR).
Flags: needinfo?(etienne)
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.