[B2G][RTL][Dialer] Arabic: "Call Log" in "Dialer" app has multiple issues.

VERIFIED FIXED in 2.1 S7 (24Oct)

Status

defect
VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: mlivingston, Assigned: nefzaoui)

Tracking

unspecified
2.1 S7 (24Oct)
ARM
Gonk (Firefox OS)
Dependency tree / graph
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(b2g-v1.3 unaffected, b2g-v1.4 affected, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: LocRun1.4)

Attachments

(5 attachments)

Reporter

Description

5 years ago
Posted file call log
Description:
The following issues are in the "Call Log" within the "Dialer" app:

-Red check boxes when they're not supposed to be there.
-When the "checkmark" icon is pressed, the cancel (x) button overlaps with "Edit" header and "# Selected".
-When the "checkmark" icon is pressed, all logged calls are shifted to the right causing a truncation off the screen.

Pre-requisite: Have multiple calls logged.

Repro Steps:
1) Update a Buri to BuildID: 20140515000202 and change the language to Arabic.
2) From the homescreen, tap on the "Dialer" app.
3) Tap on the "Call Log" icon at the bottom of the screen.
4) Observe the red check boxes appearing in the middle of each logged call.
5) Tap on the "checkmark" icon.
6) Observe that the logged calls are shifted to the right off screen.
7) Observe that the cancel(x) button overlaps with the header string "Edit"
8) Observe that the red check boxes are in the middle of each logged call.
9) Tap on one(1) or more logged call.
10) Observe that the cancel(x) button overlaps with the header string "# Selected" 

Actual:
The "Call Log" functions improperly.

Expected:
The "Call Log" functions properly.

1.4 Environmental Variables:
Device: Buri 1.4 MOZ
BuildID: 20140515000202
Gaia: 2e97bee6bb79d3577dba1bf2a1bbfcba64ee99ab
Gecko: 0cb91945f404
Version: 30.0
Firmware Version: v1.2-device.cfg

Repro frequency: 100%
Link to failed test case: https://moztrap.mozilla.org/manage/case/12298/
See attached: Screenshot
Reporter

Comment 1

5 years ago
Posted image call log.jpg
1.3 Environmental Variables:
Device: Buri 1.3 MOZ
BuildID: 20140514024003
Gaia: 96e3fa769a436a2182e6d54088fb41386eb2b5b5
Gecko: 685cf1d0dedb
Version: 28.0
Firmware Version: v1.2-device.cfg

These multiple issues are not present in Buri 1.3

Comment 2

5 years ago
Ahmed, I believe this call log issue is fixed by new UI, per the attached screenshot. Please verify that there are no other issues and, if this is truly correct, we can resolve this as fixed. Thank you!
Flags: needinfo?(nefzaoui.ahmed)

Updated

5 years ago
Blocks: dialer-rtl
No longer blocks: gaia-rtl
Assignee

Comment 3

5 years ago
(In reply to Stephany Wilkes from comment #2)
> Created attachment 8494094 [details]
> 2014-09-23-18-31-17.png
> 
> Ahmed, I believe this call log issue is fixed by new UI, per the attached
> screenshot. Please verify that there are no other issues and, if this is
> truly correct, we can resolve this as fixed. Thank you!

Not yet, The call icons still need to move to the right side, behind the called name & number. :)
Assignee: nobody → nefzaoui.ahmed
Status: NEW → ASSIGNED
Flags: needinfo?(nefzaoui.ahmed)
Assignee

Comment 4

5 years ago
There we go. :)
Attachment #8499847 - Flags: ui-review?(swilkes)
Attachment #8499847 - Flags: review?(etienne)
Comment on attachment 8499847 [details] [review]
Link to Github pull-reques

redirecting...
Attachment #8499847 - Flags: review?(etienne) → review?(drs+bugzilla)
Comment on attachment 8499847 [details] [review]
Link to Github pull-reques

Flagging Arnau to review the shared styles portion. I skimmed through it and the changes there looked reasonable.

For the dialer part, I left one comment on the PR which I suspect would have been caught during ui-review anyways.

I noticed that the "X" button to get out of edit mode is on the right even when in RTL mode. We could either fix that here and re-request review, or file a followup and fix it there.
Attachment #8499847 - Flags: review?(rnowmrch)
Attachment #8499847 - Flags: review?(drs+bugzilla)
Attachment #8499847 - Flags: review+
Target Milestone: --- → 2.1 S6 (10oct)
Do we want to use -moz-margin-start and related prefixed properties?
(In reply to Anthony Ricaud (:rik) from comment #7)
> Do we want to use -moz-margin-start and related prefixed properties?

Yes, I wondered this as well, though it seems reasonable to me. It's already in the System app in several places. [1] I wondered if we should add `margin-***` props as well, but the spec for it isn't far enough along [2] for that to be a good idea, IMO.

[1] https://github.com/mozilla-b2g/gaia/search?utf8=%E2%9C%93&q=-moz-margin-start
[2] https://developer.mozilla.org/en-US/docs/Web/CSS/-moz-margin-start#Specifications
Can we check with people involved in Gecko CSS ?

Updated

5 years ago
Attachment #8499847 - Flags: ui-review?(swilkes) → ui-review+

Comment 10

5 years ago
I believe we may need a second person flagged on review?. I believe Arnau's time with us has become more limited. Please add, and in the meantime I am flagging Przemek and Wilson who have been working on shared styles a great deal recently. 

UI approved. Edit mode will change in 2.2 as well, so may need to change this again.
Flags: needinfo?(wilsonpage)
Flags: needinfo?(pabratowski)
(In reply to Anthony Ricaud (:rik) from comment #9)
> Can we check with people involved in Gecko CSS ?

I did some fairly lazy searching and it looks like this is already in fairly heavy use even within Gecko. [1] It's also in use in other products, such as SeaMonkey and Thunderbird. [2] And, as I said, it's in use in the System app in several places. [3] It seems to me like it's a safe assumption that it'll stay around for a while. Even if it stops working, it'll be fairly obvious to us, and should be easy to fix, i.e. migrating from -moz-margin-*** to margin-*** if for some reason we aren't notified of this before it happens.

[1] http://mxr.mozilla.org/mozilla-central/search?string=margin-start
[2] bug 474807
[3] https://github.com/mozilla-b2g/gaia/search?utf8=%E2%9C%93&q=-moz-margin-start
Comment on attachment 8499847 [details] [review]
Link to Github pull-reques

Comment on github, you can merge after fixing it.
Thanks!
Attachment #8499847 - Flags: review?(rnowmrch) → review+
Flags: needinfo?(wilsonpage)
Flags: needinfo?(pabratowski)
Please fix and land this.
Flags: needinfo?(nefzaoui.ahmed)
Assignee

Comment 14

5 years ago
Rebased and adjusted.
Thanks all.
Flags: needinfo?(nefzaoui.ahmed)
Keywords: checkin-needed
Master: https://github.com/mozilla-b2g/gaia/commit/5f1f0960ae9d22acf2a324ad37a48174d6df87f6
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: 2.1 S6 (10oct) → 2.1 S7 (24Oct)

Updated

5 years ago
Keywords: verifyme

Comment 16

5 years ago
This issue verified successfull on Flame 2.2
Gaia-Rev        f5b3d1b6cfa3e702033f613915ae637cb735cbfb
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/bccee1a13ba6
Build-ID        20150119002502
Version         37.0a2
Device-Name     flame
FW-Release      4.4.2
Reproduce rate  0/5
Refer to video from comment 17

Comment 17

5 years ago
This issue verified successfull on Flame 2.2
Gaia-Rev        f5b3d1b6cfa3e702033f613915ae637cb735cbfb
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/bccee1a13ba6
Build-ID        20150119002502
Version         37.0a2
Device-Name     flame
FW-Release      4.4.2
Reproduce rate  0/5
Refer to video from comment 17

Comment 18

5 years ago
Posted video VIDEO0266.mp4
Flags: in-moztrap+
This bug is verified fixed on Flame 3.0

When selecting calls in the call log there is no overlapping and is properly selected.

Environmental Variables:
Device: Flame 3.0 (319mb)(Kitkat)(Full Flash)
Build ID: 20150205010209
Gaia: 2b83a6d5d1185a438b5bbd287497ac2743b501db
Gecko: 34a66aaaca81
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?][rtl-impact]
Flags: needinfo?(pbylenga)
QA Whiteboard: [QAnalyst-Triage?][rtl-impact] → [QAnalyst-Triage+][rtl-impact]
Flags: needinfo?(pbylenga)
You need to log in before you can comment on or make changes to this bug.