Closed Bug 906270 (gaia-rtl) Opened 8 years ago Closed 3 years ago

Support RTL language for B2G (tracker bug)

Categories

(Firefox OS Graveyard :: General, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(b2g-v2.0 affected, b2g-v2.1 affected)

RESOLVED WONTFIX
Tracking Status
b2g-v2.0 --- affected
b2g-v2.1 --- affected

People

(Reporter: arky, Unassigned)

References

()

Details

(Keywords: rtl)

Attachments

(1 file, 2 obsolete files)

This bug tracks all the issues to support RTL languages on B2G.
Depends on: 903733
Depends on: 906273
Blocks: 893530
Adding Madhava Enros to this bug. He's leading a student team developing bidirectional text for Firefox for Android. Perhaps there could be some overlap between this and his team's efforts.
Blocks: 905292
No longer blocks: 905292
I'm adding building blocks' bugs that call to visually support RTL. 'Cause Supporting RTL languages by getting B2G strings localized is not enough if we're targeting a specific version, we have plenty of visual bugs. But I can not promise those (visual) bugs will land for 1.2 ..
Blocks: 905292
Depends on: 895875, 883673, 834464
No longer blocks: 905292
(In reply to Ahmed Nefzaoui [:Nefzaoui] from comment #2)
> I'm adding building blocks' bugs that call to visually support RTL. 'Cause
> Supporting RTL languages by getting B2G strings localized is not enough if
> we're targeting a specific version, we have plenty of visual bugs. But I can
> not promise those (visual) bugs will land for 1.2 ..

I don't think there's the need for this to be landed in 1.2 as there are no RTL locales requested for v1.2 (see Bug 905292)
(In reply to delphine from comment #3)
> I don't think there's the need for this to be landed in 1.2 as there are no
> RTL locales requested for v1.2 (see Bug 905292)

It is in the best interest of the community members of RTL languages. Let try to fix these issues.
(In reply to arky [:arky] from comment #4)
> (In reply to delphine from comment #3)
> > I don't think there's the need for this to be landed in 1.2 as there are no
> > RTL locales requested for v1.2 (see Bug 905292)
> 
> It is in the best interest of the community members of RTL languages. Let
> try to fix these issues.

I don't think Delphine is saying that it isn't an issue, just that it's not critical to the 1.2 release. Likely something that can still be developed on the master branch. Wondering if Madhava is looking into this with his RTL student team in addition to the Fennec RTL issue?
Depends on: 926084
While working on localization and fixing visual RTL bugs.. I have no idea about which version of Firefox OS will have Arabic... Can someone share that info with me please?
(In reply to Ahmed Nefzaoui [:Nefzaoui] from comment #6)
> While working on localization and fixing visual RTL bugs.. I have no idea
> about which version of Firefox OS will have Arabic... Can someone share that
> info with me please?

That has yet to be determined, but this bug is very much a blocker to determining it.
Depends on: 834195
Depends on: 938098
Depends on: 938100
Depends on: 900182
Depends on: 934926
Alias: gaia-rtl
Blocks: 952732
No longer blocks: 893530
Depends on: 893530
Depends on: 833401
Depends on: 964033, 964034, 964035, 964036, 964037
OS: Linux → Gonk (Firefox OS)
Hardware: x86_64 → ARM
Depends on: 925706
Depends on: 928138
Depends on: 945542
Depends on: 868549
Depends on: 796423
Depends on: 913952
Depends on: 796546
Duplicate of this bug: 815926
Depends on: 876825
Depends on: 874368
Depends on: 928637
Depends on: 876839
Depends on: 888815
Depends on: 796545
In mine scope, all you need to do is to add HTML attribute dir=auto
Keywords: rtl
Depends on: 978581
Duplicate of this bug: 796546
Depends on: 985165
Depends on: 993089
Depends on: 998917
Depends on: 1000094
Depends on: 1008013
IMO since RTL work doesn't seem to be landing for anything earlier than 2.0 and knowing that Firefox OS 2.0 will have a different Homescreen approach Bug 989848, we should close all bugs related to the current (Horizontal-scrolling) homescreen.
Depends on: 1010471
Depends on: 1010591
Depends on: 1010613
Depends on: 1010615
Depends on: 1011183
Depends on: 1011251
Depends on: 1011272
Depends on: 1011318
Depends on: 1011594
Depends on: 1011731
Depends on: 1012804
Depends on: 1001998
Depends on: 1011329
Depends on: 1011066
Depends on: 1020522
Depends on: 1020524
Depends on: 1020525
Depends on: 1020531
Depends on: 1020533
Depends on: 1028701
Depends on: 1031015
Depends on: 1031214
Depends on: 921965
Depends on: 1033917
No longer depends on: 1031214
Depends on: 1036833
Depends on: 1037146
Depends on: 1037149
Depends on: 1037153
Depends on: 1037602
Depends on: 1037603
Depends on: 1037606
Depends on: 1037607
Depends on: 1037608
Depends on: 1037755
Depends on: 1039186
Depends on: 1041277
Depends on: 981598
Depends on: 1043563
Depends on: 1047711
Depends on: 1048477
Depends on: 1048627
Depends on: 1048603
Depends on: 1048588
Depends on: 1050615
Depends on: 1053708
Depends on: 1053709
Depends on: 1056017
Depends on: 1058692
Depends on: 1058681
Depends on: 1058693
Depends on: 1058723
Depends on: 1058730
Depends on: 1058743
Depends on: 1058752
Depends on: 1058757
Depends on: 1058760
Depends on: 1058762
Depends on: 1058697
Depends on: 1058770
Depends on: 1058781
Depends on: 1058790
Depends on: 1058792
Depends on: 1059107
Depends on: 1059017
Depends on: 1059379
Depends on: 1062967
Depends on: 1062964
Depends on: 1063406
Depends on: 1064148
Depends on: contacts-rtl
Depends on: system-rtl
Depends on: 1064562
No longer depends on: 1064562
Depends on: messages-rtl
Depends on: 1064581
Depends on: 1064584
Depends on: calendar-rtl
Depends on: email-rtl
No longer depends on: 1058742
No longer depends on: 1064148
No longer depends on: 1059017
No longer depends on: 1058770
No longer depends on: 874368
No longer depends on: 1053708
No longer depends on: 1053709
Depends on: 1070461
Depends on: homescreen-rtl
Depends on: music-rtl
Depends on: settings-rtl
Depends on: keyboard-rtl
Depends on: dialer-rtl
No longer depends on: 921965
No longer depends on: 994076
No longer depends on: 1059107
No longer depends on: 1064584
No longer depends on: 868549
No longer depends on: 1011251
No longer depends on: 1011272
No longer depends on: 1039186
Depends on: camera-rtl
No longer depends on: 1058790
No longer depends on: 1058762
No longer depends on: 1048627
No longer depends on: 994045
No longer depends on: 1044266
No longer depends on: 1044285
No longer depends on: 1064581
Depends on: 1073489
No longer depends on: 1058730
No longer depends on: 1058752
No longer depends on: 1058727
No longer depends on: 1011731
No longer depends on: 1012804
No longer depends on: 1010613
No longer depends on: 1056017
No longer depends on: 1036833
No longer depends on: 1037603
No longer depends on: 1070461
No longer depends on: 925706
Depends on: 1082541
Depends on: gallery-rtl
Depends on: clock-rtl
No longer depends on: 1058723
Depends on: cost-control-rtl
Depends on: video-rtl
Depends on: ringtones-rtl
No longer depends on: 1058697
Depends on: 1096572
No longer depends on: 1011183
No longer depends on: 1047711
No longer depends on: 1058693
No longer depends on: 1058704
No longer depends on: 1058792
No longer depends on: 1058781
Attached file BiDi_20141105.pdf (obsolete) —
Attached is the UX pattern that the Firefox OS interface (all apps) should follow for Arabic.
Depends on: fmradio-rtl
Depends on: 1082060
Depends on: rocketbar-rtl
Depends on: status-bar-rtl
Comment on attachment 8520280 [details]
BiDi_20141105.pdf

Please see this URL for the latest UX bidi document:
https://mozilla.app.box.com/s/0y1amh4rwpp6brcxd1hk
Attachment #8520280 - Attachment is obsolete: true
Depends on: browser-window-rtl
Depends on: search-rtl
Depends on: FTE-rtl
Depends on: system-dialog-rtl
Depends on: utility-tray-rtl
No longer depends on: rocketbar-rtl
No longer depends on: status-bar-rtl
No longer depends on: browser-window-rtl
No longer depends on: search-rtl
No longer depends on: system-dialog-rtl
No longer depends on: utility-tray-rtl
No longer depends on: upgrade-tutorial-rtl
No longer depends on: FTE-rtl
No longer depends on: 1058757
No longer depends on: 1033917
feature-b2g: --- → 2.2+
Depends on: 1102491
No longer depends on: 1037755
No longer depends on: 1108708
feature-b2g: 2.2+ → ---
No longer depends on: 1034210
No longer depends on: 796423
No longer depends on: 833401
No longer depends on: 876839
No longer depends on: 938098
No longer depends on: 945542
No longer depends on: 964034
No longer depends on: 964035
No longer depends on: 964036
No longer depends on: 994053
No longer depends on: 994059
No longer depends on: 994242
No longer depends on: 998917
No longer depends on: 926084
No longer depends on: 1008013
No longer depends on: 1010471
No longer depends on: 906273
No longer depends on: 1010585
No longer depends on: 1010591
No longer depends on: 1010615
No longer depends on: 1011066
No longer depends on: 1031015
No longer depends on: 1020524
No longer depends on: 1020525
No longer depends on: 1011594
No longer depends on: 1020531
No longer depends on: 1020533
No longer depends on: 1037146
No longer depends on: 1037149
No longer depends on: 1037153
No longer depends on: 1037602
No longer depends on: 1037606
No longer depends on: 1037607
No longer depends on: 1037608
No longer depends on: 1041277
No longer depends on: 1043563
No longer depends on: 1044261
No longer depends on: 1044274
No longer depends on: 1044299
No longer depends on: 1048477
No longer depends on: 1048588
No longer depends on: 1048603
No longer depends on: 1050615
No longer depends on: 1058681
No longer depends on: 1058692
No longer depends on: 1058702
No longer depends on: 1058743
No longer depends on: 1059379
No longer depends on: 1062964
No longer depends on: 796545
No longer depends on: 834195
No longer depends on: 903733
No longer depends on: 913952
No longer depends on: 964033
No longer depends on: 964037
No longer depends on: 1000094
No longer depends on: 1063406
No longer blocks: 952732
Depends on: 952732
Depends on: 1126606
Depends on: 1126630
Depends on: 1132230
Depends on: 1139306
This is latest 2.2 spec from box.com.
Attachment #8548340 - Attachment is obsolete: true
Attachment #8629248 - Attachment mime type: application/download → application/pdf
To everyone's knowledge, RTL support for 2.5 is to be tracked on bug 1179459.
Thanks!
Ahmed, should we close this bug then ?
(In reply to Julien Wajsberg [:julienw] from comment #18)
> Ahmed, should we close this bug then ?

Not sure whether there are/will still be people working on pre-2.5, I'm guessing we should keep it open just in case.
Updating spec link to point at our latest (2.5) spec.
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.