Closed Bug 1011519 Opened 6 years ago Closed 6 years ago

Use pseudolocales for testing

Categories

(Firefox OS Graveyard :: Gaia::L10n, defect, P4)

defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: stas, Assigned: stas)

References

Details

Attachments

(1 file, 1 obsolete file)

Once the pseudolocalizations work lands (bug 900182) we should be able to remove the existing Arabic, French and Traditional Chinese localization files from the Gaia repo.

Théo has been keeping them up-to-date lately (thanks!) but I think we should prefer the automatically-built pseudolocalization anyways.

Note that this only affects custom developer builds.  Builds that you can download from Mozilla's or Geeksphone's FTP specify LOCALES_FILE and LOCALE_BASEDIR to point to the translations in hg, so A) they will continue shipping with these locales (and then some) and B) they aren't using the files checked into the Gaia tree anyways.
I'm really excited about pseudolocalizations, definitely the right thing to do :)

And this will end the confusion between the fake translations and the real ones.
Depends on: 1012702
Priority: -- → P4
Assignee: nobody → stas
Depends on: 1041565
Depends on: 1015041
WIP: https://github.com/mozilla-b2g/gaia/pull/22167

I removed Arabic, French and Traditional Chinese from shared/resources/languages.json and fixed Marionette tests for Settings and Verticalhome.
My latest push to try looks promising, only one intermittent failure:

https://tbpl.mozilla.org/?rev=3ae10ddb7c8b&tree=Gaia-Try
(Which probably isn't intermittent, but something I need to fix.)
Blocks: 995169
stas, are you working on other bugs before fixing this one?
Flags: needinfo?(stas)
I was waiting for bug 1022767 to land, not b/c it's a strict dependency, but b/c I wanted to avoid bitrot.  I'll be looking into this bug soon (this week).
Flags: needinfo?(stas)
This was not the URL I was looking for.  New WIP PR: https://github.com/mozilla-b2g/gaia/pull/25308
Blocks: 1099321
I filed bug 1099321 to track the removal of actual *.{ar,fr,zh-TW}.properties files once this bug is fixed.
Summary: Remove ar, fr and zh-TW from Gaia source repo → Disable ar, fr and zh-TW in Gaia dev builds
In the mean time, to avoid the huge confusion for people dogfooding, would it be possible to land a dumb fix to update the name of the locales? I see quite a lot of people testing those fake locales  instead of the real ones :(

Like for instance in Settings, display:

Arabic (fake)
English
French (fake)
...

Or will it break tests?
I think there are multiple places which check for the name of the language in tests, yes.  That's what I already changed in my pull request which I'm about to submit for review.  I think we're close enough to disabling those additional languages entirely that it's not worth the effort of any temporary solution :)
https://github.com/mozilla-b2g/gaia/pull/25308
https://treeherder.mozilla.org/ui/#/jobs?repo=gaia-try&revision=3c0cf898932d

I'm still seeing one failure in Treeherder which I can't reproduce locally, but otherwise this is good for a review.
Attachment #8523192 - Flags: review?(gandalf)
Comment on attachment 8523192 [details] [diff] [review]
Disable ar, fr, zh-TW and use pseudolocales for testing

Review of attachment 8523192 [details] [diff] [review]:
-----------------------------------------------------------------

lgtm!

::: tests/python/gaia-ui-tests/gaiatest/apps/settings/app.py
@@ +2,5 @@
>  # License, v. 2.0. If a copy of the MPL was not distributed with this
>  # file, You can obtain one at http://mozilla.org/MPL/2.0/.
>  
>  from marionette.by import By
> +

empty line
Attachment #8523192 - Flags: review?(gandalf) → review+
Morphing this bug one more time:

 1. First, let's migrate all tests to use runtime pseudolocales (this bug).
 2. Then, let's make it possible to build pseudolocales on build-time (bug 1101632).
 3. Finally, let's disable and remove ar, fr and zh-TW from the source repo.
Summary: Disable ar, fr and zh-TW in Gaia dev builds → Use pseudolocales for testing
I thought this was almost ready, but I've hit a roadblock in Gij:

https://treeherder.mozilla.org/ui/#/jobs?repo=gaia-try&revision=5dbd8a1f5f96

I can't reproduce this locally.  Investigating...
Attached patch Patch 2Splinter Review
I was finally able to get a green build.  I think that bug 1102138 helped here as the failures I was seeing were related to returning from the Language panel to the root panel in Settings when the current locale was Mirrored English (qps-plocm, i.e. Fake RTL).

https://github.com/mozilla-b2g/gaia/pull/25308
https://treeherder.mozilla.org/ui/#/jobs?repo=gaia-try&revision=7e859a5e23e2

Carrying over Gandalf's r+.  Kevin, do you have time to take a look at this as well?
Attachment #8523192 - Attachment is obsolete: true
Attachment #8528391 - Flags: review?(kgrandon)
Comment on attachment 8528391 [details] [diff] [review]
Patch 2

Review of attachment 8528391 [details] [diff] [review]:
-----------------------------------------------------------------

Homescreen bits look fine to me, but I think you should also get a review by a settings peer.

::: apps/verticalhome/test/marionette/lib/home2.js
@@ +287,5 @@
>        entryPoint = null;
>      }
>  
> +    var chromeClient = this.client.scope({context: 'chrome'});
> +    var contentClient = this.client.scope({context: 'content'});

Do we need this? Can we just use this.client here?
Attachment #8528391 - Flags: review?(kgrandon)
Attachment #8528391 - Flags: review?(arthur.chen)
Attachment #8528391 - Flags: review+
Comment on attachment 8528391 [details] [diff] [review]
Patch 2

Review of attachment 8528391 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good, thanks. r=me.
Attachment #8528391 - Flags: review?(arthur.chen) → review+
(In reply to Kevin Grandon :kgrandon from comment #17)

> > +    var chromeClient = this.client.scope({context: 'chrome'});
> > +    var contentClient = this.client.scope({context: 'content'});
> 
> Do we need this? Can we just use this.client here?

You're right, I'll change this before merging.
Master: https://github.com/mozilla-b2g/gaia/commit/caa6dd8e6c5abfef557bfe0794d7e1c2088d25da
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
No longer blocks: 995169
You need to log in before you can comment on or make changes to this bug.