Closed Bug 1102138 Opened 5 years ago Closed 5 years ago

[gaia-header] Should no longer reverse content in RTL mode

Categories

(Firefox OS Graveyard :: Gaia::Components, defect)

x86
macOS
defect
Not set

Tracking

(b2g-v2.2 verified)

VERIFIED FIXED
2.2 S1 (5dec)
Tracking Status
b2g-v2.2 --- verified

People

(Reporter: wilsonpage, Assigned: wilsonpage)

References

Details

(Whiteboard: [ft:media])

Attachments

(2 files)

No description provided.
No longer blocks: 1095829
Blocks: 1095838
Blocks: 1095837
See Also: → 1102132
Blocks: 1095829
Duplicate of this bug: 1095829
Duplicate of this bug: 1102150
Attached file pull-request (master)
Updates gaia-header to v0.5.0, which includes the removal of RTL logic.
Attachment #8526711 - Flags: review?(felash)
Comment on attachment 8526711 [details] [review]
pull-request (master)

r=me with the small nits and one question to answer about calculating shadowCss.

I'm always wary of executing things when the script is just executed, but since it's not the goal of this patch let's move forward and handle this separately.

Maybe we should ask a review from a peer for Music as well?
Attachment #8526711 - Flags: review?(felash) → review+
Whiteboard: [ft:media]
Target Milestone: --- → 2.2 S1 (5dec)
Comment on attachment 8526711 [details] [review]
pull-request (master)

Updated patch to address comments. Just waiting on green.
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Duplicate of this bug: 1098366
Blocks: music-rtl
Duplicate of this bug: 1102360
Landed in Gaia master: 2cb461dde5b9430ed87919e768de8c1cea503db6
Mmm sorry, wrong bug, forget me :)
Depends on: 1115173
Keywords: verifyme
Attached image Screenshot
This problem is verified pass on latest build of Flame2.2. On Contacts list view, the header is not reverse in RTL mode.
See attachment: English&Arabic_Screenshot.PNG
Reproduce rate 0/5

Flame 2.2 build:
Gaia-Rev        0518f4581a0925c0b703d730ef289ab15cbd1216
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/c6aa604a7967
Build-ID        20150126002536
Version         37.0a2
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150126.042138
FW-Date         Mon Jan 26 04:21:49 EST 2015
Bootloader      L1TC000118D0
Status: RESOLVED → VERIFIED
Keywords: verifyme
QA Whiteboard: MGSEI-Triage+
Test case has been added in moztrap:
https://moztrap.mozilla.org/manage/case/15382/
Flags: in-moztrap+
You need to log in before you can comment on or make changes to this bug.