Closed Bug 1012483 Opened 5 years ago Closed 4 years ago

nike.com doesn't serve the mobile content to Firefox OS

Categories

(Web Compatibility :: Mobile, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: karlcow, Assigned: karlcow, Mentored)

References

()

Details

(Whiteboard: [mobile-compat-form] [country-all] [clientsniff] [sitewait] )

Attachments

(2 files)

Site: http://nike.com/
nike.com doesn't serve the mobile content to Firefox OS

:: Steps To Reproduce

1. With Firefox OS on Flame
2. Go http://nike.com/


:: Expected Result

Receive the mobile content like Firefox on Android

:: Actual Result

receiving Desktop content

:: Additional Information

Software Version: 1.4
Device Information: Flame
Reporter's User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:31.0) Gecko/20100101 Firefox/31.0
Their Web site is a giant… JavaScript.
http://store.nike.com/NikeScriptManager.js

which is loading a lot of assets.

<script type="text/javascript" src="http://store.nike.com/NikeScriptManager.js?assets=nike,jQuery,nike.ScriptLoader,nike.EventBus,nike.page.OneNikeShell,nike.page.OneNikePageLayout,nike.fonts.glyphPolyfill,nike.exp.global.Ad,nike.exp.global.FunctionalAndPerformance,nike.style.exp.exp-desktop,nike.style.nsg.nsg-desktop,nike.style.nsg.font.desktop-font-en_us&assetType=SCRIPT&buildRev=206632"></script>

It creates a first redirection to the country specific site: Here Japan
http://www.nike.com/jp/ja_jp/

Then it loads other assets such as 
http://store.nike.com/common/scripts/device_detect.js?buildRev=206632

If it's a mobile device it will redirect to m.nike.com. The part of the script where the mobile device is identified.

    nike.exp.script.device_detect.isMobile = function () {
        b('UserAgent: ' + navigator.userAgent);
        nike.exp.script.device_detect._isMobile = /iPhone|iPod|Windows Phone|IEMobile/i.test(navigator.userAgent) || /android.*mobile/i.test(navigator.userAgent);
        return nike.exp.script.device_detect._isMobile
    };

Suggestion to fix:

    nike.exp.script.device_detect.isMobile = function () {
        b('UserAgent: ' + navigator.userAgent);
        nike.exp.script.device_detect._isMobile = /mobile/i.test(navigator.userAgent) && !(/ipad/i.test(navigator.userAgent));
        return nike.exp.script.device_detect._isMobile
    };



This is the list of countries where they have a Web site.

Africa http://www.nike.com/xf/en_gb/
Argentina http://www.nike.com/ar/es_ar/
Australia http://www.nike.com/au/en_gb/
Belgium http://www.nike.com/be/en_gb/
Brasil http://www.nike.com/br/pt_br/
Canada http://www.nike.com/ca/en_ca/
Czech Republic http://www.nike.com/cz/en_gb/
Denmark http://www.nike.com/dk/en_gb/
Deutschland http://www.nike.com/de/de_de/
España http://www.nike.com/es/es_es/
Finland http://www.nike.com/fi/en_gb/
France http://www.nike.com/fr/fr_fr/
Greece http://www.nike.com/gr/en_gb/
Hong Kong http://www.nike.com/hk/en_gb/
Hungary http://www.nike.com/hu/en_gb/
India http://www.nike.com/in/en_gb/
Indonesia http://www.nike.com/id/en_gb/
Ireland http://www.nike.com/ie/en_gb/
Israel http://www.nike.com/il/en_gb/
Italia http://www.nike.com/it/it_it/
Latin America http://www.nike.com/xl/es_la/
Luxembourg http://www.nike.com/lu/en_gb/
Malaysia http://www.nike.com/my/en_gb/
Middle East http://www.nike.com/xm/en_gb/
México http://www.nike.com/mx/es_la/
Netherlands http://www.nike.com/nl/en_gb/
New Zealand http://www.nike.com/nz/en_gb/
Norway http://www.nike.com/no/en_gb/
Philippines http://www.nike.com/ph/en_gb/
Poland http://www.nike.com/pl/en_gb/
Portugal http://www.nike.com/pt/en_gb/
Singapore http://www.nike.com/sg/en_gb/
Slovenia http://www.nike.com/si/en_gb/
Sweden http://www.nike.com/se/en_gb/
Switzerland http://www.nike.com/ch/en_gb/
Thailand http://www.nike.com/th/th_th/
Turkey http://www.nike.com/tr/tr_tr/
United Kingdom http://www.nike.com/gb/en_gb/
United States http://www.nike.com/us/en_us/
Österreich http://www.nike.com/at/de_de/
Россия http://www.nike.com/ru/ru_ru/
中国大陆 http://www.nike.com/cn/zh_cn/
台灣 http://www.nike.com/tw/zh_tw/
日本 http://www.nike.com/jp/ja_jp/
대한민국 http://www.nike.com/kr/ko_kr/
Blocks: 1011341
Status: UNCONFIRMED → NEW
Ever confirmed: true
Hardware: Other → ARM
Whiteboard: [mobile-compat-form] → [mobile-compat-form] [country-all] [clientsniff] [contactready] [mentor=kdubost]
Mentor: kdubost
Whiteboard: [mobile-compat-form] [country-all] [clientsniff] [contactready] [mentor=kdubost] → [mobile-compat-form] [country-all] [clientsniff] [contactready]
Mentor: kdubost
Duplicate of this bug: 1037253
1st attempt at a human contact
http://twitter.com/MozWebCompat/status/499075575848255489
Assignee: nobody → kdubost
Mentor: kdubost
Status: NEW → ASSIGNED
Whiteboard: [mobile-compat-form] [country-all] [clientsniff] [contactready] → [mobile-compat-form] [country-all] [clientsniff] [sitewait]
Hey guys,

I opened a ticket on our end and will look into it. Where can we pick up test devices?
Hi Zac, thanks! You can purchase a reference Flame device here: <https://developer.mozilla.org/en-US/Firefox_OS/Developer_phone_guide/Flame> or you can use the App Manager with a Simulator: <https://developer.mozilla.org/en-US/Firefox_OS/Using_the_App_Manager>.
Hi Mike,

We're doing some testing with the simulator now.

Thanks!
Hello,

We've changed our device detection and Firefox OS will be included and served mobile content. This should be in production in 6-8 weeks.
Fix is live indeed :)
Thank you Zac!
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
No problem!
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.