The default bug view has changed. See this FAQ.

Create mozilla-esr31 branch

RESOLVED FIXED

Status

Release Engineering
General Automation
P2
normal
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: rail, Assigned: massimo)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(7 attachments, 1 obsolete attachment)

(Reporter)

Description

3 years ago
+++ This bug was initially created as a clone of Bug #913195 +++

Like bug 913195 and bug 796995, but for esr31 this cycle.
(Reporter)

Updated

3 years ago
Blocks: 1012648
(Reporter)

Updated

3 years ago
Assignee: nobody → mgervasini
(Assignee)

Updated

3 years ago
Depends on: 1030208
(Assignee)

Updated

3 years ago
Depends on: 1030143, 1030150
(Assignee)

Updated

3 years ago
Depends on: 1030224
(Assignee)

Updated

3 years ago
Depends on: 1030240
(Assignee)

Updated

3 years ago
Depends on: 1030274
(Assignee)

Comment 1

3 years ago
Created attachment 8448431 [details] [diff] [review]
tools-esr31.patch

tools changes for esr31
Attachment #8448431 - Flags: review?(nthomas)
(Assignee)

Comment 2

3 years ago
Created attachment 8448432 [details] [diff] [review]
buildbot-configs-esr31.patch

buildbot-configs changes for esr31
Attachment #8448432 - Flags: review?(nthomas)
Comment on attachment 8448431 [details] [diff] [review]
tools-esr31.patch

>diff --git a/buildbot-helpers/mozconfig_whitelist b/buildbot-helpers/mozconfig_whitelist

I'm not sure if this will work or not, have you tested ? I'll r+ for the rest and ask you check it out. There's reasonable chance that copying the whitelist from esr24 will have missed changes on release in the meantime. We have this funny mismash of release sanity checks, and the in-tree mozconfigs and whitelist (see browser/config/mozconfigs/whitelist, which we verify each time 'make check' is run on a dep build). 

>diff --git a/scripts/preproduction/repo_setup_config.py b/scripts/preproduction/repo_setup_config.py

Don't worry about this one, preproduction is deader than a dead thing.
Attachment #8448431 - Flags: review?(nthomas) → review+
Comment on attachment 8448432 [details] [diff] [review]
buildbot-configs-esr31.patch

Nearly there, but needs a few minor fixes.

>diff --git a/mozilla-tests/config.py b/mozilla-tests/config.py
>+BRANCHES['mozilla-esr31']['xperf_tests'] = (0, False, TALOS_TP_NEW_OPTS, WIN7_ONLY)

Strongly suspect this was set for esr24 because xperf wasn't supported on 24. We do have it enabled on beta so lets remove this line.

>diff --git a/mozilla/config.py b/mozilla/config.py
>+    'mozilla-esr31': {
>+        'branch_projects': [],
>+        'lock_platforms': True,
>+        'gecko_version': 31,
>+        'platforms': {
>+            'linux': {},
>+            'linux64': {},
...

We may need android-armv6 here too. Check with coop on the status of dropping Android 2.2 support.

>diff --git a/mozilla/master_common.py b/mozilla/master_common.py
> BRANCH_PRIORITIES = {
>     'mozilla-release': 0,
>     'comm-esr24': 0,
>+    'comm-esr31': 0,
>     'mozilla-esr24': 1,

Please change this to mozilla-esr31.

>diff --git a/mozilla/preproduction_config.py b/mozilla/preproduction_config.py
>diff --git a/mozilla/preproduction_release_overrides-esr31.py b/mozilla/preproduction_release_overrides-esr31.py

Can leave both of these out, the parrot is dead. [http://www.youtube.com/watch?v=npjOSLCR2hE]

>diff --git a/mozilla/staging_release-firefox-mozilla-esr24.py b/mozilla/staging_release-firefox-mozilla-esr31.py

Needs the js/src/config/milestone.txt removal from bumpFiles; the template does too. Might find some other things if you diff against the template.

>diff --git a/mozilla/staging_release-firefox-mozilla-esr24.py b/mozilla/staging_release-firefox-mozilla-esr31.py.template
>similarity index 77%
>copy from mozilla/staging_release-firefox-mozilla-esr24.py
>copy to mozilla/staging_release-firefox-mozilla-esr31.py.template

Ooof, did this one the hard way ;-)

>diff --git a/setup-master.py b/setup-master.py
>                     [('staging_release-thunderbird-comm-%s.py' % v,
>                       'release-thunderbird-comm-%s.py' % v)
>-                        for v in ['beta', 'release', 'esr24']
>+                        for v in ['beta', 'release', 'esr24', 'esr31']

This will likely break test-masters.sh, as the release configs aren't being added by the patch. It's fine to leave comm-esr31 to other patches.
Attachment #8448432 - Flags: review?(nthomas) → review-
(Assignee)

Comment 5

3 years ago
Created attachment 8449743 [details] [diff] [review]
esr31-buildbot-configs.patch

Thanks for the review, nthomas. Here's an updated version of the patch
Attachment #8448432 - Attachment is obsolete: true
Attachment #8449743 - Flags: review?(nthomas)

Updated

3 years ago
Attachment #8449743 - Flags: review?(nthomas) → review+
(Assignee)

Updated

3 years ago
Attachment #8448431 - Flags: checked-in+
(Assignee)

Updated

3 years ago
Attachment #8449743 - Flags: checked-in+
(Assignee)

Comment 6

3 years ago
Created attachment 8450356 [details] [diff] [review]
esr31-firefox-mozilla-esr31.patch

added mozilla/release-firefox-mozilla-esr31.py, added releaseConfig['skip_updates'] = True in mozilla/release-firefox-mozilla-esr31.py.template
Attachment #8450356 - Flags: review?(rail)
(Reporter)

Updated

3 years ago
Attachment #8450356 - Flags: review?(rail) → review+
(Assignee)

Updated

3 years ago
Attachment #8450356 - Flags: checked-in+

Comment 7

3 years ago
Merged to production, and deployed.
(Assignee)

Comment 8

3 years ago
Created attachment 8452404 [details] [diff] [review]
[buildbot-configs] Bug 1012647 - add mozconfig for esr31.patch

Added mozilla2/linux/mozilla-esr31/release/mozconfig as a copy of esr24
Attachment #8452404 - Flags: review?(rail)
(Reporter)

Comment 9

3 years ago
Comment on attachment 8452404 [details] [diff] [review]
[buildbot-configs] Bug 1012647 - add mozconfig for esr31.patch

stamp
Attachment #8452404 - Flags: review?(rail) → review+
(Assignee)

Updated

3 years ago
Attachment #8452404 - Flags: checked-in+
(Assignee)

Comment 10

3 years ago
Created attachment 8453927 [details] [diff] [review]
[tools] Bug 1012647 - updated mozconfig_whitelist for esr31.patch

updated mozconfig_whitelist file needed by the esr31 staging release
Attachment #8453927 - Flags: review?(rail)
(Reporter)

Updated

3 years ago
Attachment #8453927 - Flags: review?(rail) → review+
(Assignee)

Comment 11

3 years ago
Created attachment 8453945 [details] [diff] [review]
[buildbot-configs] Bug 1012647 - Disable partial updates for esr31 first release.patch

this patches removes the partialUpdates because the first esr31 has none. The skip_update is at the top with a hug HACK ALERT and must be removed after this release
Attachment #8453945 - Flags: review?(rail)
(Reporter)

Updated

3 years ago
Attachment #8453945 - Flags: review?(rail) → review+
(Assignee)

Updated

3 years ago
Attachment #8453945 - Flags: checked-in+
(Assignee)

Updated

3 years ago
Attachment #8453927 - Flags: checked-in+
(Assignee)

Updated

3 years ago
Depends on: 1037175
Merged to production, and deployed.
No longer depends on: 1037175
So is this branch already up-to-date or do we still have to push the latest state from the mozilla-release branch (from after todays merge) to it?
(Reporter)

Comment 14

3 years ago
I pulled new changes from mozilla-release after the merge push and applied this patch on top of default to update the branding:

http://hg.mozilla.org/releases/mozilla-esr31/rev/450086c0ded0
Looks like we need the equivalent patch to
  http://hg.mozilla.org/releases/mozilla-release/diff/d33428174ff1/browser/confvars.sh
(Reporter)

Comment 16

3 years ago
Created attachment 8455644 [details] [diff] [review]
update channel
Attachment #8455644 - Flags: review?(nthomas)

Updated

3 years ago
Attachment #8455644 - Flags: review?(nthomas) → review+
(Reporter)

Comment 17

3 years ago
Comment on attachment 8455644 [details] [diff] [review]
update channel

https://hg.mozilla.org/releases/mozilla-esr31/rev/e91c79c4c04b
Attachment #8455644 - Flags: checked-in+
(Reporter)

Updated

3 years ago
Depends on: 1039559
(Assignee)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.