Closed Bug 1013382 Opened 8 years ago Closed 8 years ago

Add a way to notify the other devices the call was answered or rejected in a multi-device scenario

Categories

(Hello (Loop) :: Server, defect)

defect
Not set
normal

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 1025872

People

(Reporter: alexis+bugs, Unassigned)

References

Details

Once multiple devices will be supported, we will need to notify all other devices the call was answered when one device picked up / rejected the call.

There are multiple ways to solve this problem:

- Either we let the client poll on the status of the call (we currently have a GET /calls/id/:callId endpoint, so that will support that); If we do that, we would need to store another information in the call, which is that the call was rejected / accepted.

- We could put this information in the list of calls we get from the server, and register as a different "app" on the simple push server.
Blocks: 1003170
Depends on: 1015087
I believe that when the clients are notified about a new call, they could start listening on the same endpoint the caller listens to, in order to know if the call was answered or not.

This is the same solution that will be used in bug 1015087
Depends on: 1025872
No longer depends on: 1015087
Summary: Add a way to notify the other devices the call was answered. → Add a way to notify the other devices the call was answered or rejected in a multi-device scenario
When all devices connect they will receive the broadcast messages of progress/states.
They should stop ringing when receiving a progress/connecting.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1025872
OK.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.