Moving the scroll bar in the Folder sidebar clears out the thread pane

VERIFIED DUPLICATE of bug 9029

Status

defect
P3
normal
VERIFIED DUPLICATE of bug 9029
20 years ago
3 years ago

People

(Reporter: lchiang, Assigned: hyatt)

Tracking

Trunk
All
Windows NT
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PR1])

Moving the scroll bar in the Folder sidebar clears out the thread pane

Build: 1999071911 release build
Windows NT 4.0
Have not tried the other platforms yet

Setup: have enough mail folders / accounts to cause a scroll bar to appear in
the sidebar for Messenger Folders

1) Start Messenger
2) Set to display the sidebar area
3) Open one of your mail accounts and select a folder such as the Inbox
4) In the thread pane, the message listing of your Inbox messages appear
5) Go back to the sidebar and click the down arrow in the scroll bar for the
Messenger Folders.

Actual Results:  The message listing in the thread pane disappears.  You must
select another folder and reselect in order to see the message listing again.
Resiziing the window does not help.

Expected Results:  The message listing in the thread pane should remain
untouched because in step 5, I don't select another folder; I'm just scrolling
the folder list.
QA Contact: lchiang → nbaca
Hardware: PC → All
fyi

This problem also occurs in today Mac commercial seamonkey build (1999-07-19-11-

m9)

Changing platform to All.



Note: have not tried linux.
fyi,
Problem also occurs on today linux build (1999-07-19-11-m9)
Assignee: putterman → hyatt
reassigning to hyatt.  I imagine this is a scrollbar/tree problem.
Linux 91999-07-19-11 m9)
I see it on Linux too.
Target Milestone: M9
Blocks: 11091
Moving to M10.
Status: NEW → ASSIGNED
Whiteboard: [PR1]
Sounds like this needs to be fixed for PR1, so I added a note to the Status
Whiteboard
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
This is a dup of 9029... the scrollbar events are bubbling up to your event
handler.  If you actually put a type check in your event handler to verify that
the clicks are happening on treecells (and screen out the scrollbar), then you
could work around this problem.


*** This bug has been marked as a duplicate of 9029 ***
Status: RESOLVED → VERIFIED
marking as verified.  I added a comment in the other bug to verify the mail
case.  Also added the other bug to the dependency list since this one has it.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.