Implement form autocomplete (aka what Win IE 5.5 & Mac IE 5 has)

VERIFIED DUPLICATE of bug 60861

Status

()

Core
Layout: Form Controls
--
enhancement
VERIFIED DUPLICATE of bug 60861
17 years ago
17 years ago

People

(Reporter: Julian Hsiao, Assigned: Stephen P. Morse)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:0.9.4+) Gecko/20010921
BuildID:    2001092108

One feature that I miss very much in Mozilla is the lack of form autocomplete,
the same mechanism used in the location bar.  In short, what IE has.

Interesting enough, IE 5.5 for Windows has a different mechanism than IE 5 for
Macs; IE 5.5 builds the autocomplete list by remembering the most recent entries
(which gets reset when quit), while IE 5 needs its users to input the
autocomplete list beforehand (but stays permanent).

What would be best in my mind would be the combination of both behaviors: have a
permanent list that's created by the user, and a dynamic list that's generated
automatically but disappears when quit.
(Assignee)

Updated

17 years ago
Component: Form Manager → HTML Form Controls
You _do_ know that Mozilla has a form manager that allows remembering and
restoring form input values, right?
(Assignee)

Comment 2

17 years ago
Autocomplete has to do with trying to guess what the user is typing based on 
things that he has typed previously.  It gets called into play automatically 
without any explicit action on the part of the user.  From manager as it is 
currently implemented has to do with allowing the user to explicitly put values 
into his "wallet" and then explicitly prefill new forms using his "wallet" data.
(Reporter)

Comment 3

17 years ago
In response to Boris Zbarsky's comment:

Yes, I know about the Prefill Form function.  However it doesn't do what I have
in mind.  This is what I mean: if I type "Moz" in one of the form fields,
Mozilla will automatically append "illa" to what I typed to give "Mozilla."  I
didn't mean to imply that this should replace the Prefill Form function (in
fact, IE 5 for the Mac has both functions, but without the dynamic autocomplete
list generation, while IE 5.5 for Windows lacks the Prefill Forms function).

Comment 4

17 years ago

*** This bug has been marked as a duplicate of 60861 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 5

17 years ago
Verified Duplicate
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.