If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Autocompletion for form <input> fields like IE, Konqueror, Safari, Firefox

RESOLVED WORKSFORME

Status

()

Toolkit
Form Manager
P3
enhancement
RESOLVED WORKSFORME
17 years ago
6 years ago

People

(Reporter: Steve Chapel, Unassigned)

Tracking

({helpwanted})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
The Internet Explorer feature I miss most in Mozilla is autocompletion for form
<input> fields. IE keeps a history of what you type into each "name" of input
field and uses that history for autocompletion whenever you type into a form
input field with that same name. For example, after I type my address into one
input field named "address", the next time I enter text into a field named
"address", I just type the first character of my address, then press the down
arrow key and Enter to select the address I previously typed. This feature saves
much time when I fill out long forms that include my name, address, phone
number, fax number, email, etc.
Mozilla's form manager does something very similar...  try going to "Preferences
-> Advanced -> Forms" selecting "View Saved Data", and then adding some fields
and adding values for those fields.  Then any time you go to a form, you can
right-click on the page and select "Prefill Form" and Mozilla will fill in the
information you have previously input.

There is also a way for Mozilla to automatically capture data from forms you
fill out, and unless you have turned it off (in "Preferences -> Advanced ->
Forms") you should already have a bunch of field-value pairs stored.

This is not exactly the same system as IE's, so you may want to keep this bug
open after trying it.  But then again, you may not.  :)

Changing component to Autofill, since that is the component responsible for the
workings of the form manager.
Assignee: rods → morse
Component: Form Submission → Autofill
QA Contact: vladimire → tpreston

Comment 2

17 years ago
Boris is right -- form manager is our answer to the IE feature that you 
described.  My feeling when I designed form manager was that it would be better 
to click once to fill out an entire form than having to click on each field that 
you fill out.

Of course an advantage of the IE method is that the capturing is automatic -- 
you don't have to click at all for that to happen.  But I fear that that could 
be a security/privacy violation which could hurt Microsoft someday.  In 
particular, if this is a shared machine, someone using the machine later can get 
to see the personal information that you entered into various fields.  In our 
implementation, the saving is done only if you request it and of course you 
won't request it if you know you are on a shared machine.

For these reasons I am marking this report as WONT-FIX.

(BTW, in the recent builds we do the formfill not just by testing the "name" 
attribute of the <input> tag, but also by testing some of the on-screen text 
that precedes the field.  This makes our hit rate much higher.  Note this 
was implemented after the Netscape6 release.)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WONTFIX
Copying self. I don't think we want to reject this idea so quickly. IE's UI is
transparent and very efficient. I'm going to read the comments in 48860 before
commenting further however.

Updated

17 years ago
Blocks: 48860

Comment 4

17 years ago
I agree that we shouldn't close this up so fast.  Steve, being able to prefill 
the entire form at once is great, and that should still certainly be an 
option.  But I think this is a very useful feature in IE.  Actually, I somewhat 
considered this a prerequisite for fixing bug 48982 when I filed it.
REOPENing. I really like the way IE5 gives autocompletition for the form 
elements on the Bugzilla Query form and is one of the main reasons that I
occasionally use WinIE5 for doing Bugzilla queries.

Our form completion is great for things like personal details, but I only rarely
enter personal details on the web. Much more often I enter a variation on 
previous entries, for example similar lists of keywords on bugs or many 
different strings in a search engine. I find it useful to be able to browse my
previous entries.
Status: RESOLVED → UNCONFIRMED
Keywords: mozilla1.2
Resolution: WONTFIX → ---

Comment 6

17 years ago
Confirming: this is a valid RFE. Helpwanted.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: helpwanted, mozilla1.0
Summary: [RFE] Autocompletion for form <input> fields → [RFE] Autocompletion for form <input> fields like IE5

Updated

17 years ago
Status: NEW → ASSIGNED
Whiteboard: [z]
Target Milestone: --- → Future

Comment 7

17 years ago
Also, perhaps adding `Auto-Fill Entire Form' (after a separator) to the bottom of 
the auto-complete menu would provide a more obvious UI for filling in the whole 
form than the item in the Edit menu would. It would certainly be a much more 
convenient and unobtrusive method of informing the user whether a given form was 
autofillable or not.
Netscape nav triage team: based on Steve Morse's pre-triage recommendation, this 
is not a beta stopper.
Keywords: nsbeta1-

Comment 9

17 years ago
.
Assignee: morse → nobody
Status: ASSIGNED → NEW
Whiteboard: [z]

Comment 10

16 years ago
I agree that the auto completion of IE is a *really* nice feature which is much
more handy than Mozilla's current solution. While Mozilla's form manager may be
more sophisticated, IE is much more convenient for every day use. I suggest,
that two concepts should be combined. IE's weakness is that you have less
control over the collected data. Mozilla should have an input collect option
which activates an IE like behaviour. But Mozilla should also keep the form
manager concept as it stands right now. This would give the user the ability to
have complete control over his data. 

For example, I have an entry <name> on the web site "mozilla.org", if data
collection is activated Mozilla should rememver my entry and give me the
possiblity to

- use <name> for all sites
- use <name> only on "mozilla.org" or other sites I define
- never collect anything from "mozilla.org"

I realize that this means a lot of work, but IMO this would be a perfect
solution. It would allow an IE like behaviour if all sites are allowed to be
collected from, and it would also allow very strict regulations as it is
possible right now with the form manager.

The user should also be able to chose from different autocompletion behaviours,
i.e. doubleclick vs. IE autocompletion. 

Comment 11

16 years ago
*** Bug 101351 has been marked as a duplicate of this bug. ***

Comment 12

16 years ago
I am ODP editor and it is quite useful to manually complete the windows to add a
new URL. Many times the first part of the new URL is similar from a previous
address. And with Form Manager is impossible.

Comment 13

16 years ago
adding self to cc list

Updated

16 years ago
Blocks: 30378

Updated

16 years ago
No longer blocks: 30378
*** Bug 143930 has been marked as a duplicate of this bug. ***

Comment 15

16 years ago
*** Bug 152802 has been marked as a duplicate of this bug. ***

Comment 16

15 years ago
Dan, this is the bug I was talking about the other day. I was pretty sure that
there weren't "mozilla" people objecting to the IE method. In comment 2 morse
says "My feeling when I designed form manager was that it would be better 
to click once to fill out an entire form than having to click on each field that 
you fill out." He wontfixed and then assigned the bug to nobody. It seems to me
that it was morse that killed it and not "mozilla" people. Perhaps we can get
this assigned to someone and try to move forward with an implementation that is
more discoverable, more like IE.

Comment 17

15 years ago
See the following bug reports:

   bug 48982: double clicking in text field should autofill that field
   bug 63320: bring up a list if more than one possible choice to autofill

Comment 18

15 years ago
*** Bug 158949 has been marked as a duplicate of this bug. ***
*** Bug 162581 has been marked as a duplicate of this bug. ***

Comment 20

15 years ago
*** Bug 162574 has been marked as a duplicate of this bug. ***

Comment 21

15 years ago
I'm going to have to take side with people who support this.  I do find it to 
be useful also!  I'm going to vote for this too.

I'm not saying that IE is better than Moz.  That's not the point here.  I'm 
saying that it is far more useful to have the autocompletion form.  I have been 
using it alot.  I also use the similar feature in Moz as well.  In hte long 
run, I found that autocompletion make an nice addition to Moz.  Althought it 
doesn't hurt to have it as an option in the Preference setting.  If no one like 
it then he or she can turn it off.  It's that simple!

What does RFE stand for?

Comment 22

15 years ago
RFE = Request For Enhancement

Comment 23

15 years ago
Options are good! If Mozilla has some of the things that people like from IE
(plus great new stuff like tabs) this will make _Mozilla_ better. Please don't
anyone discount a feature's usefulness just because it's in IE! Keep your eyes
on the prize - making Mozilla the Best of Breed Browser.

To those who say "Forms Manager is our answer" - no. It is _an_ answer but an
incomplete one.  I like being aable to fill in an entire form with one menu
selection; don't get me wrong. But being able to type my full address or my
spouse's name by pressing One Key is VERY USEFUL TOO.

RFE = Request For Enhancement
I met with many ppl asking for this. I told them about Form Manager... it's of
course not the same. Any chance for TM Mozilla 1.2?
Blocks: 164421
Joe, this bug's for you, I think :)

Comment 26

15 years ago
Phoenix already has most of the things we need. Will we see a move to that 
solution?
Keywords: mozilla1.0
Summary: [RFE] Autocompletion for form <input> fields like IE5 → Autocompletion for form <input> fields like IE5

Comment 27

15 years ago
Just tried out Phoenix 0.2 and they have exactly what this bug is about. So much
better like the form manager that exists now. 

Any chance it will be implemented in Mozilla?

Comment 28

15 years ago
The Phoenix autocomplete is perfect, I think Mozilla should get it.

Comment 29

15 years ago
*** Bug 179294 has been marked as a duplicate of this bug. ***
*** Bug 183970 has been marked as a duplicate of this bug. ***

Comment 31

15 years ago
I heared many times people complaining Mozilla/NN does not have this feature and
this is stopping them from moving to Mozilla/NN. If Phoenix have this feature so
it could be fast(?) ported to mozilla...

Nominating for nsbeta, changing to mozilla1.3.
Keywords: mozilla1.2 → mozilla1.3, nsbeta1
I see no chances for this to go into 1.3beta. There is no standalone patch here
for this. Meaby 1.4alpha? But first, owner of bug should interest in it...

Comment 33

15 years ago
This bug is assigned to nobody@mozilla.org... Who can do this work from
developers, who can be the bug's owner?
well a good guess might be the default assignee for this component, dveditz, but
given that he's already cc'd here I would think that the chances that he works
on this are pretty low.

Comment 35

15 years ago
Mozillazine refered to this articel, talking about 10 reasons why 
Phoenix is better then Mozilla:
http://www.vbrad.com/pf.asp?p=articles/art_phoenix.htm

Point 10 is:
> # Forms intellisense, a la IE.
> * This feature may have been backported to Mozilla, 
>   though I haven't seen it yet.

Does somebody know if this has happend?

Comment 36

15 years ago
Sorry for asking: Is somebody thinking about working on it? 
I guess Autocompletion is *really* necessary.
In future some Linux/KDE users will change to Konqueror because of this feature.
(Could somebody change summary to ...like *Konqueror*, IE...)
   	
Any chance to start work with this bug? Anyone is interested in?

I'm removing mozilla1.3 from keywords, and updating Summary.
Keywords: mozilla1.3
Summary: Autocompletion for form <input> fields like IE5 → Autocompletion for form <input> fields like IE, Konqueror, Safari

Updated

15 years ago
Summary: Autocompletion for form <input> fields like IE, Konqueror, Safari → Autocompletion for form <input> fields like IE, Konqueror, Safari, Phoenix

Comment 38

15 years ago
adt: nsbeta1-
Keywords: nsbeta1 → nsbeta1-
*** Bug 210430 has been marked as a duplicate of this bug. ***
*** Bug 220608 has been marked as a duplicate of this bug. ***

Comment 41

14 years ago
This Phoenix/Firebird have the Autocompletion features when it get built.  The 
Seamonkey build is moving to Mozilla Browser (Firebird build) soon.  So, I 
don't see why should this bug continue because there is no valid comments or 
descriptions reflecting this.

Another thing, this bug can easily be fixed with a prefix option such as 
--enable-autocomplete or --disable-autocomplete, which isn't a difficult thing 
to do or an XPI or something.

Comment 42

14 years ago
FYI - I'm not familiar with where did the AutoCompletion come from or if it 
reside in the CVS or is an extension or something.  A clarification of where it 
come from would be nice.

Comment 43

14 years ago
ZookQValem@yahoo.com: you're mistaken. seamonkey was seamonkey. is seamonkey.
seamonkey will be seamonkey. i've even heard rumors that seamonkey is not likely
to go away anytime soon. please leave technical bugs to developers.

Comment 44

14 years ago
Okay!  I'll respect your comment and keep fixing other bugs since this is only 
an RFE.

Updated

14 years ago
Blocks: 163993

Updated

14 years ago
Summary: Autocompletion for form <input> fields like IE, Konqueror, Safari, Phoenix → Autocompletion for form <input> fields like IE, Konqueror, Safari, Firebird
Summary: Autocompletion for form <input> fields like IE, Konqueror, Safari, Firebird → Autocompletion for form <input> fields like IE, Konqueror, Safari, Firefox

Comment 45

14 years ago
(In reply to comment #43)
> i've even heard rumors that seamonkey is not likely to go away anytime soon. 

The updated roadmap has confirmed this rumor: http://www.mozilla.org/roadmap.html

Prog.

Updated

13 years ago
Flags: blocking1.8a4?

Updated

13 years ago
Flags: blocking1.8a4? → blocking1.8a4-

Comment 46

13 years ago
*** Bug 274913 has been marked as a duplicate of this bug. ***

Updated

13 years ago
No longer blocks: 163993

Comment 47

12 years ago
Just to be clear, I think this is a real PIA, ever since switching to MOZ, real early, many years ago now.  And now here we are in firefox 1.5, and still no decent autocomplete.

Just to be clear, what we want here is not to figure out what fields are what.  This is for all those fields where it can't figure it out, and now, I have to fully type in my address, "819 reallLong street name St.", over and over, often many times in the same day.  True, if I ever go back to those pages, it will auto fill for me.  But big whoopie.

I'd give anything for a simple history mechanism, for all autofill data, and a "dynamic abbrev mode, from emacs".  Where I just type in "81" in a random text entry field, and it pops up to offer finishing "9 reallyLong street....".

This is pretty much the way the address bar works now.

Please, this is a really poor way to do forms.  I for one, don't like filling a whole page, because it may have fields out of sight, off page, that get filled without my knowing or intending it.  I always go field by field, and double click, and hope that it will complete, or offer a list.  And then type the whole thing, when it does not.

A simple history with dynamic substitution, or a quick pop up list, would be SUCH a HUGE win.

Thanks,
Don
(In reply to comment #47)
> Just to be clear, I think this is a real PIA, ever since switching to MOZ, real

(...)

Please, do NOT waste our time, resources, do NOT lower signal/buzz ratio by posts like this. Please, read the Bugzilla FAQ, and look around. The bug is owned by nobody, means that noone is working on it. If you're willing, Mozilla is accepting patches. If you don't have coding skills, you can always set a bounty. Do not elaborate in Bugzilla about your requests anymore please.
*** Bug 360515 has been marked as a duplicate of this bug. ***
Filter on "Nobody_NScomTLD_20080620"
QA Contact: tpreston → form-manager
Basically exists now as described.
Status: NEW → RESOLVED
Last Resolved: 17 years ago9 years ago
Resolution: --- → WORKSFORME
Component: Form Manager → Form Manager
Flags: blocking1.8a4-
Product: Core → Toolkit
QA Contact: form-manager → form.manager
Target Milestone: Future → ---
Version: Trunk → unspecified
You need to log in before you can comment on or make changes to this bug.