Closed Bug 1013560 Opened 6 years ago Closed 6 years ago

mach should recommend the test runner when the wrong one is used

Categories

(Firefox Build System :: Mach Core, enhancement)

enhancement
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 920193

People

(Reporter: jaws, Unassigned)

Details

STR:
Run the following command:
`mach mochitest-plain toolkit/content/tests/widgets/test_menubar.xul`

Actual results:
No tests could be found in the path specified. Please specify a path that is a test file or is a directory containing tests.

Expected results:
The requested test is not a `mochitest-plain` test. It needs to be run with `mochitest-chrome`. Auto-running the test with `mochitest-chrome` in:
5 seconds...
4 seconds...
3 seconds...
2 seconds...
1 second...
[Go!]

Eventually we could disable the warning/delay, but if someone chooses to run a directory of tests, switching test runners may exclude/include the wrong tests.
There's an existing bug on this, I just can't find it right now. (It even has a WIP patch!)
Bug 920193 exists but I don't see a patch.

I don't think that we should auto-run another testsuite if you explicitly call mochitest-plain, but we should do `mochitest test` which automagically runs the correct suite.

So I'm just going to dup this, even though it's not a strict dup, because I think it will be implemented as part of that bug.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 920193
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.