Closed Bug 1013696 Opened 7 years ago Closed 6 years ago

in-content preferences applications pane: remove double border from header row

Categories

(Firefox :: Preferences, defect)

defect
Not set
normal

Tracking

()

VERIFIED FIXED

People

(Reporter: soeren.hentzschel, Unassigned)

References

Details

(Whiteboard: [fixed by bug 1087618])

Attachments

(2 files)

Please remove the second border in the header row of the applications pane in the in-content preferences, see screenshot.
Blocks: 738796
It looks like an easy CSS fix. 

#typeColumn, #actionColumn {
  border-top: 0;
}

#typeColumn:-moz-locale-dir(ltr), #actionColumn:-moz-locale-dir(rtl) {
  border-left: 0;
  border-right: 0;
}

#actionColumn:-moz-locale-dir(ltr), #typeColumn:-moz-locale-dir(rtl) {
  border-right: 0;
}

Is this the correct approach?
Flags: needinfo?(jaws)
That looks like a band-aid to the real problem. We should find out why the extra border exists in the first place and remove it so that we don't need to turn it off from some other place in our CSS.

As a side note, while I agree that it would be nice to fix this bug, we should only have bugs that will legitimately stop us from shipping the in-content prefs marked as blocking bug 1014201.
Blocks: 718011
No longer blocks: ship-incontent-prefs
Flags: needinfo?(jaws)
Marking as NEW based on comment #2 ("We should find out why the extra border exists in the first place and remove it").
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Mac OS X → All
Attached image screenshot of new style
I think this bug can be closed since the new style has landed, there is no longer a double border.
Thanks Sören. Can you use mozregression to find which changeset fixed this? http://mozilla.github.io/mozregression/
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: needinfo?(cadeyrn)
Resolution: --- → FIXED
No more inbounds to bisect
Last good revision: a7d403088a16
First bad revision: f14dcd1c8c0b
Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=a7d403088a16&tochange=f14dcd1c8c0b

(in this case the "first bad revision" is the first good revision).

So I would say it was fixed by "bug 1087618 Part 1 : Introduce new tree style".
Flags: needinfo?(cadeyrn)
Depends on: 1087618
Whiteboard: [fixed by bug 1087618]
Verified fixed on Windows 7 64bit, Ubuntu 13.10 32bit and Mac OSX 10.9.5 using latest Nightly 39.0a1 (buildID: ) and latest Aurora 38.0a2 (buildID: 20150316004007).
Status: RESOLVED → VERIFIED
latest Nightly 39.0a1 (buildID: 20150317030206)
You need to log in before you can comment on or make changes to this bug.