[meta] Move preferences from a window/sheet to in-content

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
7 years ago
a year ago

People

(Reporter: jaws, Unassigned)

Tracking

(Depends on: 8 bugs, Blocks: 2 bugs, {meta})

Trunk
Points:
---

Firefox Tracking Flags

(firefox15 disabled)

Details

(Whiteboard: [tracking])

Attachments

(2 attachments)

This is a meta bug for the feature of moving preferences from a window/sheet to in-content.
---------------------------

As part of UX's goal to eliminate Firefox's separate management windows in favor of in-content designs, the Preferences window should be moved into the content area.

Such a move provides several benefits for users. First, it removes yet another easy-to-lose window. It means that changing preferences in Firefox can be an identical and easy experience across all devices, including tablet computers. It also means that more interactive portions of Preferences, such as about:permissions, can be integrated with the rest of preferences.

This feature falls primarily in the Experience category (from the "Discover, Experience, and Connect" vision statement.)

This project has two major components:
    Move Preferences into in-content pages
    Redesign Preferences such that their current usability problems are fixed and they integrate well within the content area 

Goals:
    Improve the design of Preferences
    Integrate the parts of Firefox that should be in Preferences (such as the Add-ons Manager)
    Move Preferences into the content area 

See these pages for mockups and designs of the new in-content preferences:
    1. http://blog.stephenhorlander.com/2010/06/in-content-ui-visual-unification/
    2. http://stephenhorlander.com/pages/incontent-ui-mockups/incontent-ui-mockups.html

Comment 1

7 years ago
Google is currently redesigning the in-content preferences in Chromium. It can be a great source of inspiration. See last chromium builds.I think it has already been implemented.
(In reply to GE3K0S from comment #1)
> Google is currently redesigning the in-content preferences in Chromium. It
> can be a great source of inspiration. See last chromium builds.I think it
> has already been implemented.

I can't find any mention of a new redesign, unless you mean the redesign that happened between Chrome 9 and Chrome 10?

Comment 3

7 years ago
(In reply to Blair McBride (:Unfocused) from comment #2)
> (In reply to GE3K0S from comment #1)
> > Google is currently redesigning the in-content preferences in Chromium. It
> > can be a great source of inspiration. See last chromium builds.I think it
> > has already been implemented.
> 
> I can't find any mention of a new redesign, unless you mean the redesign
> that happened between Chrome 9 and Chrome 10?

No it's a new redesign planned for Chrome 18 I guess. More on François Beaufort's Google+ page : https://plus.google.com/100132233764003563318/posts/e55rRtMnRgu

Updated

7 years ago
Depends on: 731866

Updated

7 years ago
Depends on: 733469

Updated

7 years ago
Depends on: 733473

Comment 4

7 years ago
Yeah, Google should redesign it, because Chrome's preferences tab is the most failed design of a UI that I've ever seen. Anybody who thinks that a tab instead of a preference window is easier has lost his marbles.
If this gets implemented it will be bye bye time for Firefox for me.
What idiots are managing Firefox these days that they think that copying disasters like this and trimming URL's from chrome is a good idea?
The good thing about Firefox is that there would be a pref to disable it. (Bug 735471)

Comment 6

7 years ago
Yeah, you're right, but these days I have to adjust more and more preferences after a new install of Firefox to at least get a usable browser. Up till the point it becomes to annoying and I decide to switch. Please remember, usability is more important then eye-candy. Even Firefox developers seem to forget this nowadays.
(In reply to joopbraak from comment #6)

This bug is not the right place for these discussions. Please see https://wiki.mozilla.org/In-content_preferences for more background on why this feature is being implemented. Further discussions should move to the dev.apps.firefox mailing list (https://lists.mozilla.org/listinfo/dev-apps-firefox).

Comment 9

7 years ago
I've tried it on the UX branch. Nice work ! But I can afford thinking the prefs should clearly be redesigned to have all of them on one page with all dialogs in-content (as Google Chrome). Maybe that's planned for the Australis redesign. 

The options tab should also have an icon.

Comment 10

7 years ago
Some other bugs : 
-"Applications" shows no applications
-"Advanced" shows nothing
-back/forward arrows work only sometimes
-There is a strange grey texture behind subcategory titles (like Passwords in Security)

Comment 11

7 years ago
I forgot : the old download preferences are still visible even with Javier Rueda patch to suppress them enabled.

Comment 12

7 years ago
The cookies management window is also broken.

Comment 13

7 years ago
I noticed that the bug with the back/forward arrows appears apparently only in private browsing mode.

Comment 14

7 years ago
Another inconsistency : when you click on options in the menu, it always open a new tab. When you click on the add-on manager, if the add-on tab is already open, you go directly to it.
Duplicate of this bug: 597164

Comment 16

7 years ago
I noticed a bug when cleaning history while using option. You can't go back. It's shouldn't be the default behaviour since options aren't part of the browsing history.
(In reply to Guillaume C. [:ge3k0s] from comment #16)
> I noticed a bug when cleaning history while using option. You can't go back.
> It's shouldn't be the default behaviour since options aren't part of the
> browsing history.

This has landed on mozilla-central now - please file new bugs for any issues you see, and mark them blocking this bug.

Comment 18

7 years ago
Kudos!
Well there is lil problem. In older implementation to switch between say General and Advanced , user can click the respected icon at the top of the dialog. However now to do so , one has to click back button , then see the submenu he/she has to go and click it again , this adds 1 more click and distracts from the motive IMO.

I have made a quick mockup to solve this problem , as we have done in the addon manager, i think following the same method will maintain the consistency too.

I know there are plans to bring breadcrumbs but even then the issue is not sorted, IMO Addon manager does the right job and we should follow it's implementation.

Comment 19

7 years ago
I don't like the current implementation of the settings in the tab with navigation through the pages. I need a navigation with tabs such as in about:addons. It's necessary to bring the interface to a single species.

Updated

7 years ago
Depends on: 753673
Depends on: 754120

Comment 20

7 years ago
Re comment 18: In short, one cannot jump from one options page to another, without first going back. So, it should just like the addons manager have the buttons always visible, (and the current one selected).

Comment 21

7 years ago
Extra click(+ distractions) to reach same sub menu with new implementation are making it so hard to use

In older implementation to switch between say General and Advanced, 
user can click the respected icon at the top of the dialog. However now to do so , one has to click back button , then see the sub-menu he/she has to go and click it again , this adds 1 more click and distracts from the motive IMHO.
one cannot jump from one options page to another, without first going back & this slows the user down.
it should just like the addons manager or the current in-window type where we have the buttons always visible together , (and the current one selected like we have it now).
This make the process just like it is in older versions(except in-content)

Comment 23

7 years ago
Re comment 18, comment 19, comment 20, comment 21, comment 22: Has anyone filed a bug to improve the navigation in the new in-content preferences? Possibly blocking bug 738796? (or this one)

Updated

7 years ago
Depends on: 754304
(In reply to Jon Rietveld from comment #23)
> Re comment 18, comment 19, comment 20, comment 21, comment 22: Has anyone
> filed a bug to improve the navigation in the new in-content preferences?
> Possibly blocking bug 738796? (or this one)

Yes. There is plan to redesign the interaction (including the navigation) of the in-content preferences, see bug 752719. The approach will be similar to the add-ons manager.
Depends on: 754398
Depends on: 754342
Depends on: 754521
status-firefox15: --- → disabled

Comment 25

7 years ago
What's the status of the Design Overhaul ?
(In reply to bogas04 from comment #25)
> What's the status of the Design Overhaul ?

See https://bugzilla.mozilla.org/show_bug.cgi?id=754344 for the current status.

Updated

7 years ago
Blocks: 752434

Updated

6 years ago
Depends on: 826840

Updated

6 years ago
No longer blocks: 752434
Depends on: 752434
Depends on: 881576

Updated

5 years ago
Depends on: 761566
Blocks: 950073
Whiteboard: [triage]
Whiteboard: [triage]
Whiteboard: [tracking]

Updated

5 years ago
Depends on: 989890

Updated

5 years ago
Depends on: 990973

Updated

5 years ago
Depends on: 994265
No longer depends on: 761566
No longer depends on: 754120
No longer blocks: 950073
Depends on: 1000625
Depends on: 1012223

Updated

5 years ago
Depends on: 1012368

Updated

5 years ago
Blocks: 1012402
Depends on: 1012410
Depends on: 1012399

Updated

5 years ago
Depends on: 1012575
Depends on: 1012701
Depends on: 1012767
Depends on: 1012772

Updated

5 years ago
Depends on: 1013084

Updated

5 years ago
Depends on: 1013912
Depends on: 1014758
Depends on: 1016300

Updated

5 years ago
Depends on: 1017964
Depends on: 1018549

Updated

5 years ago
Depends on: 1019344
Depends on: 1020217
Depends on: 1027652

Updated

4 years ago
Depends on: 1097393

Updated

4 years ago
Depends on: 1105734
Depends on: 1113100

Updated

4 years ago
No longer depends on: 1113100
Depends on: 1113567
Depends on: 1113581

Updated

4 years ago
No longer depends on: 1022581
Depends on: 1113629

Updated

4 years ago
Depends on: 1120189
Depends on: 919526

Updated

4 years ago
Depends on: 1120967

Comment 27

4 years ago
As a localizer, I was a bit worried about conflicting access keys (with the main menu bar) by the moving prefs, but with bug 349943 in mind I recall they will use a different key modifier. Are we sure this new combo will cause no trouble and be clear to users (as it wasn't to me when filing that bug)? Not that I'd like to see them working the same way…

Updated

4 years ago
Depends on: 1130007

Updated

4 years ago
Depends on: 1129947

Updated

4 years ago
Depends on: 1005029

Updated

4 years ago
Depends on: 1127737

Updated

4 years ago
No longer depends on: 1064261

Updated

4 years ago
Depends on: 1044586

Updated

4 years ago
Blocks: 1145701

Updated

4 years ago
Depends on: 1160076

Updated

4 years ago
Depends on: 1165676

Updated

4 years ago
Depends on: 1165437

Updated

4 years ago
Depends on: 1166213

Updated

4 years ago
No longer depends on: 1165676

Comment 28

4 years ago
Shouldn't the add-ons settings be accessable from the options tab? (See chrome)

Updated

4 years ago
Depends on: 1169704

Updated

4 years ago
No longer blocks: 1145701

Updated

4 years ago
Depends on: 1180278

Updated

4 years ago
Depends on: 1078705

Updated

4 years ago
Depends on: 1195822

Updated

3 years ago
Depends on: 1166259

Updated

3 years ago
Depends on: 1243002

Updated

3 years ago
Depends on: 1247404

Updated

3 years ago
No longer depends on: 1166259

Updated

3 years ago
No longer depends on: 1247404

Updated

3 years ago
No longer depends on: 1243002

Updated

3 years ago
No longer depends on: 1166213

Updated

3 years ago
No longer blocks: 216931

Updated

3 years ago
Blocks: 1271779

Updated

3 years ago
No longer depends on: 752719
Remove the dependency on Bug 993361 because Bug 993361 is not about moving into in-content and is already being tracked by Bug 1271779.
No longer depends on: 993361

Updated

3 years ago
No longer depends on: 1037859

Updated

3 years ago
No longer depends on: 1044586

Updated

3 years ago
No longer depends on: 1113581
No longer blocks: 1271779

Updated

2 years ago
Depends on: 1327477

Updated

2 years ago
Depends on: 1339821

Updated

2 years ago
Depends on: 1393448

Updated

2 years ago
Depends on: 1402213
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.