Closed Bug 1013851 Opened 7 years ago Closed 7 years ago

Can't install app anymore: NS_BASE_STREAM_CLOSED from nsIBufferedOutputStream.writeFrom

Categories

(DevTools Graveyard :: WebIDE, defect, P1)

x86_64
All
defect

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: paul, Unassigned)

References

Details

When installing an app to the simulator, I get this exception:

[Exception... "Component returned failure code: 0x80470002 (NS_BASE_STREAM_CLOSED) [nsIBufferedOutputStream.writeFrom]"  nsresult: "0x80470002 (NS_BASE_STREAM_CLOSED)"  location: "JS frame :: resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/devtools/transport/stream-utils.js :: StreamCopier.prototype._copy :: line 104"  data: no]
Summary: Can't install app anymore → Can't install app anymore: NS_BASE_STREAM_CLOSED from nsIBufferedOutputStream.writeFrom
Priority: -- → P1
It's only happening with a device (Flame + FxOS central).
What about on other devices, like the Nexus 4 or Keon?  That message typically means the stream was closed early while bulk data was being copied, but it's hard to say why that happened without more investigation.

Does it happen every time you try to install on the Flame?
Flags: needinfo?(paul)
I tested installing a few apps (large and small) in the following configuration:

* Flame engineering build (2.0 / 20140521)
* Firefox Nightly (2014-05-21)

I did not see any issues.

Maybe some kind of issue that is now resolved?  Or do you have any special prefs set perhaps?  Let me know if you can still reproduce this.
Blocks: build-am2
Flags: needinfo?(paul)
Blocks: enable-webide
No longer blocks: build-am2
Also see bug 1020991.
Any guess if your device was in some kind of mixed-build state, like was the case in bug 1020991?
Flags: needinfo?(paul)
I'll try to reproduce this on Monday.
Flags: needinfo?(paul)
Can't reproduce anymore.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
Product: Firefox → DevTools
Product: DevTools → DevTools Graveyard
You need to log in before you can comment on or make changes to this bug.