Closed Bug 1014278 Opened 6 years ago Closed 6 years ago

[B2G][E-mail]'No mail in this Folder' text overlaps email in Local Drafts folder

Categories

(Firefox OS Graveyard :: Gaia::E-Mail, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:1.4+, b2g-v1.4 fixed, b2g-v2.0 fixed)

RESOLVED FIXED
2.0 S2 (23may)
blocking-b2g 1.4+
Tracking Status
b2g-v1.4 --- fixed
b2g-v2.0 --- fixed

People

(Reporter: astole, Assigned: jrburke)

References

Details

(Keywords: regression)

Attachments

(3 files)

Attached file logcat
When saving a local draft email a second time, the 'No mail in this Folder' text appears over the newly saved draft.

Repro Steps:
1) Update a Open_C to BuildID: 20140521040203
2) Sign into an email address and compose a new email
3) Select back and save to Local Drafts folder
4) Open the Local Drafts folder and select newly created email
5) Edit email and press back
6) Save to Local Drafts folder again when prompted

Actual:
'No mail in this Folder' text overlaps newly edited email draft

Expected:
There is no text that says 'No mail in this Folder'

2.0 Environmental Variables:
Device: Open_C 2.0 MOZ
BuildID: 20140521040203
Gaia: c462d9183d294a2d8ecc472f593ea8cfa15bc9de
Gecko: a6f36c31aa8f
Version: 32.0a1
Firmware Version: P821A10v1.0.0B03_LOG_DL

Repro frequency: 100%
See attached: Screenshot, logcat
Attached image Screenshot
Attaching screenshot and testing on 1.4 on Open_C and master on Buri
This issue also occurs on the latest 1.4.

1.4 Environmental Variables:
Device: Open_C 1.4 MOZ
BuildID: 20140521000202
Gaia: 93623f6435849cc9f54d9996e8e64828ac9091d1
Gecko: 12fe2b67a099
Version: 30.0
Firmware Version: P821A10v1.0.0B03_LOG_DL

This issue also occurs on Master on Buri

2.0 Environmental Variables:
Device: Buri 2.0 MOZ
BuildID: 20140521040203
Gaia: c462d9183d294a2d8ecc472f593ea8cfa15bc9de
Gecko: a6f36c31aa8f
Version: 32.0a1
Firmware Version: v1.2-device.cfg
Tricky bug 796474 regression.

The problem is that we synchronously hideEmptyLayout but we asynchronously showEmptyLayout:
https://github.com/mozilla-b2g/gaia/blob/master/apps/email/js/cards/message_list.js#L1147

The net result is that showEmptyLayout will beat hideEmptyLayout.

We either need a guard in our call to showEmptyLayout to ensure that the decision to show it is still correct or we need to make the hideEmptyLayout call above it also be async.  There may be other wrinkles that :jrburke will be more wise about, so assigning to him.

Requesting 1.4 blocker since that's how we like to roll on bug 796474 regressions.
Assignee: nobody → jrburke
Status: NEW → ASSIGNED
blocking-b2g: --- → 1.4?
Depends on: 796474
Attached file GitHub pull request
Use the more accurate headerCount to know if we should show the empty message, and then also check it in the async callback, to make sure it is still true.
Attachment #8426710 - Flags: review?(bugmail)
Target Milestone: --- → 2.0 S2 (23may)
Comment on attachment 8426710 [details] [review]
GitHub pull request

Good idea to use headerCount! Thanks on the super-fast turnaround! r=asuth
Attachment #8426710 - Flags: review?(bugmail) → review+
Merged in master:
https://github.com/mozilla-b2g/gaia/commit/46ade5a109315169bbf924bade92f0f1503e4102

from pull request:
https://github.com/mozilla-b2g/gaia/pull/19517
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
blocking-b2g: 1.4? → 1.4+
Blocks: 796474
No longer depends on: 796474
Keywords: regression
Duplicate of this bug: 1022502
You need to log in before you can comment on or make changes to this bug.