Closed Bug 1014591 Opened 6 years ago Closed 6 years ago

(vertical-homescreen) Replace app icons with the final assets

Categories

(Firefox OS Graveyard :: Gaia::Homescreen, defect)

x86
macOS
defect
Not set

Tracking

(feature-b2g:2.0, b2g-v2.0 fixed)

RESOLVED FIXED
2.0 S3 (6june)
feature-b2g 2.0
Tracking Status
b2g-v2.0 --- fixed

People

(Reporter: pla, Assigned: kgrandon)

References

Details

(Whiteboard: ux-tracking, visual design, visual-tracking, [ft:systemsfe],[p=2])

Attachments

(3 files, 1 obsolete file)

Send Kevin the updated assets for replacement into the build at the following 3-column sizes for the perfect crispness:

84, 126, 142, 189 (and maybe 284 for HD)

Also send 256 just in case.
feature-b2g: --- → 2.0
Duplicate of this bug: 1014959
Attached file FFOS2AppIcons-20140523.zip (obsolete) —
Hi Kevin,

Attached are the new set of App icons at the following sizes:

@1 > 84 (HVGA)
@1.5 > 126 (WVGA/FWVGA)
@2 > 142 (qHD) - this should actually be called @1.6875x but I'm going with the convention that was already established
@2.25 > 189 (720p)
@3.375 > 284 (full HD)


I've also attached a 256x256 generic size in case you need it.

Please flag me for uireview.  Thanks!
Flags: needinfo?(kgrandon)
Thanks. Icons for apps should probably just be in folders per app, and also labeled by their size, so icon_128.png, etc. I'll go ahead and move these into the proper locations though.
Flags: needinfo?(kgrandon)
Assignee: nobody → kgrandon
Status: NEW → ASSIGNED
Whiteboard: ux-tracking, visual design, visual-tracking, [ft:systemsfe] → ux-tracking, visual design, visual-tracking, [ft:systemsfe],[p=2]
Target Milestone: --- → 2.0 S3 (6june)
Attached file renameicons.js
I am not a sed master, but i can write a quick script to rename all of the icons in a format that I want :)
Attached file Github pull request
Work in progress
This is done, but does not yet resolve the "fuzzy" icon issue in the vertical homescreen. The problem that's causing that is likely a miss in our size selection pick. Let's solve that in bug 1014364.
Comment on attachment 8428199 [details] [review]
Github pull request

It seems like this is easier to get in as a single patch instead of smaller ones. Vivien - could you do a review for this cross-gaia change? Thanks!
Attachment #8428199 - Flags: review?(21)
I think you also need to fix a few places in the Gaia were the size 60 is hardcoded ?

Like apps/system/js/app_window.js, or the old homescreen code.
Flags: needinfo?(kgrandon)
Comment on attachment 8428199 [details] [review]
Github pull request

Ugh yeah.. seems like this will be more work than I was hoping :)

Let me run through the hard-coded places and will re-open this for review. Thanks!
Attachment #8428199 - Flags: review?(21)
Flags: needinfo?(kgrandon)
Hey Kevin,

Sorry to do this - I found a few icons I wanted to tweak after the weekend.  I made tweaks to the following icons and re-exported the entire set.

> Settings
> Cost Control (Usage)
> Gallery
> Wallpaper App (not sure if this is still used?)

Sorry for the inconvenience.

Peter
Attachment #8428173 - Attachment is obsolete: true
Depends on: 1017208
Comment on attachment 8428199 [details] [review]
Github pull request

Hey Vivien - looks like we are pretty smart and don't use a hardcoded 60 value in the UI. See: https://github.com/mozilla-b2g/gaia/blob/master/apps/system/js/app_window.js#L1429

I would like to open this up for review, but I don't think we should land until we turn on the homescreen by default. Thanks!
Attachment #8428199 - Flags: review?(21)
Blocks: 1017733
Duplicate of this bug: 1017733
No longer depends on: 1017208
Landed: https://github.com/mozilla-b2g/gaia/commit/af744242d331fd2da873e3db8a86ab9ae9ab511a
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Mass modify - set status-b2g-v2.0 fixed for fixed bugs under vertical homescreen dependency tree.
You need to log in before you can comment on or make changes to this bug.