Closed Bug 1015085 Opened 7 years ago Closed 7 years ago

Loop server - Implement "User Calls Other User by ID" flow

Categories

(Hello (Loop) :: Server, defect, P1)

defect

Tracking

(Not tracked)

VERIFIED FIXED
mozilla33

People

(Reporter: RT, Assigned: ferjm)

References

Details

(Whiteboard: ft:Loop)

Attachments

(1 file)

If a contact holds multiple identities (e-mail addresses and phone numbers), these multiple identities are sent to the server which will notify identities which are registered and connected of an incoming call request.
If multiple identities are registered they are all notified though push notifications and the first identity which answers or declines causes all other engaged identities to have their incoming calls cancelled (first who answers or declines wins).
Blocks: 972017
Concerns related to load issues when sending a long list of identities should be addressed by the fact that the server will only try to reach connected registered identities and will discard others.
No longer blocks: 972017
This is looping on the given list and trying to call them in turn, if the simple push url exists.
We want to have an API exposed to do a POST on /calls.


Client would need to pass in the body the list of users she want to reach. It will get in return a caller token, in the same way described in the call to /call/{token}
Assignee: nobody → ferjmoreno
Summary: Loop server - handle multiple identities in a call invitation → Loop server - Implement "User Calls Other User by ID" flow
OS: Linux → All
Hardware: x86 → All
Blocks: 1025894
Priority: P3 → P1
Whiteboard: ft:Loop
Verified in code and through unit tests.
Status: RESOLVED → VERIFIED
Duplicate of this bug: 1027081
You need to log in before you can comment on or make changes to this bug.