Closed Bug 1015484 Opened 6 years ago Closed 6 years ago

[B2G][Homescreen]Repositioning final icons from one group to another group leaves the divider and an empty group section on vertical homescreen

Categories

(Firefox OS Graveyard :: Gaia::Homescreen, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

VERIFIED WORKSFORME
2.0 S3 (6june)

People

(Reporter: mclemmons, Assigned: kgrandon)

References

Details

(Whiteboard: [systemsfe])

Attachments

(2 files)

User relocates the final app icons from the last group and places them in the second group. Once the final icon is placed, the divider between group two and three remains and the space between the groups. 

Prerequisites:
1. Have at least three groups with icons

Repro Steps:
1) Update a Flame to BuildID: 20140523073020
2) Move all icons from the third group to the second group
3) Observe the device
4)
 

Actual:
Second group is populated correctly but the third group and the dividers remain even though there are no icons within the section

Expected:
Second group is populated correctly but the dividers disappear

2.0 Environmental Variables:
Device: Flame 2.0 MOZ
BuildID: 20140523073020
Gaia: e83bd91c8f7c66f95d55cb741299e12bc8f7b429
Gecko: 681c5668d881
Version: 32.0a1
Firmware Version: v10G-2


Repro frequency: 3/3

See attached: (screenshot, logcat)
Unable to reproduce issue on Open C following STR from Comment 0. 

2.0 Environmental Variables:
Device: Open_C 2.0
BuildID: 20140523073020
Gaia: e83bd91c8f7c66f95d55cb741299e12bc8f7b429
Gecko: 681c5668d881
Version: 32.0a1
Firmware Version: P821A10V1.0.0B06_LOG_DL
Summary: [B2G][Homescreen]Repositioning final icons from one group to another group leaves the divider and an empty group section → [B2G][Homescreen]Repositioning final icons from one group to another group leaves the divider and an empty group section on vertical homescreen
Whiteboard: systemfe → [systemsfe]
No longer blocks: vertical-homescreen
Blocks: 1017360
Just taking these bugs so no one else does as I'm doing a pretty big refactoring of how this works in bug 1017360.
Assignee: nobody → kgrandon
Status: NEW → ASSIGNED
Target Milestone: --- → 2.0 S3 (6june)
I have not been able to reproduce this, but we did a lot of refactoring of dragdrop in bug 1017360. It's unlikely that this can still happen. Please reopen with a video if you are still able to reproduce this. Thanks!
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.