Closed Bug 1015492 Opened 6 years ago Closed 6 years ago

[B2G][Flame][Vertical Homescreen] Homescreen scroll descriptions lack padding and are very close to screen edge

Categories

(Firefox OS Graveyard :: Gaia::Settings, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v2.0 affected)

RESOLVED DUPLICATE of bug 985475
Tracking Status
b2g-v2.0 --- affected

People

(Reporter: rpribble, Unassigned)

Details

(Whiteboard: systemfe)

Attachments

(1 file)

Attached image Screenshot.png
Description:
The home screen scroll orientation descriptions in the settings lack padding or are misaligned.  They appear to be touching the left side of the screen.

Repro Steps:
1) Updated Flame to BuildID: 20140523073020
2) Tap the settings icon
3) Tap the home screen option
4) Check description text under both home screen and vertical options

Actual:
Descriptions are very close to the left edge of the screen.

Expected:
Descriptions appear properly aligned with the rest of the page.

Environmental Variables:
Device: Flame v2.0 MOZ ril
BuildID: 20140523073020
Gaia: e83bd91c8f7c66f95d55cb741299e12bc8f7b429
Gecko: 681c5668d881
Version: 32.0a1
Firmware Version: v10G-2

Notes:

Repro frequency: 100%
See attached: Screenshot

-------------------------------------------------

This issue also occurs on the Open_C v2.0 engineering build.

Open C 2.0 Eng
2.0 Environmental Variables:
Device: Open_C v2.0 MOZ ril
BuildID: 20140523073020
Gaia: e83bd91c8f7c66f95d55cb741299e12bc8f7b429
Gecko: 681c5668d881
Version: 32.0a1
Firmware Version: P821A10V1.0.0B06_LOG_DL
Sorry, this menu will not be accessible to the final user. The vertical homescreen will be the one and only homescreen on 2.0.

No need to fix this screen.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WONTFIX
(In reply to Johan Lorenzo [:jlorenzo] from comment #1)
> Sorry, this menu will not be accessible to the final user. The vertical
> homescreen will be the one and only homescreen on 2.0.
> 
> No need to fix this screen.

No that's not right. This is part of the replaceable homescreen UX, which will be used in 2.1.
Status: RESOLVED → REOPENED
Component: Gaia::Homescreen → Gaia::Settings
Resolution: WONTFIX → ---
I would like to dupe this against bug 985475. That bug defines the scope for the feature and will track the implementation to match to the UX spec. This feature is also not coming in 2.0, but 2.1.
No longer blocks: vertical-homescreen, 1015336
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 985475
You need to log in before you can comment on or make changes to this bug.