Closed Bug 1015495 Opened 6 years ago Closed 6 years ago

[B2G][Homescreen]Moving icon along side edges to a group positions icon awkwardly between groups on vertical homescreen

Categories

(Firefox OS Graveyard :: Gaia::Homescreen, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v2.0 fixed)

VERIFIED FIXED
2.0 S3 (6june)
Tracking Status
b2g-v2.0 --- fixed

People

(Reporter: mclemmons, Assigned: kgrandon)

References

Details

(Whiteboard: [systemsfe])

Attachments

(2 files)

User long presses icon and slides it along the left or right margin of the device screen before releasing. The icon displays 75% in one group and 25% in another to display awkwardly.

Prerequisites:
1. Have at least three groups with icons

Repro Steps:
1) Update a Flame to BuildID: 20140523073020
2) Long press icon and slide it along the far edges in downward motion 
3) Release icon when in its own group
4) Observe the device

Actual:
Icon displays with parts in two groups – out of alignment

Expected:
Icon displays in one group or the other – in alignment

2.0 Environmental Variables:
Device: Flame 2.0 MOZ
BuildID: 20140523073020
Gaia: e83bd91c8f7c66f95d55cb741299e12bc8f7b429
Gecko: 681c5668d881
Version: 32.0a1
Firmware Version: v10G-2

Notes: See attached - Screenshot, logcat
Repro - 3/3 100%
Unable to reproduce this issue on Open C Engineering following the STR from Comment 0. 

2.0 Environmental Variables:
Device: Open_C 2.0
BuildID: 20140523073020
Gaia: e83bd91c8f7c66f95d55cb741299e12bc8f7b429
Gecko: 681c5668d881
Version: 32.0a1
Firmware Version: P821A10V1.0.0B06_LOG_DL
Whiteboard: systemfe → [systemsfe]
No longer blocks: vertical-homescreen
Blocks: 1017360
Just taking these bugs so no one else does as I'm doing a pretty big refactoring of how this works in bug 1017360.
Assignee: nobody → kgrandon
Status: NEW → ASSIGNED
Target Milestone: --- → 2.0 S3 (6june)
Bug 1017360 has now landed a lot of dragdrop improvements, and this was one of them. You should not be able to drop in a strange location like this anymore.
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
Mass modify - set status-b2g-v2.0 fixed for fixed bugs under vertical homescreen dependency tree.
You need to log in before you can comment on or make changes to this bug.