[appmgr v2] Missing icons

VERIFIED FIXED in Firefox 33

Status

VERIFIED FIXED
4 years ago
3 months ago

People

(Reporter: paul, Assigned: paul)

Tracking

Trunk
Firefox 33
x86_64
All
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 4 obsolete attachments)

(Assignee)

Description

4 years ago
Created attachment 8429968 [details]
icons.png

We need more icons:
- laptop icons for local connection (the same way we have a phone icon)
- remote icons for remote connection (some sort of wire)
- info icon (like screenshot, a question mark maybe)

Attached, the current icons.
(Assignee)

Comment 1

4 years ago
Note to myself: don't use the device icon in the runtime panel button.
(Assignee)

Updated

4 years ago
Blocks: 1007057
No longer blocks: 1007059
(Assignee)

Updated

4 years ago
Blocks: 1007059
(Assignee)

Updated

4 years ago
No longer blocks: 1007057
Created attachment 8434191 [details]
v2-icons

New icons as requested.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Comment 3

4 years ago
Sorry, I realize that my instructions were not clear at all:

(In reply to Paul Rouget [:paul] (slow to respond. Ping me on IRC) from comment #0)
> We need more icons:
> - laptop icons for local connection (the same way we have a phone icon)

I meant the small phone icon, not the big one.

> - remote icons for remote connection (some sort of wire)

Same, small.

> - info icon (like screenshot, a question mark maybe)

This one is good.

And actually, thinking about it, we got a couple of things wrong in the first icons.

So here is exactly what needs to be done from attachment 8434191 [details]:
- Remove the "download" icons (icons 3x1, 3x2, 3x3)
- Remove the "big phone" icons (icons 5x1, 5x2, 5x3)
- shrink laptop icons (icons 10x1, 10x2) and remove its active state (10x3)
- shrink wire icons (icons 11x1, 11x2) and remove its active state (11x3)
- rocket icon needs to have a blue version (8x2)
- small phone icon needs to have a blue version (7x2)

To summarize:
- only 4 big icons: play / stop / pause / down-arrow. Each with 3 states
- 11 small icons: "+", folder, globe, phone, rocket, lock, camera, "v", "?", laptop, wire
- 4 of these small icons need a blue version: phone, wire, rocket, laptop 

I hope it's clear enough. If you have any question, please let me know.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 4

4 years ago
Darrin, we need your help here
Flags: needinfo?(dhenein)
Created attachment 8448162 [details]
v2-icons-2.1.png

Paul, let me know if this is better. I wasn't sure which icons needed to be the 'flat' style (the 11 in the center) or inset (the 3 big ones, the small laptop and usb). Let me know if some are not how they should be.

Flat is for use in the dropdown panels and inset is for use in the grey textured chrome.
Attachment #8434191 - Attachment is obsolete: true
Flags: needinfo?(dhenein)
(Assignee)

Comment 6

4 years ago
(In reply to Darrin Henein [:darrin] from comment #5)
> Created attachment 8448162 [details]
> v2-icons-2.1.png
> 
> Paul, let me know if this is better. I wasn't sure which icons needed to be
> the 'flat' style (the 11 in the center) or inset (the 3 big ones, the small
> laptop and usb). Let me know if some are not how they should be.
> 
> Flat is for use in the dropdown panels and inset is for use in the grey
> textured chrome.

Darrin, this is great.

All the big icons are perfect (the blue dropdown icon is not used though).

Some of the small icons don't have the same size as the other small icons. For example the "?" icon is bigger than the phone icon. It doesn't have the same bounding box.

Can you make sure all the icons fit in a 40x40 box, and they all centered in it?

You don't have the keep the original grid layout. It might actually be easier to draw the small icons in a 40x40 grid and keep the big ones in a 100x100 grid. Up to you.

If you have time, we also need a wifi icon (new feature), the same way we have a "USB cable" icon.
(Assignee)

Comment 7

4 years ago
Created attachment 8456100 [details] [diff] [review]
v1
Assignee: dhenein → paul
Attachment #8429968 - Attachment is obsolete: true
Attachment #8448162 - Attachment is obsolete: true
Status: REOPENED → ASSIGNED
(Assignee)

Comment 8

4 years ago
Created attachment 8456104 [details] [diff] [review]
v1

I've use Darrin's icons and changed the layout if the icon file.
Attachment #8456100 - Attachment is obsolete: true
Attachment #8456104 - Flags: review?(jryans)
(Assignee)

Updated

4 years ago
Duplicate of this bug: 1027773
(Assignee)

Updated

4 years ago
Blocks: 1037115
Comment on attachment 8456104 [details] [diff] [review]
v1

Review of attachment 8456104 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good!  Works correctly for WiFi devices too.
Attachment #8456104 - Flags: review?(jryans) → review+
(Assignee)

Comment 11

4 years ago
https://hg.mozilla.org/integration/fx-team/rev/cb01d0c61cca
Whiteboard: [fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/cb01d0c61cca
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 33
QA Whiteboard: [qa+]
Verified that the new icons are used - Firefox 33 beta 7 (available simulators and a Flame device); Win 7 64-bit, Ubuntu 12.10 32-bit and Mac OSX 10.8.5.
Status: RESOLVED → VERIFIED

Updated

3 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.