Closed Bug 10171 Opened 21 years ago Closed 19 years ago

[FEATURE] Automatically migrate all 4.x profiles

Categories

(Core Graveyard :: Profile: BackEnd, defect, P3)

All
Other
defect

Tracking

(Not tracked)

VERIFIED WONTFIX
Future

People

(Reporter: selmer, Assigned: ccarlen)

References

Details

To simplify the user experience, we've decided to automatically migrate if there
is exactly one profile during the -installer phase.  This way we can avoid
having the user see UI that only presents a single choice.  In the vast majority
of cases, this is really the right thing to do anyway.
Status: NEW → ASSIGNED
Target Milestone: M10
P3s aren't going to make it in M10.  Bulk moving to M11.
Blocks: 12696
Summary: Automatically migrate if only 1 profile → [FEATURE] Automatically migrate all 4.x profiles
Simplified again.  All migration will occur at install time.  We should
implement a space limit if we continue to do copying.  A meeting will be held
shortly to determine if the RTM product will continue to copy profiles or just
use them in-place.
*** Bug 10172 has been marked as a duplicate of this bug. ***
These bugs are not critical for beta 1, moving out.
No longer blocks: 12696
Steve,

Maybe we should change this to 'auto migrate 1 profile' now for the commercial
version and reference the other bugs that deal with the discussion - bug 18118
and bug 23090.  And mark fixed?

Grace
Grace, this bug is about the desire to just do all the migrations in one shot
without having to bother the user over it.  This may not be possible, so the bug
might get closed as invalid.  However, it is nothing like the migrate one
profile bugs since it intends to deal with all profiles.

The only thing that makes this bug feasible is if we get migrate-in-place to
work reliably and with high performance/low impact.

The thing that may kill this is the concept of migrating profiles that "belong"
to a user other than the one doing the install.  We haven't decided that yet.
Component: Profile Manager → Profile Manager BackEnd
Moving all Profile Manager bugs to new Profile Manager Backend component.
Profile Manager component to be deleted.
Target Milestone: M15 → M17
Moving this to M20.
Target Milestone: M17 → M20
Doing a mass reassign to Conrad Carlen.

Conrad is going address all current and upcoming profile manager issues. Please
do not hesitate to involve me in any of the issues.
Assignee: racham → ccarlen
Status: ASSIGNED → NEW
What are current thoughts on this? This one is very old. We now automatically
migrate if there is one profile and if there are more, ask the user which to
migrate. Seems sensible. If we were to migrate many up front without asking
first, it would increase disk space needs and initial startup time.
Setting to future due to lack of response to my last question.
Target Milestone: --- → Future
WONTFIX might be more appropriate.  I don't think this is given serious
consideration anymore.
I agree.
Status: NEW → RESOLVED
Closed: 19 years ago
Resolution: --- → WONTFIX
verify
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.